summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2009-03-05 21:13:28 +0000
committerSven Wegener <swegener@gentoo.org>2009-03-05 21:13:28 +0000
commit9f723373dc12a188fd5262cdd9baddb6cb574be5 (patch)
tree6573c0e65106ad6915c3616e5a199fd9605b28da /net-dns
parentversion bump (diff)
downloadgentoo-2-9f723373dc12a188fd5262cdd9baddb6cb574be5.tar.gz
gentoo-2-9f723373dc12a188fd5262cdd9baddb6cb574be5.tar.bz2
gentoo-2-9f723373dc12a188fd5262cdd9baddb6cb574be5.zip
Add gfbsd patches, bug #184008. Security bump, bug #260971.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/avahi/ChangeLog12
-rw-r--r--net-dns/avahi/avahi-0.6.24-r1.ebuild214
-rw-r--r--net-dns/avahi/avahi-0.6.24.ebuild4
-rw-r--r--net-dns/avahi/files/avahi-0.6.24-CVE-2009-0758.patch22
-rw-r--r--net-dns/avahi/files/avahi-0.6.24-cmsg_space.patch11
-rw-r--r--net-dns/avahi/files/avahi-0.6.24-libintl.patch11
6 files changed, 270 insertions, 4 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index a9f5b70a03a0..ac1af3f13bc4 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/avahi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.155 2008/12/22 18:51:28 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.156 2009/03/05 21:13:28 swegener Exp $
+
+*avahi-0.6.24-r1 (05 Mar 2009)
+
+ 05 Mar 2009; Sven Wegener <swegener@gentoo.org>
+ +files/avahi-0.6.24-CVE-2009-0758.patch,
+ +files/avahi-0.6.24-cmsg_space.patch, +files/avahi-0.6.24-libintl.patch,
+ +avahi-0.6.24-r1.ebuild:
+ Add gfbsd patches, bug #184008. Security bump, bug #260971.
22 Dec 2008; Raúl Porcel <armin76@gentoo.org> avahi-0.6.24.ebuild:
ia64/sparc stable wrt #250913
diff --git a/net-dns/avahi/avahi-0.6.24-r1.ebuild b/net-dns/avahi/avahi-0.6.24-r1.ebuild
new file mode 100644
index 000000000000..95b9b20b7479
--- /dev/null
+++ b/net-dns/avahi/avahi-0.6.24-r1.ebuild
@@ -0,0 +1,214 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.24-r1.ebuild,v 1.1 2009/03/05 21:13:27 swegener Exp $
+
+EAPI="1"
+
+inherit autotools eutils mono python multilib
+
+DESCRIPTION="System which facilitates service discovery on a local network"
+HOMEPAGE="http://avahi.org/"
+SRC_URI="http://avahi.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="bookmarks howl-compat mdnsresponder-compat gdbm dbus doc mono gtk python qt3 qt4 autoipd kernel_linux test ipv6"
+
+RDEPEND=">=dev-libs/libdaemon-0.11-r1
+ dev-libs/expat
+ >=dev-libs/glib-2
+ gdbm? ( sys-libs/gdbm )
+ qt3? ( x11-libs/qt:3 )
+ qt4? (
+ || (
+ x11-libs/qt-core:4
+ x11-libs/qt:4
+ )
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.4.0
+ >=gnome-base/libglade-2.4.0
+ )
+ dbus? (
+ >=sys-apps/dbus-0.30
+ python? (
+ || (
+ dev-python/dbus-python
+ (
+ <sys-apps/dbus-0.90
+ >=sys-apps/dbus-0.30
+ )
+ )
+ )
+ )
+ mono? (
+ >=dev-lang/mono-1.1.10
+ gtk? ( >=dev-dotnet/gtk-sharp-2 )
+ )
+ howl-compat? ( !net-misc/howl )
+ mdnsresponder-compat? ( !net-misc/mDNSResponder )
+ python? (
+ >=virtual/python-2.4
+ gtk? ( >=dev-python/pygtk-2 )
+ )
+ bookmarks? (
+ dev-python/twisted
+ dev-python/twisted-web
+ )
+ kernel_linux? ( sys-libs/libcap )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9.0
+ doc? (
+ app-doc/doxygen
+ mono? ( >=virtual/monodoc-1.1.8 )
+ )"
+
+pkg_setup() {
+ if use python && ! built_with_use dev-lang/python gdbm
+ then
+ die "For python support you need dev-lang/python compiled with gdbm support!"
+ fi
+
+ if use python && use dbus && ! has_version dev-python/dbus-python && ! built_with_use sys-apps/dbus python
+ then
+ die "For python and dbus support you need sys-apps/dbus compiled with python support or dev-python/dbus-python!"
+ fi
+
+ if ( use mdnsresponder-compat || use howl-compat || use mono ) && ! use dbus
+ then
+ die "For *-compat or mono support you also need to enable the dbus USE flag!"
+ fi
+
+ if use bookmarks && ! ( use python && use dbus && use gtk )
+ then
+ die "For bookmarks support you also need to enable the python, dbus and gtk USE flags!"
+ fi
+
+ if use python && ! use dbus && ! use gtk
+ then
+ die "For proper python support you also need the dbus and gtk USE flags!"
+ fi
+}
+
+pkg_preinst() {
+ enewgroup netdev
+ enewgroup avahi
+ enewuser avahi -1 -1 -1 avahi
+
+ if use autoipd
+ then
+ enewgroup avahi-autoipd
+ enewuser avahi-autoipd -1 -1 -1 avahi-autoipd
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use ipv6 && sed -i -e s/use-ipv6=no/use-ipv6=yes/ avahi-daemon/avahi-daemon.conf
+
+ sed -i -e "s:\\.\\./\\.\\./\\.\\./doc/avahi-docs/html/:../../../doc/${PF}/html/:" doxygen_to_devhelp.xsl
+
+ epatch "${FILESDIR}"/${P}-*.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if use python
+ then
+ use dbus && myconf="${myconf} --enable-python-dbus"
+ use gtk && myconf="${myconf} --enable-pygtk"
+ fi
+
+ if use mono && use doc
+ then
+ myconf="${myconf} --enable-monodoc"
+ fi
+
+ # We need to unset DISPLAY, else the configure script might have problems detecting the pygtk module
+ unset DISPLAY
+
+ econf \
+ --localstatedir=/var \
+ --with-distro=gentoo \
+ --disable-python-dbus \
+ --disable-pygtk \
+ --disable-xmltoman \
+ --disable-monodoc \
+ --enable-glib \
+ $(use_enable test tests) \
+ $(use_enable autoipd) \
+ $(use_enable mdnsresponder-compat compat-libdns_sd) \
+ $(use_enable howl-compat compat-howl) \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable mono) \
+ $(use_enable dbus) \
+ $(use_enable python) \
+ $(use_enable gtk) \
+ $(use_enable qt3) \
+ $(use_enable qt4) \
+ $(use_enable gdbm) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ use doc && emake avahi.devhelp
+}
+
+src_install() {
+ emake install py_compile=true DESTDIR="${D}" || die "make install failed"
+ use bookmarks || rm -f "${D}"/usr/bin/avahi-bookmarks
+
+ use howl-compat && ln -s avahi-compat-howl.pc "${D}"/usr/$(get_libdir)/pkgconfig/howl.pc
+ use mdnsresponder-compat && ln -s avahi-compat-libdns_sd/dns_sd.h "${D}"/usr/include/dns_sd.h
+
+ if use autoipd
+ then
+ insinto /$(get_libdir)/rcscripts/net
+ doins "${FILESDIR}"/autoipd.sh
+
+ insinto /$(get_libdir)/rc/net
+ newins "${FILESDIR}"/autoipd-openrc.sh autoipd.sh
+ fi
+
+ dodoc docs/{AUTHORS,README,TODO}
+
+ if use doc
+ then
+ dohtml -r doxygen/html/.
+ insinto /usr/share/devhelp/books/avahi
+ doins avahi.devhelp
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/avahi
+ fi
+
+ if use autoipd
+ then
+ elog
+ elog "To use avahi-autoipd to configure your interfaces with IPv4LL (RFC3927)"
+ elog "addresses, just set config_<interface>=( autoipd ) in /etc/conf.d/net!"
+ elog
+ fi
+
+ if use dbus
+ then
+ elog
+ elog "If this is your first install of avahi please reload your dbus config"
+ elog "with /etc/init.d/dbus reload before starting avahi-daemon!"
+ elog
+ fi
+}
diff --git a/net-dns/avahi/avahi-0.6.24.ebuild b/net-dns/avahi/avahi-0.6.24.ebuild
index 3cc3ea783fe2..ebcc7cac642a 100644
--- a/net-dns/avahi/avahi-0.6.24.ebuild
+++ b/net-dns/avahi/avahi-0.6.24.ebuild
@@ -1,6 +1,6 @@
-# Copyright 2000-2008 Gentoo Foundation
+# Copyright 2000-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.24.ebuild,v 1.7 2008/12/22 18:51:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.24.ebuild,v 1.8 2009/03/05 21:13:27 swegener Exp $
EAPI="1"
diff --git a/net-dns/avahi/files/avahi-0.6.24-CVE-2009-0758.patch b/net-dns/avahi/files/avahi-0.6.24-CVE-2009-0758.patch
new file mode 100644
index 000000000000..578839364c62
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.24-CVE-2009-0758.patch
@@ -0,0 +1,22 @@
+diff --git a/avahi-core/server.c b/avahi-core/server.c
+index 453db09..8187690 100644
+--- a/avahi-core/server.c
++++ b/avahi-core/server.c
+@@ -844,7 +844,7 @@ static int originates_from_local_legacy_unicast_socket(AvahiServer *s, const Ava
+ if (getsockname(s->fd_legacy_unicast_ipv4, (struct sockaddr*) &lsa, &l) != 0)
+ avahi_log_warn("getsockname(): %s", strerror(errno));
+ else
+- return lsa.sin_port == port;
++ return avahi_port_from_sockaddr((struct sockaddr*) &lsa) == port;
+
+ }
+
+@@ -855,7 +855,7 @@ static int originates_from_local_legacy_unicast_socket(AvahiServer *s, const Ava
+ if (getsockname(s->fd_legacy_unicast_ipv6, (struct sockaddr*) &lsa, &l) != 0)
+ avahi_log_warn("getsockname(): %s", strerror(errno));
+ else
+- return lsa.sin6_port == port;
++ return avahi_port_from_sockaddr((struct sockaddr*) &lsa) == port;
+ }
+
+ return 0;
diff --git a/net-dns/avahi/files/avahi-0.6.24-cmsg_space.patch b/net-dns/avahi/files/avahi-0.6.24-cmsg_space.patch
new file mode 100644
index 000000000000..220e63fa24f3
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.24-cmsg_space.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2009-02-25 11:51:29 +0100
++++ configure.ac 2009-02-25 11:55:47 +0100
+@@ -348,7 +348,7 @@
+ # Solaris stuff
+ AC_SEARCH_LIBS([inet_ntop],[nsl])
+ AC_SEARCH_LIBS([recv],[socket])
+- AC_CHECK_DECL([CMSG_SPACE],,CFLAGS="$CFLAGS -D_XOPEN_SOURCE=500 -D__EXTENSIONS__")
++ AC_CHECK_DECL([CMSG_SPACE],,CFLAGS="$CFLAGS -D_XOPEN_SOURCE=500 -D__EXTENSIONS__", [[#include <sys/socket.h>]])
+
+ # Checks for library functions.
+ AC_FUNC_MEMCMP
diff --git a/net-dns/avahi/files/avahi-0.6.24-libintl.patch b/net-dns/avahi/files/avahi-0.6.24-libintl.patch
new file mode 100644
index 000000000000..3ad943ac130c
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.24-libintl.patch
@@ -0,0 +1,11 @@
+--- avahi-common/Makefile.am.orig 2008-12-12 21:33:35 +0100
++++ avahi-common/Makefile.am 2009-02-25 12:21:14 +0100
+@@ -71,7 +71,7 @@
+ i18n.c i18n.h
+
+ libavahi_common_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -DAVAHI_LOCALEDIR=\"$(avahilocaledir)\"
+-libavahi_common_la_LIBADD = $(AM_LDADD) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS) $(LIBINTL)
++libavahi_common_la_LIBADD = $(AM_LDADD) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS) $(INTLLIBS)
+ libavahi_common_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBAVAHI_COMMON_VERSION_INFO)
+
+ strlst_test_SOURCES = \