summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-09 17:32:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-09 17:32:04 +0000
commit7ea643684e72095eaa071f817e3a51cfe3a8d020 (patch)
treec7b5541fc697c3a9b30be9b0ebac2053eb18b729 /net-dns
parentBump (Manifest recommit) (diff)
downloadgentoo-2-7ea643684e72095eaa071f817e3a51cfe3a8d020.tar.gz
gentoo-2-7ea643684e72095eaa071f817e3a51cfe3a8d020.tar.bz2
gentoo-2-7ea643684e72095eaa071f817e3a51cfe3a8d020.zip
uclibc lovin
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/bind-9.2.2-r3.ebuild38
-rw-r--r--net-dns/bind/bind-9.2.2-r4.ebuild37
2 files changed, 43 insertions, 32 deletions
diff --git a/net-dns/bind/bind-9.2.2-r3.ebuild b/net-dns/bind/bind-9.2.2-r3.ebuild
index 909254a5ecb8..a70c319a808f 100644
--- a/net-dns/bind/bind-9.2.2-r3.ebuild
+++ b/net-dns/bind/bind-9.2.2-r3.ebuild
@@ -1,38 +1,42 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r3.ebuild,v 1.12 2004/07/29 15:08:34 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r3.ebuild,v 1.13 2004/10/09 17:32:04 vapier Exp $
-inherit eutils
-
-IUSE="doc ipv6 selinux ssl"
+inherit eutils gnuconfig libtool
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
-SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz
+ ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
-KEYWORDS="x86 ppc sparc ~alpha hppa ~amd64 ppc64"
LICENSE="as-is"
SLOT="0"
+KEYWORDS="~alpha ~amd64 hppa ppc ppc64 sparc x86"
+IUSE="doc ipv6 selinux ssl"
DEPEND="sys-apps/groff
>=sys-apps/sed-4
ssl? ( >=dev-libs/openssl-0.9.6g )"
-
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-bind )"
src_unpack() {
- unpack ${A} && cd ${S}
+ unpack ${A}
+ cd ${S}
epatch ${DISTDIR}/patch.${PV}-P1
# Adjusting PATHs in manpages
for i in `echo bin/{named/named.8,check/named-checkconf.8,nsupdate/nsupdate.8,rndc/rndc.8}`; do
- sed -i -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
- -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
- -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
- ${i}
+ sed -i \
+ -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ ${i} || die "sed $i"
done
+
+ gnuconfig_update
+ uclibctoolize
}
src_compile() {
@@ -41,19 +45,21 @@ src_compile() {
use ssl && myconf="${myconf} --with-openssl"
use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
- econf --sysconfdir=/etc/bind \
+ econf \
+ --sysconfdir=/etc/bind \
--localstatedir=/var \
--enable-threads \
--with-libtool \
- ${myconf} || die "econf failed"
+ ${myconf} \
+ || die "econf failed"
- MAKEOPTS="${MAKEOPTS} -j1" emake || die "failed to compile bind"
+ emake -j1 || die "failed to compile bind"
}
src_install() {
einstall || die "failed to install bind"
- dodoc CHANGES COPYRIGHT FAQ README
+ dodoc CHANGES FAQ README
use doc && {
docinto misc ; dodoc doc/misc/*
diff --git a/net-dns/bind/bind-9.2.2-r4.ebuild b/net-dns/bind/bind-9.2.2-r4.ebuild
index eeb8690f92ef..14ab11d6ce22 100644
--- a/net-dns/bind/bind-9.2.2-r4.ebuild
+++ b/net-dns/bind/bind-9.2.2-r4.ebuild
@@ -1,43 +1,47 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r4.ebuild,v 1.4 2004/08/19 20:11:00 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r4.ebuild,v 1.5 2004/10/09 17:32:04 vapier Exp $
-inherit eutils
-
-IUSE="doc ipv6 mysql selinux ssl"
+inherit eutils gnuconfig libtool
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
-SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz
+ ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
-KEYWORDS="~x86 ppc -sparc ~alpha ~hppa ~amd64 ~ppc64"
LICENSE="as-is"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ppc ~ppc64 -sparc ~x86"
+IUSE="doc ipv6 mysql selinux ssl"
DEPEND="sys-apps/groff
>=sys-apps/sed-4
ssl? ( >=dev-libs/openssl-0.9.6g )"
-
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-bind )"
src_unpack() {
- unpack ${A} && cd ${S}
+ unpack ${A}
+ cd ${S}
epatch ${DISTDIR}/patch.${PV}-P1
# Adjusting PATHs in manpages
for i in `echo bin/{named/named.8,check/named-checkconf.8,nsupdate/nsupdate.8,rndc/rndc.8}`; do
- sed -i -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
- -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
- -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
- ${i}
+ sed -i \
+ -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ ${i} || die "sed $i"
done
if use mysql; then
EPATCH_OPTS="-p0 -d ${S}" \
epatch ${FILESDIR}/bind-9.2.2-mysql.patch
fi
+
+ gnuconfig_update
+ uclibctoolize
}
src_compile() {
@@ -46,13 +50,14 @@ src_compile() {
use ssl && myconf="${myconf} --with-openssl"
use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
- econf --sysconfdir=/etc/bind \
+ econf \
+ --sysconfdir=/etc/bind \
--localstatedir=/var \
--enable-threads \
--with-libtool \
- ${myconf} || die "econf failed"
-
- MAKEOPTS="${MAKEOPTS} -j1" emake || die "failed to compile bind"
+ ${myconf} \
+ || die "econf failed"
+ emake -j1 || die "failed to compile bind"
}
src_install() {