summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-13 00:02:12 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-13 00:02:12 +0000
commit6d37944d19b4fe99baa0af9ba6cf49ef39749baa (patch)
treedfe25eb3ec9d991300a140d94864d9e1133109af /net-dns
parentmark stable (diff)
downloadgentoo-2-6d37944d19b4fe99baa0af9ba6cf49ef39749baa.tar.gz
gentoo-2-6d37944d19b4fe99baa0af9ba6cf49ef39749baa.tar.bz2
gentoo-2-6d37944d19b4fe99baa0af9ba6cf49ef39749baa.zip
ew version actually works with FreeBSD and GNU sed.
(Portage version: 2.1.1)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/resolvconf-gentoo/ChangeLog9
-rw-r--r--net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.13
-rw-r--r--net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild12
-rw-r--r--net-dns/resolvconf-gentoo/resolvconf-gentoo-1.1.ebuild63
4 files changed, 76 insertions, 11 deletions
diff --git a/net-dns/resolvconf-gentoo/ChangeLog b/net-dns/resolvconf-gentoo/ChangeLog
index 5c45570f1c0f..a6d9d8c43bbb 100644
--- a/net-dns/resolvconf-gentoo/ChangeLog
+++ b/net-dns/resolvconf-gentoo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/resolvconf-gentoo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/ChangeLog,v 1.13 2006/09/09 22:36:33 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/ChangeLog,v 1.14 2006/09/13 00:02:12 uberlord Exp $
+
+*resolvconf-gentoo-1.1 (13 Sep 2006)
+
+ 13 Sep 2006; Roy Marples <uberlord@gentoo.org>
+ -files/resolvconf-gentoo-1.0-run-parts.patch,
+ resolvconf-gentoo-1.0.ebuild, +resolvconf-gentoo-1.1.ebuild:
+ New version actually works with FreeBSD and GNU sed.
09 Sep 2006; Roy Marples <uberlord@gentoo.org>
+files/resolvconf-gentoo-1.0-run-parts.patch,
diff --git a/net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.1 b/net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.1
new file mode 100644
index 000000000000..5c2a0fcfa4a5
--- /dev/null
+++ b/net-dns/resolvconf-gentoo/files/digest-resolvconf-gentoo-1.1
@@ -0,0 +1,3 @@
+MD5 8695623f03245755207bc376d43032e7 resolvconf-gentoo-1.1.tar.bz2 5322
+RMD160 8fcc6fbd9cfc0acf8f47dd7371356f7f56f694e2 resolvconf-gentoo-1.1.tar.bz2 5322
+SHA256 3c1f667fc6681816f22780051432e6e3727b49aad32a840be07988e73bc55ec0 resolvconf-gentoo-1.1.tar.bz2 5322
diff --git a/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild
index ac75078ce1de..2a04323b524b 100644
--- a/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild
+++ b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild,v 1.12 2006/09/09 22:36:33 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild,v 1.13 2006/09/13 00:02:12 uberlord Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://dev.gentoo.org/~uberlord/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE=""
DEPEND=""
@@ -25,14 +25,6 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # run-parts is Linux only, so replace with a bash loop
- epatch "${FILESDIR}/${P}-run-parts.patch"
-}
-
src_install() {
make ROOT="${D}" install || die "Failed to install"
}
diff --git a/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.1.ebuild b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.1.ebuild
new file mode 100644
index 000000000000..7011c8ca7076
--- /dev/null
+++ b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.1.ebuild,v 1.1 2006/09/13 00:02:12 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~uberlord/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+pkg_setup() {
+ if ! grep -q "^uniqify()" "${ROOT}"/etc/init.d/functions.sh ; then
+ eerror "/etc/init.d/functions.sh does not supply the uniqify function"
+ eerror "Please upgrade to a baselayout that support it"
+ eerror "(baselayout-1.12.0_pre17 and later versions do)"
+ die "function uniqify does not exist"
+ fi
+}
+
+src_install() {
+ make ROOT="${D}" install || die "Failed to install"
+}
+
+pkg_postinst() {
+ if [[ ! -"L ${ROOT}/etc/resolv.conf" ]] \
+ || [[ $(readlink "${ROOT}/etc/resolv.conf") != \
+ "resolvconf/run/resolv.conf" ]] ; then
+ ewarn "resolvconf requires ${ROOT}/etc/resolv.conf to be a symbolic"
+ ewarn "to resolvconf/run/resolv.conf"
+ einfo "To set this up automatically type"
+ einfo " emerge --config =${PF}"
+ fi
+}
+
+pkg_config() {
+ cd "${ROOT}/etc"
+ if [[ -L resolv.conf && $(readlink resolv.conf) == \
+ "resolvconf/run/resolv.conf" ]] ; then
+ einfo "${ROOT}/etc/resolv.conf is already configured for ${PN}"
+ else
+ if [[ -e resolv.conf ]] ; then
+ einfo "Your existing resolv.conf is will be mapped to an"
+ einfo "interface called \"dummy\" in resolvconf. This will"
+ einfo "disappear when you reboot."
+ cp resolv.conf resolvconf/run/resolv.conf
+ [[ ! -d resolvconf/run/interfaces ]] \
+ && mkdir resolvconf/run/interfaces
+ cp resolv.conf resolvconf/run/interfaces/dummy
+ echo "dummy" > resolvconf/run/add_order
+ fi
+ rm -f resolv.conf
+ ln -snf resolvconf/run/resolv.conf .
+ einfo "${ROOT}/etc/resolv.conf is now correctly configured for ${PN}"
+ fi
+}