summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-11-04 07:33:32 +0000
committerSven Wegener <swegener@gentoo.org>2005-11-04 07:33:32 +0000
commit51b2efcbc02223cc637a7ad12151c42b6cc09f6e (patch)
tree1a917d8cb6b0da011659984bd24e1d48f92732ec /net-dns
parent+# Sven Wegener <swegener@gentoo.org> (04 Nov 2005) (diff)
downloadgentoo-2-51b2efcbc02223cc637a7ad12151c42b6cc09f6e.tar.gz
gentoo-2-51b2efcbc02223cc637a7ad12151c42b6cc09f6e.tar.bz2
gentoo-2-51b2efcbc02223cc637a7ad12151c42b6cc09f6e.zip
Revision bump for testing the mono docs stuff.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/avahi/ChangeLog7
-rw-r--r--net-dns/avahi/avahi-0.5.2-r1.ebuild85
-rw-r--r--net-dns/avahi/files/digest-avahi-0.5.2-r11
3 files changed, 92 insertions, 1 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index 0b9ced7ec339..c12d8f371467 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.15 2005/11/04 07:23:58 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.16 2005/11/04 07:33:32 swegener Exp $
+
+*avahi-0.5.2-r1 (04 Nov 2005)
+
+ 04 Nov 2005; Sven Wegener <swegener@gentoo.org> +avahi-0.5.2-r1.ebuild:
+ Revision bump for testing the mono docs stuff.
04 Nov 2005; Sven Wegener <swegener@gentoo.org> avahi-0.5.2.ebuild:
Add built_with_use test for bug #111413.
diff --git a/net-dns/avahi/avahi-0.5.2-r1.ebuild b/net-dns/avahi/avahi-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..a4ba37740066
--- /dev/null
+++ b/net-dns/avahi/avahi-0.5.2-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2-r1.ebuild,v 1.1 2005/11/04 07:33:32 swegener Exp $
+
+inherit eutils qt3 mono
+
+DESCRIPTION="System which facilitates service discovery on a local network"
+HOMEPAGE="http://www.freedesktop.org/Software/Avahi"
+SRC_URI="http://www.freedesktop.org/~lennart/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus doc mono gtk python qt"
+
+RDEPEND="dev-libs/libdaemon
+ dev-libs/expat
+ qt? ( $(qt_min_version 3.3) )
+ gtk? (
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=dev-libs/glib-2
+ )
+ mono? ( >=dev-lang/mono-1.1.3 )
+ dbus? (
+ >=sys-apps/dbus-0.30
+ python? (
+ >=virtual/python-2.4
+ >=dev-python/pygtk-2
+ )
+ )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ mono? ( >=dev-util/monodoc-1.1.8 )
+ )"
+
+export PKG_CONFIG_PATH="${QTDIR}/lib/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use dev-lang/python gdbm
+ then
+ die "Need dev-lang/python compiled with gdbm support!"
+ fi
+
+ enewgroup avahi
+ enewuser avahi -1 -1 -1 avahi
+}
+
+src_compile() {
+ local myconf=""
+
+ if use python && use dbus
+ then
+ myconf="${myconf} --enable-python"
+ fi
+
+ if use mono && use doc
+ then
+ myconf="${myconf} --enable-mono-docs"
+ fi
+
+ econf \
+ --localstatedir=/var \
+ --with-distro=gentoo \
+ --disable-python \
+ --disable-qt4 \
+ --disable-xmltoman \
+ --disable-mono-docs \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable mono) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_enable qt qt3) \
+ $(use_enable gtk glib) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc docs/{AUTHORS,README,TODO}
+}
diff --git a/net-dns/avahi/files/digest-avahi-0.5.2-r1 b/net-dns/avahi/files/digest-avahi-0.5.2-r1
new file mode 100644
index 000000000000..f53471ba3676
--- /dev/null
+++ b/net-dns/avahi/files/digest-avahi-0.5.2-r1
@@ -0,0 +1 @@
+MD5 dc7ce24ffaab251a2002bf1dfdbe256d avahi-0.5.2.tar.gz 651504