summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-17 04:50:51 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-17 04:50:51 +0000
commit42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f (patch)
tree4909112dca2c10b8140cdf52d17bbc5ded926eae /net-dns
parentAdded new net-dns/pdns flags. (diff)
downloadgentoo-2-42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f.tar.gz
gentoo-2-42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f.tar.bz2
gentoo-2-42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f.zip
Version bump. Added support for the recursor component, bug #59862. Added multiple instances support, thanks to Christian Zoffoli in bug #80322. Enabled the sqlite backend, bug #91325.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/ChangeLog10
-rw-r--r--net-dns/pdns/Manifest6
-rw-r--r--net-dns/pdns/files/digest-pdns-2.9.181
-rw-r--r--net-dns/pdns/files/pdns31
-rw-r--r--net-dns/pdns/files/precursor20
-rw-r--r--net-dns/pdns/files/recursor.conf18
-rw-r--r--net-dns/pdns/metadata.xml10
-rw-r--r--net-dns/pdns/pdns-2.9.18.ebuild79
8 files changed, 166 insertions, 9 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index 7897dd231971..c00d8ad79d4e 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/pdns
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.15 2005/05/05 17:58:51 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.16 2005/07/17 04:50:51 swegener Exp $
+
+*pdns-2.9.18 (17 Jul 2005)
+
+ 17 Jul 2005; Sven Wegener <swegener@gentoo.org> files/pdns,
+ +files/precursor, +files/recursor.conf, metadata.xml, +pdns-2.9.18.ebuild:
+ Version bump. Added support for the recursor component, bug #59862. Added
+ multiple instances support, thanks to Christian Zoffoli in bug #80322.
+ Enabled the sqlite backend, bug #91325.
05 May 2005; Seemant Kulleen <seemant@gentoo.org> -pdns-2.9.8.ebuild,
-pdns-2.9.12.ebuild, -pdns-2.9.12-r1.ebuild, -pdns-2.9.15.ebuild,
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 7609303d36f2..160b9ad7ea95 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,6 +1,8 @@
MD5 7a57f32e2b650746f5844e25cc454a75 ChangeLog 2183
-MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
-MD5 172c916f2af3e12be9af6f65bc4ab881 pdns-2.9.17.ebuild 1313
MD5 62a8267bd54fd7edf57908299088c96a files/digest-pdns-2.9.17 63
+MD5 e59bb419d93a7d7bdcb13764c57b3f6d files/digest-pdns-2.9.18 63
MD5 410f79d6f2de7a7e1ce8eeb5d87356df files/pdns 514
MD5 2d29230247ff445cea2a20fbdd25a219 files/pdns-2.9.17-amd64-fix.diff 1155
+MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
+MD5 172c916f2af3e12be9af6f65bc4ab881 pdns-2.9.17.ebuild 1313
+MD5 1b49c7c793a84aba2c4db8e967f8cc8c pdns-2.9.18.ebuild 1219
diff --git a/net-dns/pdns/files/digest-pdns-2.9.18 b/net-dns/pdns/files/digest-pdns-2.9.18
new file mode 100644
index 000000000000..423d9f95903c
--- /dev/null
+++ b/net-dns/pdns/files/digest-pdns-2.9.18
@@ -0,0 +1 @@
+MD5 bcfb0573311e80dbeff0bb16f2764363 pdns-2.9.18.tar.gz 825719
diff --git a/net-dns/pdns/files/pdns b/net-dns/pdns/files/pdns
index 4c7fcb4ca98e..bead283292eb 100644
--- a/net-dns/pdns/files/pdns
+++ b/net-dns/pdns/files/pdns
@@ -1,20 +1,39 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/files/pdns,v 1.3 2004/07/14 23:25:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/files/pdns,v 1.4 2005/07/17 04:50:51 swegener Exp $
+
+opts="${opts} reload"
+
+# Default instance
+PDNS_INSTANCE="default"
+PDNS_CONFIG=""
+
+# Multiple instances support
+if [[ "${myservice:0:5}" = "pdns-" && -n "${myservice:5}" ]]
+then
+ PDNS_INSTANCE="${myservice:5}"
+ PDNS_CONFIG="--config-name=${PDNS_INSTANCE}"
+fi
depend() {
need net
}
start() {
- ebegin "Starting PowerDNS"
- start-stop-daemon --start --quiet --exec /usr/bin/env -- /usr/sbin/pdns_server --daemon --guardian=yes
+ ebegin "Starting PowerDNS (${PDNS_INSTANCE})"
+ /usr/sbin/pdns_server ${PDNS_CONFIG} --daemon --guardian=yes
eend $?
}
stop() {
- ebegin "Stopping PowerDNS"
- start-stop-daemon --stop --quiet --pidfile=/var/run/pdns.pid
+ ebegin "Stopping PowerDNS (${PDNS_INSTANCE})"
+ start-stop-daemon --stop --quiet --pidfile /var/run/${myservice}.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading PowerDNS (${PDNS_INSTANCE})"
+ /usr/bin/pdns_control ${PDNS_CONFIG} cycle &>/dev/null
eend $?
}
diff --git a/net-dns/pdns/files/precursor b/net-dns/pdns/files/precursor
new file mode 100644
index 000000000000..f2da0e822431
--- /dev/null
+++ b/net-dns/pdns/files/precursor
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/files/precursor,v 1.1 2005/07/17 04:50:51 swegener Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting PowerDNS Recursor"
+ /usr/sbin/pdns_recursor --daemon &>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping PowerDNS Recursor"
+ start-stop-daemon --stop --quiet --pidfile=/var/run/pdns_recursor.pid
+ eend $?
+}
diff --git a/net-dns/pdns/files/recursor.conf b/net-dns/pdns/files/recursor.conf
new file mode 100644
index 000000000000..7b7d81597135
--- /dev/null
+++ b/net-dns/pdns/files/recursor.conf
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/files/recursor.conf,v 1.1 2005/07/17 04:50:51 swegener Exp $
+
+# Drop uid
+setuid=nobody
+
+# Drop gid
+setgid=nobody
+
+# Don't log queries
+quiet=on
+
+# Local IP address to bind to
+local-address=127.0.0.1
+
+# Local port to bind to
+local-port=53
diff --git a/net-dns/pdns/metadata.xml b/net-dns/pdns/metadata.xml
index 20ce219711a2..e55cf02e3bf4 100644
--- a/net-dns/pdns/metadata.xml
+++ b/net-dns/pdns/metadata.xml
@@ -2,4 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
+<maintainer>
+ <email>swegener@gentoo.org</email>
+ <name>Sven Wegener</name>
+ <description>Primary Maintainer</description>
+</maintainer>
+<longdescription>
+The PowerDNS Nameserver is a modern, advanced and high performance authoritative-
+only nameserver. It is written from scratch and conforms to all relevant DNS
+standards documents. Furthermore, PowerDNS interfaces with almost any database.
+</longdescription>
</pkgmetadata>
diff --git a/net-dns/pdns/pdns-2.9.18.ebuild b/net-dns/pdns/pdns-2.9.18.ebuild
new file mode 100644
index 000000000000..151fd7bba3e4
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.18.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.18.ebuild,v 1.1 2005/07/17 04:50:51 swegener Exp $
+
+DESCRIPTION="The PowerDNS Daemon"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc ldap mysql postgres recursor sqlite static tdb"
+
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )
+ sqlite? ( >=dev-db/sqlite-3 )
+ recursor? ( dev-libs/boost )
+ tdb? ( dev-libs/tdb )"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ local modules="pipe geo" myconf=""
+
+ use mysql && modules="${modules} gmysql"
+ use postgres && modules="${modules} gpgsql"
+ use sqlite && modules="${modules} gsqlite"
+ use ldap && modules="${modules} ldap"
+ use tdb && modules="${modules} xdb"
+ use debug && myconf="${myconf} --enable-verbose-logging"
+
+ econf \
+ --with-modules= \
+ --with-dynmodules="${modules}" \
+ $(use_enable static static-binaries) \
+ $(use_enable recursor) \
+ ${myconf} \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use doc
+ then
+ emake -C codedocs codedocs || die "emake codedocs failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ mv "${D}"/etc/pdns.conf{-dist,}
+ doinitd "${FILESDIR}"/pdns
+
+ if use recursor
+ then
+ doinitd "${FILESDIR}"/precursor
+ insinto /etc
+ doins "${FILESDIR}"/recursor.conf
+ fi
+
+ dodoc ChangeLog README TODO
+ use doc && dohtml -r codedocs/html/.
+}
+
+pkg_postinst() {
+ einfo
+ einfo "pdns now provides multiple instances support. You can create more instances"
+ einfo "by symlinking the pdns init script to another name."
+ einfo
+ einfo "The name must be in the format pdns-<suffix> and PowerDNS will use the"
+ einfo "/etc/pdns-<suffix>.conf configuration file instead of the default."
+ einfo
+ einfo "Also all backends, except the bind and random backends, are now compiled as"
+ einfo "loadable modules and must be loaded with load-modules= in the configuration"
+ einfo "file."
+ einfo
+}