summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-11 11:18:37 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-11 11:18:37 +0000
commit42c2db2e16c59164d15d1acd68c7a78f201ef8ff (patch)
tree33a77809314fc923178a3178246ecc3c7095f919 /net-dns
parents390/sparc stable wrt #321951, drop alpha (diff)
downloadgentoo-2-42c2db2e16c59164d15d1acd68c7a78f201ef8ff.tar.gz
gentoo-2-42c2db2e16c59164d15d1acd68c7a78f201ef8ff.tar.bz2
gentoo-2-42c2db2e16c59164d15d1acd68c7a78f201ef8ff.zip
Initial commit. Fixes bug #309179. Thanks to Doktor Notor <notordoktor@gmail.com> for the ebuild
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/hesinfo/ChangeLog11
-rw-r--r--net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch58
-rw-r--r--net-dns/hesinfo/hesinfo-3.1.0.ebuild29
-rw-r--r--net-dns/hesinfo/metadata.xml11
4 files changed, 109 insertions, 0 deletions
diff --git a/net-dns/hesinfo/ChangeLog b/net-dns/hesinfo/ChangeLog
new file mode 100644
index 000000000000..d0af2fcb5981
--- /dev/null
+++ b/net-dns/hesinfo/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-dns/hesinfo
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesinfo/ChangeLog,v 1.1 2010/07/11 11:18:36 hwoarang Exp $
+
+*hesinfo-3.1.0 (11 Jul 2010)
+
+ 11 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +hesinfo-3.1.0.ebuild,
+ +files/hesinfo-3.1.0-autotools.patch:
+ Initial commit. Fixes bug #309179. Thanks to Doktor Notor
+ <notordoktor@gmail.com> for the ebuild
+
diff --git a/net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch b/net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch
new file mode 100644
index 000000000000..7e611c042bee
--- /dev/null
+++ b/net-dns/hesinfo/files/hesinfo-3.1.0-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.in 2006-03-30 18:22:39.000000000 +0200
++++ Makefile.in 2010-03-12 21:34:34.000000000 +0100
+@@ -22,7 +22,7 @@
+ all: hesinfo
+
+ hesinfo: hesinfo.o
+- ${CC} ${LDFLAGS} -o $@ hesinfo.o -lhesiod ${LIBS}
++ ${CC} ${LDFLAGS} -o $@ hesinfo.o -lhesiod ${LIBS} ${LDFLAGS}
+
+ .c.o:
+ ${CC} -c ${ALL_CFLAGS} $<
+--- configure.in 2006-03-30 18:22:39.000000000 +0200
++++ configure.in 2010-03-12 21:42:05.000000000 +0100
+@@ -7,6 +7,43 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+
+-ATHENA_HESIOD_REQUIRED
++dnl This file provides local macros for packages which use specific
++dnl external libraries. The public macros are:
++dnl
++dnl ATHENA_HESIOD_REQUIRED
++dnl Generates error if Hesiod not found.
++dnl Specify desired AFS libraries as a parameter.
++dnl ----- Hesiod -----
++
++AC_DEFUN(ATHENA_HESIOD_CHECK,
++[AC_CHECK_FUNC(res_send, :, AC_CHECK_LIB(resolv, res_send))
++if test "$hesiod" != yes; then
++ CPPFLAGS="$CPPFLAGS -I$hesiod/include"
++ LDFLAGS="$LDFLAGS -L$hesiod/lib"
++fi
++AC_CHECK_LIB(hesiod, hes_resolve, :,
++ [AC_MSG_ERROR(Hesiod library not found)])])
++
++AC_DEFUN(ATHENA_HESIOD,
++[AC_ARG_WITH(hesiod,
++ [ --with-hesiod=PREFIX Use Hesiod],
++ [hesiod="$withval"], [hesiod=no])
++if test "$hesiod" != no; then
++ ATHENA_HESIOD_CHECK
++ HESIOD_LIBS="-lhesiod"
++ AC_DEFINE(HAVE_HESIOD)
++fi
++AC_SUBST(HESIOD_LIBS)])
+
++AC_DEFUN(ATHENA_HESIOD_REQUIRED,
++[AC_ARG_WITH(hesiod,
++ [ --with-hesiod=PREFIX Specify location of Hesiod],
++ [hesiod="$withval"], [hesiod=yes])
++if test "$hesiod" != no; then
++ ATHENA_HESIOD_CHECK
++else
++ AC_MSG_ERROR(This package requires Hesiod.)
++fi])
++
++ATHENA_HESIOD_REQUIRED
+ AC_OUTPUT(Makefile)
diff --git a/net-dns/hesinfo/hesinfo-3.1.0.ebuild b/net-dns/hesinfo/hesinfo-3.1.0.ebuild
new file mode 100644
index 000000000000..01394e1f34f8
--- /dev/null
+++ b/net-dns/hesinfo/hesinfo-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesinfo/hesinfo-3.1.0.ebuild,v 1.1 2010/07/11 11:18:36 hwoarang Exp $
+
+EAPI="2"
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A simple command-line interface to the net-dns/hesiod service library"
+HOMEPAGE="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod"
+SRC_URI="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=net-dns/hesiod-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -f aclocal.m4 || die "rm failed"
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc NEWS README || die
+}
diff --git a/net-dns/hesinfo/metadata.xml b/net-dns/hesinfo/metadata.xml
new file mode 100644
index 000000000000..64bb85684608
--- /dev/null
+++ b/net-dns/hesinfo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+