summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-11-10 11:07:30 +0000
committerSven Wegener <swegener@gentoo.org>2005-11-10 11:07:30 +0000
commit032cdfb5bdcb449b8be002c93f9102b71f6a266c (patch)
tree60ec746cb6b778d85bab71045ac5b4506d92c95f /net-dns
parentVersion bump. (diff)
downloadgentoo-2-032cdfb5bdcb449b8be002c93f9102b71f6a266c.tar.gz
gentoo-2-032cdfb5bdcb449b8be002c93f9102b71f6a266c.tar.bz2
gentoo-2-032cdfb5bdcb449b8be002c93f9102b71f6a266c.zip
touchup the python/dbus/gtk logic
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/avahi/avahi-0.5.2-r1.ebuild39
-rw-r--r--net-dns/avahi/avahi-0.5.2.ebuild42
2 files changed, 42 insertions, 39 deletions
diff --git a/net-dns/avahi/avahi-0.5.2-r1.ebuild b/net-dns/avahi/avahi-0.5.2-r1.ebuild
index 3d6c9518ddf9..a5ac76e547de 100644
--- a/net-dns/avahi/avahi-0.5.2-r1.ebuild
+++ b/net-dns/avahi/avahi-0.5.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2-r1.ebuild,v 1.2 2005/11/07 16:05:25 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2-r1.ebuild,v 1.3 2005/11/10 11:07:30 swegener Exp $
-inherit eutils qt3 mono
+inherit eutils qt3 mono python
DESCRIPTION="System which facilitates service discovery on a local network"
HOMEPAGE="http://www.freedesktop.org/Software/Avahi"
@@ -22,12 +22,10 @@ RDEPEND="dev-libs/libdaemon
>=dev-libs/glib-2
)
mono? ( >=dev-lang/mono-1.1.3 )
- dbus? (
- >=sys-apps/dbus-0.30
- python? (
- >=virtual/python-2.4
- gtk? ( >=dev-python/pygtk-2 )
- )
+ dbus? ( >=sys-apps/dbus-0.30 )
+ python? (
+ >=virtual/python-2.4
+ gtk? ( >=dev-python/pygtk-2 )
)"
DEPEND="${RDEPEND}
doc? (
@@ -38,7 +36,7 @@ DEPEND="${RDEPEND}
export PKG_CONFIG_PATH="${QTDIR}/lib/pkgconfig"
pkg_setup() {
- if ! built_with_use dev-lang/python gdbm
+ if use python && ! built_with_use dev-lang/python gdbm
then
die "Need dev-lang/python compiled with gdbm support!"
fi
@@ -50,14 +48,10 @@ pkg_setup() {
src_compile() {
local myconf=""
- if use python && use dbus
+ if use python
then
- myconf="${myconf} --enable-python"
-
- if use gtk
- then
- myconf="${myconf} --enable-pygtk"
- fi
+ use dbus && myconf="${myconf} --enable-python-dbus"
+ use gtk && myconf="${myconf} --enable-pygtk"
fi
if use mono && use doc
@@ -68,14 +62,15 @@ src_compile() {
econf \
--localstatedir=/var \
--with-distro=gentoo \
- --disable-python \
- --disable-pygtk \
--disable-qt4 \
+ --disable-python-dbus \
+ --disable-pygtk \
--disable-xmltoman \
--disable-mono-docs \
$(use_enable doc doxygen-doc) \
$(use_enable mono) \
$(use_enable dbus) \
+ $(use_enable python) \
$(use_enable gtk) \
$(use_enable qt qt3) \
$(use_enable gtk glib) \
@@ -89,3 +84,11 @@ src_install() {
dodoc docs/{AUTHORS,README,TODO}
}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/avahi
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/avahi
+}
diff --git a/net-dns/avahi/avahi-0.5.2.ebuild b/net-dns/avahi/avahi-0.5.2.ebuild
index f7db6162a72f..b37d408be93d 100644
--- a/net-dns/avahi/avahi-0.5.2.ebuild
+++ b/net-dns/avahi/avahi-0.5.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2.ebuild,v 1.3 2005/11/07 16:05:25 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.5.2.ebuild,v 1.4 2005/11/10 11:07:30 swegener Exp $
-inherit eutils qt3 mono
+inherit eutils qt3 mono python
DESCRIPTION="System which facilitates service discovery on a local network"
HOMEPAGE="http://www.freedesktop.org/Software/Avahi"
@@ -22,23 +22,18 @@ RDEPEND="dev-libs/libdaemon
>=dev-libs/glib-2
)
mono? ( >=dev-lang/mono-1.1.3 )
- dbus? (
- >=sys-apps/dbus-0.30
- python? (
- >=virtual/python-2.4
- gtk? ( >=dev-python/pygtk-2 )
- )
+ dbus? ( >=sys-apps/dbus-0.30 )
+ python? (
+ >=virtual/python-2.4
+ gtk? ( >=dev-python/pygtk-2 )
)"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-# Future things:
-# doc? ( mono? ( >=dev-util/monodoc-1.18 ) )
-
export PKG_CONFIG_PATH="${QTDIR}/lib/pkgconfig"
pkg_setup() {
- if ! built_with_use dev-lang/python gdbm
+ if use python && ! built_with_use dev-lang/python gdbm
then
die "Need dev-lang/python compiled with gdbm support!"
fi
@@ -50,27 +45,24 @@ pkg_setup() {
src_compile() {
local myconf=""
- if use python && use dbus
+ if use python
then
- myconf="${myconf} --enable-python"
-
- if use gtk
- then
- myconf="${myconf} --enable-pygtk"
- fi
+ use dbus && myconf="${myconf} --enable-python-dbus"
+ use gtk && myconf="${myconf} --enable-pygtk"
fi
econf \
--localstatedir=/var \
--with-distro=gentoo \
- --disable-python \
- --disable-pygtk \
--disable-qt4 \
+ --disable-python-dbus \
+ --disable-pygtk \
--disable-xmltoman \
--disable-mono-docs \
$(use_enable doc doxygen-doc) \
$(use_enable mono) \
$(use_enable dbus) \
+ $(use_enable python) \
$(use_enable gtk) \
$(use_enable qt qt3) \
$(use_enable gtk glib) \
@@ -84,3 +76,11 @@ src_install() {
dodoc docs/{AUTHORS,README,TODO}
}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/avahi
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/avahi
+}