summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-04-01 10:36:53 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-04-01 10:36:53 +0000
commit36bae42a069dd578983fa00c8baf725c668d2c5c (patch)
tree50e296e4d7f20172764d623bb94981c61e406858 /net-dns/updatedd
parentia64/sparc/x86 stable (diff)
downloadgentoo-2-36bae42a069dd578983fa00c8baf725c668d2c5c.tar.gz
gentoo-2-36bae42a069dd578983fa00c8baf725c668d2c5c.tar.bz2
gentoo-2-36bae42a069dd578983fa00c8baf725c668d2c5c.zip
fix SEGV thanks to patch supplied by Alexandre Ferreir in bug #195709. also added version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-dns/updatedd')
-rw-r--r--net-dns/updatedd/ChangeLog13
-rw-r--r--net-dns/updatedd/files/updatedd-2.6-options.patch12
-rw-r--r--net-dns/updatedd/updatedd-2.5-r1.ebuild (renamed from net-dns/updatedd/updatedd-2.3.ebuild)11
-rw-r--r--net-dns/updatedd/updatedd-2.6.ebuild (renamed from net-dns/updatedd/updatedd-2.4.ebuild)13
4 files changed, 38 insertions, 11 deletions
diff --git a/net-dns/updatedd/ChangeLog b/net-dns/updatedd/ChangeLog
index 413dbc33abdc..8267784e4d0f 100644
--- a/net-dns/updatedd/ChangeLog
+++ b/net-dns/updatedd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-dns/updatedd
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/updatedd/ChangeLog,v 1.8 2007/02/22 02:05:25 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/updatedd/ChangeLog,v 1.9 2008/04/01 10:36:52 dragonheart Exp $
+
+*updatedd-2.6 (01 Apr 2008)
+*updatedd-2.5-r1 (01 Apr 2008)
+
+ 01 Apr 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/updatedd-2.6-options.patch, -updatedd-2.3.ebuild,
+ -updatedd-2.4.ebuild, +updatedd-2.5-r1.ebuild, +updatedd-2.6.ebuild:
+ fix SEGV thanks to patch supplied by Alexandre Ferreir in bug #195709. also
+ added version bump
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/net-dns/updatedd/files/updatedd-2.6-options.patch b/net-dns/updatedd/files/updatedd-2.6-options.patch
new file mode 100644
index 000000000000..17fe89b3e49d
--- /dev/null
+++ b/net-dns/updatedd/files/updatedd-2.6-options.patch
@@ -0,0 +1,12 @@
+--- updatedd-2.6/src/updatedd.c.orig 2008-04-01 19:00:30.000000000 +1100
++++ updatedd-2.6/src/updatedd.c 2008-04-01 19:01:17.000000000 +1100
+@@ -272,7 +272,8 @@
+ int c, option_index = 0;
+ static struct option long_options[] = {
+ { "help", 0, 0, 'h' },
+- { "version", 0, 0, 'v' }
++ { "version", 0, 0, 'v' },
++ { 0, 0, 0, 0 }
+ };
+
+ c = getopt_long(argc, argv, "LY",
diff --git a/net-dns/updatedd/updatedd-2.3.ebuild b/net-dns/updatedd/updatedd-2.5-r1.ebuild
index ee09877b4c52..c819fa4a7a54 100644
--- a/net-dns/updatedd/updatedd-2.3.ebuild
+++ b/net-dns/updatedd/updatedd-2.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/updatedd/updatedd-2.3.ebuild,v 1.2 2005/01/31 16:06:42 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/updatedd/updatedd-2.5-r1.ebuild,v 1.1 2008/04/01 10:36:52 dragonheart Exp $
inherit eutils
@@ -10,16 +10,15 @@ SRC_URI="http://savannah.nongnu.org/download/updatedd/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- # Fix the Makefile.in so $(bindir) is created before installing files there
- cd ${S}
- epatch ${FILESDIR}/${P}-makefile.patch || die "Patch Failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.6-options.patch
}
src_install() {
diff --git a/net-dns/updatedd/updatedd-2.4.ebuild b/net-dns/updatedd/updatedd-2.6.ebuild
index f6a635a3d9ec..f4f6c336b034 100644
--- a/net-dns/updatedd/updatedd-2.4.ebuild
+++ b/net-dns/updatedd/updatedd-2.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/updatedd/updatedd-2.4.ebuild,v 1.1 2005/03/02 08:02:33 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/updatedd/updatedd-2.6.ebuild,v 1.1 2008/04/01 10:36:52 dragonheart Exp $
+
+inherit eutils
DESCRIPTION="Dynamic DNS client with plugins for several dynamic dns services"
HOMEPAGE="http://updatedd.philipp-benner.de/"
@@ -8,11 +10,16 @@ SRC_URI="http://savannah.nongnu.org/download/updatedd/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="virtual/libc"
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}"/${P}-options.patch
+}
+
src_install() {
emake DESTDIR=${D} install || die
mv ${D}/usr/share/doc/updatedd ${D}/usr/share/doc/${PF}