summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-11-05 05:49:03 +0000
committerAlin Năstac <mrness@gentoo.org>2007-11-05 05:49:03 +0000
commit02cf9cfd3b9de5ffbc2978d4b887960f307f77b9 (patch)
tree2e265b76c369f421e3c7964e0e314dd00234c2ef /net-dns/pdnsd
parentAdded urandom flag for net-dns/pdnsd. (diff)
downloadgentoo-2-02cf9cfd3b9de5ffbc2978d4b887960f307f77b9.tar.gz
gentoo-2-02cf9cfd3b9de5ffbc2978d4b887960f307f77b9.tar.bz2
gentoo-2-02cf9cfd3b9de5ffbc2978d4b887960f307f77b9.zip
Version bumped under new GPL-3 license. Add urandom USE flag.
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-dns/pdnsd')
-rw-r--r--net-dns/pdnsd/ChangeLog8
-rw-r--r--net-dns/pdnsd/files/digest-pdnsd-1.2.63
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild6
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.6.ebuild101
4 files changed, 112 insertions, 6 deletions
diff --git a/net-dns/pdnsd/ChangeLog b/net-dns/pdnsd/ChangeLog
index c7754799dd02..62672b7deddc 100644
--- a/net-dns/pdnsd/ChangeLog
+++ b/net-dns/pdnsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/pdnsd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.72 2007/07/13 07:46:00 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.73 2007/11/05 05:49:02 mrness Exp $
+
+*pdnsd-1.2.6 (05 Nov 2007)
+
+ 05 Nov 2007; Alin Năstac <mrness@gentoo.org> pdnsd-1.2.5-r1.ebuild,
+ +pdnsd-1.2.6.ebuild:
+ Version bumped under new GPL-3 license. Add urandom USE flag.
*pdnsd-1.2.5-r1 (13 Jul 2007)
diff --git a/net-dns/pdnsd/files/digest-pdnsd-1.2.6 b/net-dns/pdnsd/files/digest-pdnsd-1.2.6
new file mode 100644
index 000000000000..7e78d16db7f8
--- /dev/null
+++ b/net-dns/pdnsd/files/digest-pdnsd-1.2.6
@@ -0,0 +1,3 @@
+MD5 65c88e22152a885a0437578eedc8b118 pdnsd-1.2.6-par.tar.gz 451465
+RMD160 4d7fc3b4bafc6dafc41e4d4b00e601f7de200c53 pdnsd-1.2.6-par.tar.gz 451465
+SHA256 84a4165471856f71725e5dc958978d9aee671c33b94a7dca0be09e60d99069ed pdnsd-1.2.6-par.tar.gz 451465
diff --git a/net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild b/net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild
index 9932eca1dbce..fef7c5e3a28f 100644
--- a/net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild,v 1.1 2007/07/13 07:46:00 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.5-r1.ebuild,v 1.2 2007/11/05 05:49:02 mrness Exp $
inherit eutils
@@ -94,10 +94,6 @@ src_test() {
}
pkg_preinst() {
- # Duplicated so that binary packages work
- enewgroup pdnsd
- enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
-
# Copy cache from older versions
[ -f "${ROOT}/var/lib/pdnsd/pdnsd.cache" ] && \
cp "${ROOT}/var/lib/pdnsd/pdnsd.cache" "${D}/var/cache/pdnsd/pdnsd.cache"
diff --git a/net-dns/pdnsd/pdnsd-1.2.6.ebuild b/net-dns/pdnsd/pdnsd-1.2.6.ebuild
new file mode 100644
index 000000000000..ffb2417a0018
--- /dev/null
+++ b/net-dns/pdnsd/pdnsd-1.2.6.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.6.ebuild,v 1.1 2007/11/05 05:49:02 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Proxy DNS server with permanent caching"
+HOMEPAGE="http://www.phys.uu.nl/~rombouts/pdnsd.html"
+SRC_URI="http://www.phys.uu.nl/~rombouts/pdnsd/releases/${P}-par.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~s390 ~sparc ~x86"
+IUSE="debug ipv6 isdn nptl underscores urandom"
+
+pkg_setup() {
+ enewgroup pdnsd
+ enewuser pdnsd -1 -1 /var/lib/pdnsd pdnsd
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --with-debug=3"
+ use nptl && myconf="${myconf} --with-thread-lib=NPTL"
+ use urandom && myconf="${myconf} --with-random-device=/dev/urandom"
+
+ econf \
+ --sysconfdir=/etc/pdnsd \
+ --with-cachedir=/var/cache/pdnsd \
+ --with-default-id=pdnsd \
+ $(use_enable ipv6) \
+ $(use_enable isdn) \
+ $(use_enable underscores) \
+ ${myconf} \
+ || die "bad configure"
+
+ emake all || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
+ docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
+ docinto html ; dohtml doc/html/*
+ docinto txt ; dodoc doc/txt/*
+ newdoc doc/pdnsd.conf pdnsd.conf.sample
+
+ newinitd "${FILESDIR}/pdnsd.rc6" pdnsd
+ newinitd "${FILESDIR}/pdnsd.online" pdnsd-online
+
+ dodir /etc/conf.d
+ local config="${D}/etc/conf.d/pdnsd-online"
+
+ echo -e "# Enter the interface that connects you to the dns servers" >> "${config}"
+ echo "# This will correspond to /etc/init.d/net.${IFACE}" >> "${config}"
+ echo -e "\n# IMPORTANT: Be sure to run depscan.sh after modifiying IFACE" >> "${config}"
+ echo "IFACE=ppp0" >> "${config}"
+
+ config="${D}/etc/conf.d/pdnsd"
+ "${D}/usr/sbin/pdnsd" --help | sed "s/^/# /g" > "${config}"
+ echo "# Command line options" >> "${config}"
+ use ipv6 && echo PDNSDCONFIG="-a" >> "${config}" \
+ || echo PDNSDCONFIG="" >> "${config}"
+
+ # gentoo resolvconf support
+ exeinto /etc/resolvconf/update.d
+ newexe "${FILESDIR}/pdnsd.resolvconf" pdnsd
+}
+
+src_test() {
+ if [ -x /usr/bin/dig ]; then
+ mkdir "${T}/pdnsd"
+ echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
+ IPS=$(grep ^nameserver /etc/resolv.conf | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
+ sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
+ > "${T}/pdnsd.conf.test"
+ src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
+ sleep 3
+
+ find "${T}" -ls
+ [ -s "${T}/pid" ] || die "empty or no pid file created"
+ [ -S "${T}/pdnsd/pdnsd.status" ] || die "no socket created"
+ src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || die "failed to start the daemon"
+ src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" status || die "failed to communicate with the daemon"
+ sleep 3
+
+ dig @127.0.0.1 -p 33455 www.gentoo.org | fgrep "status: NOERROR" || die "www.gentoo.org lookup failed"
+ kill $(<"${T}/pid") || die "failed to terminate daemon"
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "Add pdnsd to your default runlevel - rc-update add pdnsd default"
+ elog ""
+ elog "Add pdnsd-online to your online runlevel."
+ elog "The online interface will be listed in /etc/conf.d/pdnsd-online"
+ elog ""
+ elog "Sample config file in /etc/pdnsd/pdnsd.conf.sample"
+}