summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-11-16 20:41:42 +0000
committerSven Wegener <swegener@gentoo.org>2008-11-16 20:41:42 +0000
commitb67cd19a870a42b6a6cce7fd784e4a89c7247434 (patch)
treeffad67d638c0e365c0cef42d97655afae76d84c1 /net-dns/pdns
parentFix typo in build system for indent test #247080 by Mark Nowiasz. (diff)
downloadgentoo-2-b67cd19a870a42b6a6cce7fd784e4a89c7247434.tar.gz
gentoo-2-b67cd19a870a42b6a6cce7fd784e4a89c7247434.tar.bz2
gentoo-2-b67cd19a870a42b6a6cce7fd784e4a89c7247434.zip
Version bump.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc5 x86_64)
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/ChangeLog7
-rw-r--r--net-dns/pdns/pdns-2.9.21.2.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index 6df754d0d9df..e6ae9d24576b 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdns
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.55 2008/09/04 10:51:37 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.56 2008/11/16 20:41:42 swegener Exp $
+
+*pdns-2.9.21.2 (16 Nov 2008)
+
+ 16 Nov 2008; Sven Wegener <swegener@gentoo.org> +pdns-2.9.21.2.ebuild:
+ Version bump.
04 Sep 2008; Sven Wegener <swegener@gentoo.org> -pdns-2.9.21.ebuild:
Cleanup.
diff --git a/net-dns/pdns/pdns-2.9.21.2.ebuild b/net-dns/pdns/pdns-2.9.21.2.ebuild
new file mode 100644
index 000000000000..3dfb2d0605db
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.21.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.21.2.ebuild,v 1.1 2008/11/16 20:41:42 swegener Exp $
+
+inherit multilib eutils autotools
+
+DESCRIPTION="The PowerDNS Daemon"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ldap mysql postgres sqlite sqlite3 static tdb opendbx"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )
+ sqlite? ( =dev-db/sqlite-2.8* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ opendbx? ( dev-db/opendbx )
+ tdb? ( dev-libs/tdb )
+ >=dev-libs/boost-1.31"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/2.9.18-default-mysql-options.patch
+ epatch "${FILESDIR}"/2.9.20-ldap-deprecated.patch
+ epatch "${FILESDIR}"/2.9.21-gcc-4.3.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ local modules="pipe geo" myconf=""
+
+ use mysql && modules="${modules} gmysql"
+ use postgres && modules="${modules} gpgsql"
+ use sqlite && modules="${modules} gsqlite"
+ use sqlite3 && modules="${modules} gsqlite3"
+ use opendbx && modules="${modules} opendbx"
+ use ldap && modules="${modules} ldap"
+ use tdb && modules="${modules} xdb"
+ use debug && myconf="${myconf} --enable-verbose-logging"
+
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --disable-recursor \
+ --with-modules= \
+ --with-dynmodules="${modules}" \
+ --with-pgsql-includes=/usr/include \
+ --with-pgsql-lib=/usr/$(get_libdir) \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-sqlite-lib=/usr/$(get_libdir) \
+ --with-sqlite3-lib=/usr/$(get_libdir) \
+ $(use_enable static static-binaries) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc
+ then
+ emake -C codedocs codedocs || die "emake codedocs failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ doinitd "${FILESDIR}"/pdns
+
+ keepdir /var/empty
+
+ dodoc ChangeLog README TODO
+ use doc && dohtml -r codedocs/html/.
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+}
+
+pkg_preinst() {
+ enewgroup pdns
+ enewuser pdns -1 -1 /var/empty pdns
+}
+
+pkg_postinst() {
+ elog
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+ elog
+}