summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-03-31 12:46:46 +0000
committerSven Wegener <swegener@gentoo.org>2008-03-31 12:46:46 +0000
commit54e3b7dcf8d0675b0171d7085032bed47052efe1 (patch)
treeb94c4d288df5c1e154e76a59d3eecdba00906d07 /net-dns/pdns-recursor
parentfix incorrect changelog format (diff)
downloadgentoo-2-54e3b7dcf8d0675b0171d7085032bed47052efe1.tar.gz
gentoo-2-54e3b7dcf8d0675b0171d7085032bed47052efe1.tar.bz2
gentoo-2-54e3b7dcf8d0675b0171d7085032bed47052efe1.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/ChangeLog11
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-3.1.5-chdir.patch13
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-3.1.5-statedir.patch9
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.1.5.ebuild51
4 files changed, 82 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 94e02acf3dde..e50c681d4c2f 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/pdns-recursor
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.15 2007/09/22 19:35:40 swegener Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.16 2008/03/31 12:46:46 swegener Exp $
+
+*pdns-recursor-3.1.5 (31 Mar 2008)
+
+ 31 Mar 2008; Sven Wegener <swegener@gentoo.org>
+ +files/pdns-recursor-3.1.5-chdir.patch,
+ +files/pdns-recursor-3.1.5-statedir.patch, +pdns-recursor-3.1.5.ebuild:
+ Version bump.
22 Sep 2007; Sven Wegener <swegener@gentoo.org>
+files/pdns-recursor-3.1.4-gcc42.patch, pdns-recursor-3.1.4.ebuild:
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-3.1.5-chdir.patch b/net-dns/pdns-recursor/files/pdns-recursor-3.1.5-chdir.patch
new file mode 100644
index 000000000000..d30ca4286c02
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-3.1.5-chdir.patch
@@ -0,0 +1,13 @@
+--- pdns-recursor/pdns_recursor.cc
++++ pdns-recursor/pdns_recursor.cc
+@@ -1565,6 +1565,10 @@
+ }
+ }
+
++ // this is needed to really get into the chroot. and even without chroot
++ // enabled it's nice to not block the directory we're currently in.
++ chdir("/");
++
+ Utility::dropPrivs(newuid, newgid);
+ g_fdm->addReadFD(s_rcc.d_fd, handleRCC); // control channel
+ #endif
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-3.1.5-statedir.patch b/net-dns/pdns-recursor/files/pdns-recursor-3.1.5-statedir.patch
new file mode 100644
index 000000000000..2bd1690084a3
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-3.1.5-statedir.patch
@@ -0,0 +1,9 @@
+--- pdns-recursor/config.h
++++ pdns-recursor/config.h
+@@ -1,5 +1,5 @@
+ #define SYSCONFDIR "/etc/powerdns/"
+-#define LOCALSTATEDIR "/var/run/"
++#define LOCALSTATEDIR "/var/lib/powerdns"
+ #define VERSION "3.1.5"
+ #define RECURSOR
+ #ifndef WIN32
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.1.5.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.1.5.ebuild
new file mode 100644
index 000000000000..d49817131d98
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.1.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.5.ebuild,v 1.1 2008/03/31 12:46:46 swegener Exp $
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33.1"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-statedir.patch
+ epatch "${FILESDIR}"/${P}-chdir.patch
+}
+
+src_compile() {
+ filter-flags -ftree-vectorize
+
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control || die "dosbin failed"
+ doman pdns_recursor.1 rec_control.1 || die "doman failed"
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf || die "doins failed"
+
+ doinitd "${FILESDIR}"/precursor || die "doinitd failed"
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}