summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-12-03 03:46:55 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-12-03 03:46:55 +0000
commitc50f183cfc68ae1c4ee1370e4520e68265314589 (patch)
tree3aabfb0a547e8f0abeebf2767f4103dbe6490b8b /net-dns/maradns/maradns-1.2.12.04.ebuild
parentVersion bump (diff)
downloadgentoo-2-c50f183cfc68ae1c4ee1370e4520e68265314589.tar.gz
gentoo-2-c50f183cfc68ae1c4ee1370e4520e68265314589.tar.bz2
gentoo-2-c50f183cfc68ae1c4ee1370e4520e68265314589.zip
Version bumped, Support to syslog, bug #156564.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-dns/maradns/maradns-1.2.12.04.ebuild')
-rw-r--r--net-dns/maradns/maradns-1.2.12.04.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-dns/maradns/maradns-1.2.12.04.ebuild b/net-dns/maradns/maradns-1.2.12.04.ebuild
new file mode 100644
index 000000000000..c0de67e0cd2a
--- /dev/null
+++ b/net-dns/maradns/maradns-1.2.12.04.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/maradns/maradns-1.2.12.04.ebuild,v 1.1 2006/12/03 03:46:54 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Proxy DNS server with permanent caching"
+HOMEPAGE="http://www.maradns.org/"
+SRC_URI="mirror://sourceforge/maradns/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:PREFIX/man:PREFIX/share/man:" \
+ -e "s:PREFIX/doc/maradns-\$VERSION:PREFIX/share/doc/${PF}:" \
+ build/install.locations || die
+ sed -i -e "s:-O2:${CFLAGS}:" build/Makefile.linux || die
+}
+
+src_compile() {
+ ./configure || die
+ emake CC="$(tc-getCC)" || die "compile problem"
+}
+
+src_install() {
+ dosbin server/maradns
+ # use authonly && newsbin server/maradns.authonly maradns
+ dosbin tcp/zoneserver
+
+ dobin tcp/getzone tcp/fetchzone tools/askmara tools/duende
+
+ doman doc/en/man/*.[1-9]
+
+ dodoc maradns.gpg.key
+ dodoc doc/en/{QuickStart,README,*.txt}
+ dohtml doc/en/*.html
+ dohtml -r doc/en/webpage
+
+ insinto /etc; newins doc/en/examples/example_mararc mararc
+ insinto /etc/maradns; newins doc/en/examples/example_csv2 db.example.net
+ keepdir /etc/maradns/logger
+
+ newinitd "${FILESDIR}"/maradns.rc6 maradns
+ newinitd "${FILESDIR}"/zoneserver.rc6 zoneserver
+}
+
+pkg_postinst() {
+ enewuser maradns 99 -1 /var/empty daemon
+}