summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-25 20:11:20 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-25 20:11:20 +0000
commit35fd8a959aba1ee4e8fca27a9a5c1e862aeab163 (patch)
tree2103a2f6ecaf9303d13f26f5e7fa666616fe5242 /net-dns/libidn
parentDelete older ebuild. (diff)
downloadgentoo-2-35fd8a959aba1ee4e8fca27a9a5c1e862aeab163.tar.gz
gentoo-2-35fd8a959aba1ee4e8fca27a9a5c1e862aeab163.tar.bz2
gentoo-2-35fd8a959aba1ee4e8fca27a9a5c1e862aeab163.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-dns/libidn')
-rw-r--r--net-dns/libidn/ChangeLog7
-rw-r--r--net-dns/libidn/libidn-1.21.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/net-dns/libidn/ChangeLog b/net-dns/libidn/ChangeLog
index 764863ad30bf..e4ebf97a1f11 100644
--- a/net-dns/libidn/ChangeLog
+++ b/net-dns/libidn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/libidn
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.130 2011/03/01 19:00:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.131 2011/04/25 20:11:20 jer Exp $
+
+*libidn-1.21 (25 Apr 2011)
+
+ 25 Apr 2011; Jeroen Roovers <jer@gentoo.org> +libidn-1.21.ebuild:
+ Version bump.
*libidn-1.20 (01 Mar 2011)
diff --git a/net-dns/libidn/libidn-1.21.ebuild b/net-dns/libidn/libidn-1.21.ebuild
new file mode 100644
index 000000000000..6043502ba560
--- /dev/null
+++ b/net-dns/libidn/libidn-1.21.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/libidn-1.21.ebuild,v 1.1 2011/04/25 20:11:20 jer Exp $
+
+inherit java-pkg-opt-2 mono elisp-common
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="http://www.gnu.org/software/libidn/"
+SRC_URI="mirror://gnu/libidn/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc emacs java mono nls static-libs"
+
+COMMON_DEPEND="emacs? ( virtual/emacs )
+ mono? ( >=dev-lang/mono-0.95 )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( >=sys-devel/gettext-0.17 )
+ java? (
+ >=virtual/jdk-1.4
+ doc? ( dev-java/gjdoc )
+ )"
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )
+ java? ( >=virtual/jre-1.4 )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ # bundled, with wrong bytecode
+ rm "${S}/java/${P}.jar" || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable java) \
+ $(use_enable mono csharp mono) \
+ $(use_enable static-libs static) \
+ --disable-valgrind-tests \
+ --with-lispdir="${SITELISP}/${PN}" \
+ --with-packager="Gentoo" \
+ --with-packager-version="r${PR}" \
+ --with-packager-bug-reports="https://bugs.gentoo.org" \
+ || die
+
+ emake || die
+
+ if use emacs; then
+ elisp-compile src/*.el || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO || die
+
+ if use emacs; then
+ # *.el are installed by the build system
+ elisp-install ${PN} src/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ else
+ rm -rf "${D}/usr/share/emacs"
+ fi
+
+ if use doc ; then
+ dohtml -r doc/reference/html/* || die
+ fi
+
+ if use java ; then
+ java-pkg_newjar java/${P}.jar ${PN}.jar || die
+ rm -rf "${D}"/usr/share/java || die
+
+ if use doc ; then
+ java-pkg_dojavadoc doc/java
+ fi
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}