summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2009-03-30 04:14:35 +0000
committerPatrick McLean <chutzpah@gentoo.org>2009-03-30 04:14:35 +0000
commit6914ab58009d14ad7c1bfbb3d560326f2249a8b3 (patch)
tree2524a585f0a821750c40707e2535b60969f07914 /net-dns/dnsmasq
parentThe debug use flag just enabled -g, use CFLAGS if you want that (diff)
downloadgentoo-2-6914ab58009d14ad7c1bfbb3d560326f2249a8b3.tar.gz
gentoo-2-6914ab58009d14ad7c1bfbb3d560326f2249a8b3.tar.bz2
gentoo-2-6914ab58009d14ad7c1bfbb3d560326f2249a8b3.zip
Version bump (bug #259224).
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/ChangeLog10
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.47.ebuild67
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.47-fbsd-config.patch16
3 files changed, 91 insertions, 2 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 674bdbb302ae..75950a27270f 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/dnsmasq
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.175 2008/12/23 16:00:58 chutzpah Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.176 2009/03/30 04:14:34 chutzpah Exp $
+
+*dnsmasq-2.47 (30 Mar 2009)
+
+ 30 Mar 2009; Patrick McLean <chutzpah@gentoo.org>
+ +files/dnsmasq-2.47-fbsd-config.patch, +dnsmasq-2.47.ebuild:
+ Version bump (bug #259224).
*dnsmasq-2.46 (23 Dec 2008)
diff --git a/net-dns/dnsmasq/dnsmasq-2.47.ebuild b/net-dns/dnsmasq/dnsmasq-2.47.ebuild
new file mode 100644
index 000000000000..1140d2ca4353
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.47.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.47.ebuild,v 1.1 2009/03/30 04:14:34 chutzpah Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+#SRC_URI="http://www.thekelleys.org.uk/dnsmasq/release-candidates/${MY_P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="dbus ipv6 nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i '/^AWK/s:nawk:gawk:' Makefile #214865
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${P}-fbsd-config.patch"
+}
+
+src_compile() {
+ use tftp || append-flags -DNO_TFTP
+ use ipv6 || append-flags -DNO_IPV6
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ all$(use nls && echo "-i18n") || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n") || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.47-fbsd-config.patch b/net-dns/dnsmasq/files/dnsmasq-2.47-fbsd-config.patch
new file mode 100644
index 000000000000..38a3679bd240
--- /dev/null
+++ b/net-dns/dnsmasq/files/dnsmasq-2.47-fbsd-config.patch
@@ -0,0 +1,16 @@
+diff -ur dnsmasq-2.47.orig/src/config.h dnsmasq-2.47/src/config.h
+--- dnsmasq-2.47.orig/src/config.h 2009-02-05 07:14:24.000000000 -0500
++++ dnsmasq-2.47/src/config.h 2009-03-30 00:04:52.000000000 -0400
+@@ -50,11 +50,7 @@
+ #endif
+
+ #ifndef CONFFILE
+-# if defined(__FreeBSD__)
+-# define CONFFILE "/usr/local/etc/dnsmasq.conf"
+-# else
+-# define CONFFILE "/etc/dnsmasq.conf"
+-# endif
++# define CONFFILE "/etc/dnsmasq.conf"
+ #endif
+
+ #define DEFLEASE 3600 /* default lease time, 1 hour */