summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-02-08 15:28:18 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-02-08 15:28:18 +0000
commitd922832e2cecc22bf7ac9a91aae498aa2b0e1404 (patch)
tree6b9ba5a94b1510da9c9c761058ed3306f6b1b77b /net-dns/dnsmasq/files
parentFix the patch to fix the qmake parser. (diff)
downloadgentoo-2-d922832e2cecc22bf7ac9a91aae498aa2b0e1404.tar.gz
gentoo-2-d922832e2cecc22bf7ac9a91aae498aa2b0e1404.tar.bz2
gentoo-2-d922832e2cecc22bf7ac9a91aae498aa2b0e1404.zip
Add patch to fix compilation on bsd, clean out some stale files and previous version.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-dns/dnsmasq/files')
-rw-r--r--net-dns/dnsmasq/files/digest-dnsmasq-2.363
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.37-bsd.patch29
-rw-r--r--net-dns/dnsmasq/files/dnsmasq221-netlink.diff10
-rw-r--r--net-dns/dnsmasq/files/dnsmasq232-ldflags.diff11
4 files changed, 29 insertions, 24 deletions
diff --git a/net-dns/dnsmasq/files/digest-dnsmasq-2.36 b/net-dns/dnsmasq/files/digest-dnsmasq-2.36
deleted file mode 100644
index f046a4c2cf28..000000000000
--- a/net-dns/dnsmasq/files/digest-dnsmasq-2.36
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 392bf22dbff84eae010e149f15cd4136 dnsmasq-2.36.tar.gz 268105
-RMD160 14d1616cb0d57addf4afa3a9725a97cf5f479884 dnsmasq-2.36.tar.gz 268105
-SHA256 0acc17cf059bb9b0ecde9a57ca5f09aadfebf99fe6b4ebcddf5800875aee3242 dnsmasq-2.36.tar.gz 268105
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.37-bsd.patch b/net-dns/dnsmasq/files/dnsmasq-2.37-bsd.patch
new file mode 100644
index 000000000000..dd7e42c549d5
--- /dev/null
+++ b/net-dns/dnsmasq/files/dnsmasq-2.37-bsd.patch
@@ -0,0 +1,29 @@
+--- src/rfc2131.c.orig 2007-02-07 20:52:07.000000000 +0000
++++ src/rfc2131.c 2007-02-06 22:13:02.000000000 +0000
+@@ -101,16 +101,22 @@
+ {
+ if (hwlen == 0 && clid && clid_len > 3)
+ {
+- if ((clid[0] == ARPHRD_EUI64 && hwtype == ARPHRD_IEEE1394) || clid[0] == hwtype)
++ if (clid[0] == hwtype)
+ {
+ *len_out = clid_len - 1 ;
+ return clid + 1;
+ }
+- else
++
++#if defined(ARPHRD_EUI64) && defined(ARPHRD_IEEE1394)
++ if (clid[0] == ARPHRD_EUI64 && hwtype == ARPHRD_IEEE1394)
+ {
+- *len_out = clid_len;
+- return clid;
++ *len_out = clid_len - 1 ;
++ return clid + 1;
+ }
++#endif
++
++ *len_out = clid_len;
++ return clid;
+ }
+
+ *len_out = hwlen;
diff --git a/net-dns/dnsmasq/files/dnsmasq221-netlink.diff b/net-dns/dnsmasq/files/dnsmasq221-netlink.diff
deleted file mode 100644
index 221114765434..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq221-netlink.diff
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -urN dnsmasq-2.21.orig/src/netlink.c dnsmasq-2.21/src/netlink.c
---- dnsmasq-2.21.orig/src/netlink.c 2005-03-13 10:37:44.000000000 +0100
-+++ dnsmasq-2.21/src/netlink.c 2005-03-24 12:31:52.000000000 +0100
-@@ -16,6 +16,7 @@
-
- #ifdef HAVE_RTNETLINK
-
-+#include <linux/types.h>
- #include <linux/netlink.h>
- #include <linux/rtnetlink.h>
diff --git a/net-dns/dnsmasq/files/dnsmasq232-ldflags.diff b/net-dns/dnsmasq/files/dnsmasq232-ldflags.diff
deleted file mode 100644
index 1eb7deb859ae..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq232-ldflags.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- bld/Makefile 2006-06-08 21:22:22.000000000 +0200
-+++ bld/Makefile 2006-06-08 21:22:56.000000000 +0200
-@@ -9,7 +9,7 @@
- $(CC) $(CFLAGS) $(COPTS) $(I18N) `echo $(COPTS) | ../bld/pkg-wrapper $(PKG_CONFIG) --cflags dbus-1` $(RPM_OPT_FLAGS) -Wall -W -c $<
-
- dnsmasq : $(OBJS)
-- $(CC) -o $@ $(OBJS) `echo $(COPTS) | ../bld/pkg-wrapper $(PKG_CONFIG) --libs dbus-1` $(LIBS)
-+ $(CC) $(LDFLAGS) -o $@ $(OBJS) `echo $(COPTS) | ../bld/pkg-wrapper $(PKG_CONFIG) --libs dbus-1` $(LIBS)
-
- dnsmasq.pot : $(OBJS:.o=.c) dnsmasq.h config.h
- xgettext -d dnsmasq --foreign-user --keyword=_ -o dnsmasq.pot -i $(OBJS:.o=.c)