summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-04-11 13:08:58 +0000
committerDane Smith <c1pher@gentoo.org>2011-04-11 13:08:58 +0000
commit07071bf566dc86153ce63c877b5901052aa5654f (patch)
treea7da87147ed05887ff2e9de8add457445de60088 /net-dns/djbdns
parentFix MODULE_AUTHOR (#363097). Thanks to Denis Sokolovsky (diff)
downloadgentoo-2-07071bf566dc86153ce63c877b5901052aa5654f.tar.gz
gentoo-2-07071bf566dc86153ce63c877b5901052aa5654f.tar.bz2
gentoo-2-07071bf566dc86153ce63c877b5901052aa5654f.zip
new-dns/djbdns: Add new patch to fix parallel compilation issues wrt bug 362771.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/djbdns')
-rw-r--r--net-dns/djbdns/ChangeLog8
-rw-r--r--net-dns/djbdns/djbdns-1.05-r24.ebuild5
-rw-r--r--net-dns/djbdns/files/makefile-parallel.patch80
3 files changed, 90 insertions, 3 deletions
diff --git a/net-dns/djbdns/ChangeLog b/net-dns/djbdns/ChangeLog
index 4fa200d33ad7..b4fd60ac4a7b 100644
--- a/net-dns/djbdns/ChangeLog
+++ b/net-dns/djbdns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/djbdns
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.123 2011/04/04 18:58:49 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.124 2011/04/11 13:08:57 c1pher Exp $
+
+ 11 Apr 2011; Dane Smith <c1pher@gentoo.org> djbdns-1.05-r24.ebuild,
+ +files/makefile-parallel.patch:
+ Add patch to fix parallel make issues when USE="ipv6" wrt bug 362771.
+ Thanks
+ Michael for spotting and fixing this.
04 Apr 2011; Dane Smith <c1pher@gentoo.org> djbdns-1.05-r24.ebuild:
Remove parallel compilation workaround. Seems to be fixed upstream.
diff --git a/net-dns/djbdns/djbdns-1.05-r24.ebuild b/net-dns/djbdns/djbdns-1.05-r24.ebuild
index 84bd9960cccd..0c9f560acc00 100644
--- a/net-dns/djbdns/djbdns-1.05-r24.ebuild
+++ b/net-dns/djbdns/djbdns-1.05-r24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.3 2011/04/04 18:58:49 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.4 2011/04/11 13:08:57 c1pher Exp $
EAPI="2"
inherit eutils flag-o-matic toolchain-funcs
@@ -54,7 +54,8 @@ src_prepare() {
# Fix CVE2008-4392
epatch \
"${FILESDIR}/CVE2008-4392_0001-dnscache-merge-similar-outgoing-queries-ipv6.patch" \
- "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch"
+ "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch" \
+ "${FILESDIR}/makefile-parallel.patch"
cd "${S}-noipv6"
fi
diff --git a/net-dns/djbdns/files/makefile-parallel.patch b/net-dns/djbdns/files/makefile-parallel.patch
new file mode 100644
index 000000000000..51c0317eca94
--- /dev/null
+++ b/net-dns/djbdns/files/makefile-parallel.patch
@@ -0,0 +1,80 @@
+--- a/Makefile 2011-04-07 21:49:48.140645070 -0400
++++ b/Makefile 2011-04-07 22:24:06.595746444 -0400
+@@ -332,7 +332,7 @@
+
+ dns_transmit.o: \
+ compile dns_transmit.c socket.h uint16.h alloc.h error.h byte.h \
+-uint16.h dns.h stralloc.h gen_alloc.h iopause.h taia.h tai.h uint64.h \
++uint32.h dns.h stralloc.h gen_alloc.h iopause.h taia.h tai.h uint64.h \
+ taia.h
+ ./compile dns_transmit.c
+
+@@ -860,15 +860,15 @@
+ rm -f trylsock.o trylsock
+
+ socket_accept.o: \
+-compile socket_accept.c byte.h socket.h uint16.h
++compile socket_accept.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_accept.c
+
+ socket_accept6.o: \
+-compile socket_accept6.c byte.h socket.h uint16.h
++compile socket_accept6.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_accept6.c
+
+ socket_bind.o: \
+-compile socket_bind.c byte.h socket.h uint16.h
++compile socket_bind.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_bind.c
+
+ socket_bind6.o: \
+@@ -876,7 +876,7 @@
+ ./compile socket_bind6.c
+
+ socket_conn.o: \
+-compile socket_conn.c byte.h socket.h uint16.h
++compile socket_conn.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_conn.c
+
+ socket_connect6.o: \
+@@ -884,11 +884,11 @@
+ ./compile socket_connect6.c
+
+ socket_listen.o: \
+-compile socket_listen.c socket.h uint16.h
++compile socket_listen.c socket.h uint16.h uint32.h
+ ./compile socket_listen.c
+
+ socket_recv.o: \
+-compile socket_recv.c byte.h socket.h uint16.h
++compile socket_recv.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_recv.c
+
+ socket_recv6.o: \
+@@ -896,7 +896,7 @@
+ ./compile socket_recv6.c
+
+ socket_send.o: \
+-compile socket_send.c byte.h socket.h uint16.h
++compile socket_send.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_send.c
+
+ socket_send6.o: \
+@@ -904,7 +904,7 @@
+ ./compile socket_send6.c
+
+ socket_tcp.o: \
+-compile socket_tcp.c ndelay.h socket.h uint16.h
++compile socket_tcp.c ndelay.h socket.h uint16.h uint32.h
+ ./compile socket_tcp.c
+
+ socket_tcp6.o: \
+@@ -912,7 +912,7 @@
+ ./compile socket_tcp6.c
+
+ socket_udp.o: \
+-compile socket_udp.c ndelay.h socket.h uint16.h
++compile socket_udp.c ndelay.h socket.h uint16.h uint32.h
+ ./compile socket_udp.c
+
+ socket_udp6.o: \