summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-07-21 20:56:35 +0000
committerAlec Warner <antarus@gentoo.org>2007-07-21 20:56:35 +0000
commit314ae31114a9722ea833e560371ffba7f9fd8e8f (patch)
treec14c39a8cc340f144c02d15f4ebdf9ce20f42830 /net-dns/ddclient
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-314ae31114a9722ea833e560371ffba7f9fd8e8f.tar.gz
gentoo-2-314ae31114a9722ea833e560371ffba7f9fd8e8f.tar.bz2
gentoo-2-314ae31114a9722ea833e560371ffba7f9fd8e8f.zip
Bump ddclient for bug 124333, thanks to Paul Bredbury and Michael A. Smith
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-dns/ddclient')
-rw-r--r--net-dns/ddclient/ChangeLog7
-rw-r--r--net-dns/ddclient/ddclient-3.7.2.ebuild79
-rw-r--r--net-dns/ddclient/files/digest-ddclient-3.7.23
3 files changed, 88 insertions, 1 deletions
diff --git a/net-dns/ddclient/ChangeLog b/net-dns/ddclient/ChangeLog
index 38ec201d8823..0b095b8d87f6 100644
--- a/net-dns/ddclient/ChangeLog
+++ b/net-dns/ddclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ddclient
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.25 2007/04/28 17:21:25 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.26 2007/07/21 20:56:35 antarus Exp $
+
+*ddclient-3.7.2 (21 Jul 2007)
+
+ 21 Jul 2007; Alec Warner <antarus@gentoo.org> +ddclient-3.7.2.ebuild:
+ Bump ddclient for bug 124333, thanks to Paul Bredbury and Michael A. Smith
28 Apr 2007; Sven Wegener <swegener@gentoo.org> ddclient-3.6.3.ebuild:
Fix *initd, *confd and *envd calls (#173884, #174266)
diff --git a/net-dns/ddclient/ddclient-3.7.2.ebuild b/net-dns/ddclient/ddclient-3.7.2.ebuild
new file mode 100644
index 000000000000..11415157f36c
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.7.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.7.2.ebuild,v 1.1 2007/07/21 20:56:35 antarus Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl updater client for dynamic DNS services"
+HOMEPAGE="http://ddclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl"
+
+RDEPEND=">=dev-lang/perl-5.1
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-reasonable-security.patch"
+
+ einfo "Applying version string fix"
+ if ! sed -i "s/3\.7\.1/$PV/" "$PN"; then
+ eerror "Failed to update ddclient's internal version string"
+ eerror 'ddclient 3.7.2 will erroneously report a version of 3.7.1'
+ fi
+
+ # Remove pid line, because it is specified in /etc/conf.d/ddclient
+ einfo "Applying PID setup"
+ if ! sed -i "/^pid=*/d" "sample-etc_${PN}.conf"; then
+ eerror "Failed to remove pid from /etc/$PN/$PN.conf"
+ eerror "Please set the PID in /etc/conf.d/$PN, not /etc/$PN/$PN.conf"
+ fi
+
+ if ! use ssl; then
+ einfo "Disabling ssl per your useflags"
+ sed -i "/^ssl=*/d" "sample-etc_${PN}.conf" ||
+ eerror "Failed to remove ssl from /etc/$PN/$PN.conf"
+ fi
+}
+
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+ dodoc README* Change* COPYRIGHT sample*
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "newinitd failed"
+
+ # Filename of sample conf - use live filename if available
+ local sample=${PN}.conf
+ [[ -e "${ROOT}/etc/${PN}/${sample}" ]] && sample="${sample}.sample"
+
+ insinto /etc/${PN}
+ insopts -m 0640 -o root -g ${PN}
+ newins sample-etc_${PN}.conf "${sample}" || die "newins conf failed"
+
+ insinto /etc/conf.d
+ insopts -m 0644 -o root -g root
+ newins "${FILESDIR}"/${PN}.confd ${PN} || die "newins confd failed"
+
+ diropts -m 0755 -o ${PN} -g ${PN}
+ keepdir /var/{cache,run}/${PN}
+}
+pkg_postinst() {
+ use ssl && return
+ ewarn
+ ewarn "$PN will not have support for ssl, which means your dynamic DNS account"
+ ewarn "information -- including your password -- will be sent over the Internet in the"
+ ewarn "clear. To secure your information, add 'ssl' to your USEflags,"
+ ewarn "emerge -N ddclient, and add 'ssl=yes' to /etc/$PN/$PN.conf"
+ ewarn
+} \ No newline at end of file
diff --git a/net-dns/ddclient/files/digest-ddclient-3.7.2 b/net-dns/ddclient/files/digest-ddclient-3.7.2
new file mode 100644
index 000000000000..bd4c9926be21
--- /dev/null
+++ b/net-dns/ddclient/files/digest-ddclient-3.7.2
@@ -0,0 +1,3 @@
+MD5 53fa5f06788f8732bff3ee7098fadc4d ddclient-3.7.2.tar.gz 87040
+RMD160 fed9642560d74f462179edae92b8346e08cd514e ddclient-3.7.2.tar.gz 87040
+SHA256 7aedbeb5f737cd46794393bdf166fe6b856dc6c97d402a5dcfbfe6247bb37fe2 ddclient-3.7.2.tar.gz 87040