summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-09-08 00:22:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-09-08 00:22:30 +0000
commit2626af856b766a4044e9554029cf9158473036c9 (patch)
tree391d67a9cbaf91b487efde280fd7c123272911f2 /net-dns/ddclient
parentwoops, not straight to stable (diff)
downloadgentoo-2-2626af856b766a4044e9554029cf9158473036c9.tar.gz
gentoo-2-2626af856b766a4044e9554029cf9158473036c9.tar.bz2
gentoo-2-2626af856b766a4044e9554029cf9158473036c9.zip
Version bump with some long needed improvements. Many thanks to: Paul Bredbury, Michael A. Smith, Arun Raghavan for their patience and their mad skillz
(Portage version: 2.1.1_rc1-r7)
Diffstat (limited to 'net-dns/ddclient')
-rw-r--r--net-dns/ddclient/ChangeLog12
-rw-r--r--net-dns/ddclient/ddclient-3.7.0.ebuild61
-rw-r--r--net-dns/ddclient/files/ddclient.initd49
-rw-r--r--net-dns/ddclient/files/digest-ddclient-3.7.03
4 files changed, 123 insertions, 2 deletions
diff --git a/net-dns/ddclient/ChangeLog b/net-dns/ddclient/ChangeLog
index 0232ee799519..b32baea56743 100644
--- a/net-dns/ddclient/ChangeLog
+++ b/net-dns/ddclient/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/ddclient
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.21 2005/08/23 21:58:23 dragonheart Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.22 2006/09/08 00:22:30 seemant Exp $
+
+*ddclient-3.7.0 (08 Sep 2006)
+
+ 08 Sep 2006; Seemant Kulleen <seemant@gentoo.org> +files/ddclient.initd,
+ +ddclient-3.7.0.ebuild:
+ Version bump with some long needed improvements. Many thanks to: Paul
+ Bredbury, Michael A. Smith, Arun Raghavan for their patience and their mad
+ skillz
23 Aug 2005; Daniel Black <dragonheart@gentoo.org> ddclient-3.6.6.ebuild:
removing /bin/false from enewuser - bug #103421
diff --git a/net-dns/ddclient/ddclient-3.7.0.ebuild b/net-dns/ddclient/ddclient-3.7.0.ebuild
new file mode 100644
index 000000000000..6bb1cfaba773
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.7.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.7.0.ebuild,v 1.1 2006/09/08 00:22:30 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl updater client for dynamic DNS services"
+HOMEPAGE="http://ddclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.1
+ dev-perl/IO-Socket-SSL"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-reasonable-security.patch
+
+ sed -i ${PN} \
+ -e 's:$etc$program.cache:/var/cache/ddclient/$program.cache:' \
+ || die "sed ${PN} failed"
+
+ # Remove pid line, because it is specified in /etc/conf.d/ddclient
+ sed -i sample-etc_${PN}.conf \
+ -e "/^pid=*/d" \
+ || die "sed sample failed"
+}
+
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+ dodoc README* Change* COPYRIGHT sample*
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # Determine name of sample configuration file
+ local sample=${PN}.conf
+ [[ -e /etc/${PN}/${sample} ]] && sample=${PN}-sample.conf
+
+ insinto /etc/${PN}
+ insopts -m 0640 -o root -g ${PN}
+ newins sample-etc_${PN}.conf ${sample}
+
+ insinto /etc/conf.d
+ insopts -m 0644 -o root -g root
+ newins "${FILESDIR}"/${PN}.confd ${PN}
+
+ diropts -m 0755 -o ${PN} -g ${PN}
+ keepdir /var/{cache,run}/${PN}
+}
+
diff --git a/net-dns/ddclient/files/ddclient.initd b/net-dns/ddclient/files/ddclient.initd
new file mode 100644
index 000000000000..3ec5283f9acb
--- /dev/null
+++ b/net-dns/ddclient/files/ddclient.initd
@@ -0,0 +1,49 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/files/ddclient.initd,v 1.1 2006/09/08 00:22:30 seemant Exp $
+
+# Default location if not specified in /etc/conf.d/ddclient
+PIDFILE=${PIDFILE:-/var/run/ddclient/ddclient.pid}
+
+depend() {
+ before cron
+ need net
+ use dns logger
+}
+
+checkconfig() {
+ local conf="/etc/ddclient/ddclient.conf"
+
+ if [[ -e "${conf}" ]] ; then
+ if [[ -n "$(find /etc/ddclient -maxdepth 1 -name ddclient.conf -perm +0004)" ]] ; then
+ eerror "${conf} must not be world-readable. Run e.g.:"
+ eerror " chmod 640 ${conf}"
+ eerror " chown root:ddclient ${conf}"
+ return 1
+ fi
+ else
+ eerror "/etc/ddclient/ddclient.conf is needed to run ddclient"
+ eerror "There is a sample file in /etc/ddclient/"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting DDClient"
+ start-stop-daemon \
+ --start \
+ --chuid ddclient \
+ --exec /usr/sbin/ddclient -- -pid="${PIDFILE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping DDClient"
+ start-stop-daemon \
+ --stop \
+ --signal USR1 \
+ --pidfile "${PIDFILE}"
+ eend $?
+}
diff --git a/net-dns/ddclient/files/digest-ddclient-3.7.0 b/net-dns/ddclient/files/digest-ddclient-3.7.0
new file mode 100644
index 000000000000..837ebf950428
--- /dev/null
+++ b/net-dns/ddclient/files/digest-ddclient-3.7.0
@@ -0,0 +1,3 @@
+MD5 67976f65c2aad267664267bed940ce18 ddclient-3.7.0.tar.gz 39515
+RMD160 3b682fd085e606a736a13289744ea8ce67df7ced ddclient-3.7.0.tar.gz 39515
+SHA256 2795ebafd2d439f2c887187cab7295f65ce4e03efa0156269d561f8dc0622b90 ddclient-3.7.0.tar.gz 39515