summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-01 00:16:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-01 00:16:34 +0000
commitd9873e4f495e40f7e0f4fcdc5f929adc0f6434d4 (patch)
tree3040550b32ee648b9a0fca20ce175ae6c90f4ea8 /net-dns/avahi
parentWe really need ~dev-libs/icu-4.8.1.1, bug 414103 (diff)
downloadgentoo-2-d9873e4f495e40f7e0f4fcdc5f929adc0f6434d4.tar.gz
gentoo-2-d9873e4f495e40f7e0f4fcdc5f929adc0f6434d4.tar.bz2
gentoo-2-d9873e4f495e40f7e0f4fcdc5f929adc0f6434d4.zip
Fix bug #411351 (broken parallel install with USE=utils).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/avahi')
-rw-r--r--net-dns/avahi/ChangeLog6
-rw-r--r--net-dns/avahi/avahi-0.6.30-r3.ebuild3
-rw-r--r--net-dns/avahi/files/avahi-0.6.30-parallel.patch34
3 files changed, 41 insertions, 2 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index 2d6dffc838ed..ad75ed223fd6 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.222 2012/02/12 18:55:26 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.223 2012/05/01 00:16:34 flameeyes Exp $
+
+ 01 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/avahi-0.6.30-parallel.patch, avahi-0.6.30-r3.ebuild:
+ Fix bug #411351 (broken parallel install with USE=utils).
12 Feb 2012; Mike Gilbert <floppym@gentoo.org> avahi-0.6.30-r3.ebuild:
Call python_convert_shebangs() only in correct combination of USE flags. Patch
diff --git a/net-dns/avahi/avahi-0.6.30-r3.ebuild b/net-dns/avahi/avahi-0.6.30-r3.ebuild
index e280ff387ccc..f7114ea41214 100644
--- a/net-dns/avahi/avahi-0.6.30-r3.ebuild
+++ b/net-dns/avahi/avahi-0.6.30-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.30-r3.ebuild,v 1.3 2012/02/12 18:55:26 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.30-r3.ebuild,v 1.4 2012/05/01 00:16:34 flameeyes Exp $
EAPI="3"
@@ -109,6 +109,7 @@ src_prepare() {
>py-compile
epatch "${FILESDIR}"/${P}-automake-1.11.2.patch #397477
+ epatch "${FILESDIR}"/${P}-parallel.patch #411351
eautoreconf
}
diff --git a/net-dns/avahi/files/avahi-0.6.30-parallel.patch b/net-dns/avahi/files/avahi-0.6.30-parallel.patch
new file mode 100644
index 000000000000..a75f99109c6c
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.30-parallel.patch
@@ -0,0 +1,34 @@
+From cb10a844f9e91322aca91340b7adc0db19c96b36 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
+Date: Mon, 30 Apr 2012 17:07:41 -0700
+Subject: [PATCH] build-sys: fix parallel install in avahi-utils
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The moment install-exec-local is called, we might still not have
+created ${DESTDIR}/${bindir} so we should make sure to create it
+first, and then try to chdir into it.
+
+Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
+---
+ avahi-utils/Makefile.am | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
+index a644b4a..1abc79a 100644
+--- a/avahi-utils/Makefile.am
++++ b/avahi-utils/Makefile.am
+@@ -54,7 +54,8 @@ avahi_set_host_name_CFLAGS = $(AM_CFLAGS)
+ avahi_set_host_name_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
+
+ install-exec-local:
+- cd $(DESTDIR)/$(bindir) && \
++ $(mkdir_p) $(DESTDIR)/$(bindir) && \
++ cd $(DESTDIR)/$(bindir) && \
+ rm -f avahi-resolve-host-name avahi-resolve-address avahi-browse-domains avahi-publish-address avahi-publish-service && \
+ $(LN_S) avahi-resolve avahi-resolve-host-name && \
+ $(LN_S) avahi-resolve avahi-resolve-address && \
+--
+1.7.8.6
+