summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-04-19 19:52:36 +0000
committerSven Wegener <swegener@gentoo.org>2008-04-19 19:52:36 +0000
commitd0d7f6c0c4438d0dcffc861fca31e179679411ea (patch)
tree8c203a8f8319229773208ae2aa327d4ad790c63b /net-dns/avahi
parentFix collision, bug #218455 (diff)
downloadgentoo-2-d0d7f6c0c4438d0dcffc861fca31e179679411ea.tar.gz
gentoo-2-d0d7f6c0c4438d0dcffc861fca31e179679411ea.tar.bz2
gentoo-2-d0d7f6c0c4438d0dcffc861fca31e179679411ea.zip
Adjust dependencies for split qt-4 packages, bug #217204. Add openrc-compatible autoipd.sh.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'net-dns/avahi')
-rw-r--r--net-dns/avahi/ChangeLog7
-rw-r--r--net-dns/avahi/avahi-0.6.22-r1.ebuild17
-rw-r--r--net-dns/avahi/files/autoipd-openrc.sh32
3 files changed, 51 insertions, 5 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index ae78fb08ad04..be93609d9415 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.136 2008/04/11 19:16:55 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.137 2008/04/19 19:52:35 swegener Exp $
+
+ 19 Apr 2008; Sven Wegener <swegener@gentoo.org> +files/autoipd-openrc.sh,
+ avahi-0.6.22-r1.ebuild:
+ Adjust dependencies for split qt-4 packages, bug #217204. Add
+ openrc-compatible autoipd.sh.
11 Apr 2008; Sven Wegener <swegener@gentoo.org> avahi-0.6.22-r1.ebuild:
We need dbus and gtk support for proper python support, bug #216835.
diff --git a/net-dns/avahi/avahi-0.6.22-r1.ebuild b/net-dns/avahi/avahi-0.6.22-r1.ebuild
index e9a7adffcb72..d7ca138326aa 100644
--- a/net-dns/avahi/avahi-0.6.22-r1.ebuild
+++ b/net-dns/avahi/avahi-0.6.22-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 2000-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.22-r1.ebuild,v 1.2 2008/04/11 19:16:55 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.22-r1.ebuild,v 1.3 2008/04/19 19:52:35 swegener Exp $
WANT_AUTOMAKE="1.9"
WANT_AUTOCONF="none"
+EAPI="1"
-inherit eutils mono python qt3 qt4 multilib autotools
+inherit eutils mono python multilib autotools
DESCRIPTION="System which facilitates service discovery on a local network"
HOMEPAGE="http://avahi.org/"
@@ -20,8 +21,13 @@ RDEPEND=">=dev-libs/libdaemon-0.11-r1
dev-libs/expat
>=dev-libs/glib-2
gdbm? ( sys-libs/gdbm )
- qt3? ( $(qt_min_version 3.3.6-r2) )
- qt4? ( $(qt4_min_version 4) )
+ qt3? ( x11-libs/qt:3 )
+ qt4? (
+ || (
+ x11-libs/qt-core:4
+ x11-libs/qt:4
+ )
+ )
gtk? (
>=x11-libs/gtk+-2.4.0
>=gnome-base/libglade-2.4.0
@@ -170,6 +176,9 @@ src_install() {
then
insinto /$(get_libdir)/rcscripts/net
doins "${FILESDIR}"/autoipd.sh
+
+ insinto /$(get_libdir)/rc/net
+ newins "${FILESDIR}"/autoipd-openrc.sh autoipd.sh
fi
dodoc docs/{AUTHORS,README,TODO}
diff --git a/net-dns/avahi/files/autoipd-openrc.sh b/net-dns/avahi/files/autoipd-openrc.sh
new file mode 100644
index 000000000000..839c6909fa90
--- /dev/null
+++ b/net-dns/avahi/files/autoipd-openrc.sh
@@ -0,0 +1,32 @@
+# Copyright (C) 2004-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# Contributed by Sven Wegener (swegener@gentoo.org)
+
+_config_vars="$_config_vars autoipd"
+
+autoipd_depend() {
+ program /usr/sbin/avahi-autoipd
+ after interface
+}
+
+autoipd_start() {
+ _exists true || return 1
+
+ eval args=\$autoipd_${IFVAR}
+
+ ebegin "Starting avahi-autoipd"
+ /usr/sbin/avahi-autoipd --daemonize --syslog --wait ${args} "${IFACE}"
+ eend "${?}" || return 1
+
+ _show_address
+
+ return 0
+}
+
+autoipd_stop() {
+ avahi-autoipd --check --syslog "${IFACE}" || return 0
+
+ ebegin "Stopping avahi-autoipd"
+ /usr/sbin/avahi-autoipd --kill --syslog "${IFACE}"
+ eend "${?}"
+}