summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-02-28 09:08:25 +0000
committerAlin Năstac <mrness@gentoo.org>2009-02-28 09:08:25 +0000
commitfe28022ca2e10aae8aed1e58dffd9c16beb9e07d (patch)
treee6d5694f58996d6e49baf2d10709ca23abb05945 /net-dialup
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-fe28022ca2e10aae8aed1e58dffd9c16beb9e07d.tar.gz
gentoo-2-fe28022ca2e10aae8aed1e58dffd9c16beb9e07d.tar.bz2
gentoo-2-fe28022ca2e10aae8aed1e58dffd9c16beb9e07d.zip
Fix bison-2.4 errors (#247981).
(Portage version: 2.1.6.4/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/linux-atm/ChangeLog8
-rw-r--r--net-dialup/linux-atm/files/linux-atm-2.5.0-bison24.patch47
-rw-r--r--net-dialup/linux-atm/linux-atm-2.5.0.ebuild5
3 files changed, 56 insertions, 4 deletions
diff --git a/net-dialup/linux-atm/ChangeLog b/net-dialup/linux-atm/ChangeLog
index 167cd6f1f392..f6b23a3cc456 100644
--- a/net-dialup/linux-atm/ChangeLog
+++ b/net-dialup/linux-atm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/linux-atm
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/linux-atm/ChangeLog,v 1.39 2008/08/22 21:38:44 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/linux-atm/ChangeLog,v 1.40 2009/02/28 09:08:25 mrness Exp $
+
+ 28 Feb 2009; Alin Năstac <mrness@gentoo.org>
+ +files/linux-atm-2.5.0-bison24.patch, linux-atm-2.5.0.ebuild:
+ Fix bison-2.4 errors (#247981).
22 Aug 2008; Markus Meier <maekke@gentoo.org> linux-atm-2.5.0.ebuild:
amd64 stable, bug #225777
diff --git a/net-dialup/linux-atm/files/linux-atm-2.5.0-bison24.patch b/net-dialup/linux-atm/files/linux-atm-2.5.0-bison24.patch
new file mode 100644
index 000000000000..f422c9c35e96
--- /dev/null
+++ b/net-dialup/linux-atm/files/linux-atm-2.5.0-bison24.patch
@@ -0,0 +1,47 @@
+--- linux-atm-2.5.0.orig/src/qgen/ql_y.y 2009-02-28 08:22:09.000000000 +0000
++++ linux-atm-2.5.0/src/qgen/ql_y.y 2009-02-28 08:41:35.000000000 +0000
+@@ -61,8 +61,10 @@
+ *walk = 0;
+ if (*start == ':') {
+ if (!(searching = strcmp(start+1,name)))
++ {
+ if (found) yyerror("multiple entries");
+ else found = 1;
++ }
+ continue;
+ }
+ if (searching) continue;
+@@ -308,9 +310,11 @@
+ $$->pos = $2;
+ $$->flush = !$3;
+ if ($$->pos == -1)
++ {
+ if ($$->size & 7)
+ yyerror("position required for small fields");
+ else $$->pos = 0;
++ }
+ $$->value = $5;
+ $$->structure = NULL;
+ $$->next = NULL;
+@@ -432,8 +436,8 @@
+ }
+ | TOK_ID opt_id list block
+ {
+- $$ = alloc_t(TAG);
+- $$->abort_id = abort_id;
++ $<tag>$ = alloc_t(TAG);
++ $<tag>$->abort_id = abort_id;
+ }
+ tags
+ {
+@@ -475,8 +479,8 @@
+ }
+ | TOK_ID opt_id list rep_block
+ {
+- $$ = alloc_t(TAG);
+- $$->abort_id = abort_id;
++ $<tag>$ = alloc_t(TAG);
++ $<tag>$->abort_id = abort_id;
+ }
+ rep_tags
+ {
diff --git a/net-dialup/linux-atm/linux-atm-2.5.0.ebuild b/net-dialup/linux-atm/linux-atm-2.5.0.ebuild
index 7e457f82068a..3bbc619bfbe3 100644
--- a/net-dialup/linux-atm/linux-atm-2.5.0.ebuild
+++ b/net-dialup/linux-atm/linux-atm-2.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/linux-atm/linux-atm-2.5.0.ebuild,v 1.10 2008/11/15 09:47:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/linux-atm/linux-atm-2.5.0.ebuild,v 1.11 2009/02/28 09:08:25 mrness Exp $
inherit eutils libtool flag-o-matic toolchain-funcs
@@ -20,6 +20,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-headers.patch
epatch "${FILESDIR}"/${P}-glibc28.patch
+ epatch "${FILESDIR}"/${P}-bison24.patch
sed -i '/#define _LINUX_NETDEVICE_H/d' \
src/arpd/*.c || die "sed command on arpd/*.c files failed"