summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-11-23 09:35:29 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-11-23 09:35:29 +0000
commitcdb27d9e5fa304f726bfbdd04a4f750d0372b3bd (patch)
treebb45e38f017b6bf2d02b66c6802be7693e1152b2 /net-dialup
parentbump (diff)
downloadgentoo-2-cdb27d9e5fa304f726bfbdd04a4f750d0372b3bd.tar.gz
gentoo-2-cdb27d9e5fa304f726bfbdd04a4f750d0372b3bd.tar.bz2
gentoo-2-cdb27d9e5fa304f726bfbdd04a4f750d0372b3bd.zip
bump
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capi4k-utils/ChangeLog8
-rw-r--r--net-dialup/capi4k-utils/Manifest4
-rw-r--r--net-dialup/capi4k-utils/capi4k-utils-20030616.ebuild64
-rw-r--r--net-dialup/capi4k-utils/files/digest-capi4k-utils-200306161
4 files changed, 74 insertions, 3 deletions
diff --git a/net-dialup/capi4k-utils/ChangeLog b/net-dialup/capi4k-utils/ChangeLog
index 6420bd2b48eb..69ef245ff6b4 100644
--- a/net-dialup/capi4k-utils/ChangeLog
+++ b/net-dialup/capi4k-utils/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-dialup/capi4k-utils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Maintainer Alexander Holler <holler@ahsoftware.de>
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.6 2003/11/19 14:05:20 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.7 2003/11/23 09:35:23 lanius Exp $
+
+*capi4k-utils-20030616 (23 Nov 2003)
+
+ 23 Nov 2003; Heinrich Wendel <lanius@gentoo.org>
+ capi4k-utils-20030616.ebuild:
+ bump
19 Nov 2003; Heinrich Wendel <lanius@gentoo.org> metadata.xml:
metadata.xml
diff --git a/net-dialup/capi4k-utils/Manifest b/net-dialup/capi4k-utils/Manifest
index 3304246849b1..ac8a8f9061dc 100644
--- a/net-dialup/capi4k-utils/Manifest
+++ b/net-dialup/capi4k-utils/Manifest
@@ -1,7 +1,7 @@
MD5 401fc9665fe2be5a8c7a57d5c424fc6c capi4k-utils-20020701.ebuild 1132
MD5 ff2e6a6be7c108034d4a5f3847c2ffcb capi4k-utils-20021026.ebuild 1346
-MD5 51b3621028a2c746b95d7036483b310b capi4k-utils-20030616.ebuild 1996
-MD5 4c051da1a8d9583df28b1223904c959e ChangeLog 847
+MD5 8613617552233ee05d624f3027ef3d23 capi4k-utils-20030616.ebuild 1950
+MD5 1905e8da9698e9d0c0a80141bfe18820 ChangeLog 976
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
MD5 2cc2614bcb8e3407f3a3a4f9667e09ad files/capi 647
MD5 d4eb961f35cf41379f2574203166860f files/digest-capi4k-utils-20020701 75
diff --git a/net-dialup/capi4k-utils/capi4k-utils-20030616.ebuild b/net-dialup/capi4k-utils/capi4k-utils-20030616.ebuild
new file mode 100644
index 000000000000..f93b8315367c
--- /dev/null
+++ b/net-dialup/capi4k-utils/capi4k-utils-20030616.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20030616.ebuild,v 1.1 2003/11/23 09:35:23 lanius Exp $
+
+YEAR_PV=${PV:0:4}
+MON_PV=${PV:4:2}
+DAY_PV=${PV:6:2}
+
+MY_P=${PN}-${YEAR_PV}-${MON_PV}-${DAY_PV}
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Capi4Linux Utils"
+SRC_URI="ftp://ftp.in-berlin.de/pub/capi4linux/OLD/${MY_P}.tar.gz"
+HOMEPAGE="ftp://ftp.in-berlin.de/pub/capi4linux/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/linux-sources
+ sys-devel/automake"
+
+src_compile() {
+ echo "CONFIG_DATADIR='/usr/share'" >> .config
+ echo "#" > .config
+ echo "# Automatically generated by emerge: don't edit" >> .config
+ echo "#" >> .config
+ echo "CONFIG_KERNELDIR='/usr/src/linux'" >> .config
+ echo "CONFIG_BINDIR='/usr/bin'" >> .config
+ echo "CONFIG_SBINDIR='/usr/sbin'" >> .config
+ echo "CONFIG_MANDIR='/usr/man'" >> .config
+ echo "CONFIG_AVMCAPICTRL=y" >> .config
+ echo "CONFIG_CAPIFAX=y" >> .config
+ echo "CONFIG_RCAPID=y" >> .config
+ echo "CONFIG_PPPDCAPIPLUGIN=y" >> .config
+ emake subconfig || die
+ emake || die
+}
+
+src_install() {
+ dodir /dev
+ emake install DESTDIR=${D} || die
+ rm -rf ${D}/dev
+ newdoc rcapid/README README.rcapid
+ newdoc pppdcapiplugin/README README.pppdcapiplugin
+ docinto examples.pppdcapiplugin; dodoc pppdcapiplugin/examples/*
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/capi
+ insinto /etc
+ insopts -m 0600
+ doins capiinit/capi.conf
+}
+
+pkg_postinst() {
+ einfo "To use isdn4linux with CAPI replace"
+ einfo "I4L_MODULE=\"hisax\" with I4L_MODULE=\"capidrv\","
+ einfo "start /etc/init.d/capi and load the module"
+ einfo "capidrv."
+ einfo ""
+ einfo "Annotation for active AVM ISDN boards (B1 ISA/PCI, ...):"
+ einfo "Please download the latest firmware from"
+ einfo "ftp://ftp.in-berlin.de/pub/capi4linux and copy the files "
+ einfo "to /usr/lib/isdn and check your /etc/capi.conf file"
+ einfo ""
+}
diff --git a/net-dialup/capi4k-utils/files/digest-capi4k-utils-20030616 b/net-dialup/capi4k-utils/files/digest-capi4k-utils-20030616
new file mode 100644
index 000000000000..bee17899b70b
--- /dev/null
+++ b/net-dialup/capi4k-utils/files/digest-capi4k-utils-20030616
@@ -0,0 +1 @@
+MD5 8aea2bcdc8e44459043092000c570073 capi4k-utils-2003-06-16.tar.gz 472007