summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-01 19:54:42 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-01 19:54:42 +0000
commita0eeff1e888bf04089a2a5b1a8a76c9fd37e925c (patch)
tree93b3c4b92bb545caacea36330a56bfda13c6018c /net-dialup
parentVersion bump. (diff)
downloadgentoo-2-a0eeff1e888bf04089a2a5b1a8a76c9fd37e925c.tar.gz
gentoo-2-a0eeff1e888bf04089a2a5b1a8a76c9fd37e925c.tar.bz2
gentoo-2-a0eeff1e888bf04089a2a5b1a8a76c9fd37e925c.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/minicom/ChangeLog9
-rw-r--r--net-dialup/minicom/minicom-2.7.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/net-dialup/minicom/ChangeLog b/net-dialup/minicom/ChangeLog
index 3e0de741acfd..73a110f955e0 100644
--- a/net-dialup/minicom/ChangeLog
+++ b/net-dialup/minicom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/minicom
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.101 2013/10/30 08:43:27 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.102 2014/01/01 19:54:42 radhermit Exp $
+
+*minicom-2.7 (01 Jan 2014)
+
+ 01 Jan 2014; Tim Harder <radhermit@gentoo.org> +minicom-2.7.ebuild:
+ Version bump.
*minicom-2.6.2-r1 (30 Oct 2013)
diff --git a/net-dialup/minicom/minicom-2.7.ebuild b/net-dialup/minicom/minicom-2.7.ebuild
new file mode 100644
index 000000000000..804e3664f40c
--- /dev/null
+++ b/net-dialup/minicom/minicom-2.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.7.ebuild,v 1.1 2014/01/01 19:54:42 radhermit Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+STUPID_NUM="3977"
+
+DESCRIPTION="Serial Communication Program"
+HOMEPAGE="http://alioth.debian.org/projects/minicom"
+SRC_URI="https://alioth.debian.org/frs/download.php/file/${STUPID_NUM}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="nls"
+
+COMMON_DEPEND="sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${COMMON_DEPEND}
+ net-dialup/lrzsz"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/minicom.FAQ"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs da de es fi fr hu id ja nb pl pt_BR ro ru rw sv vi zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.3-gentoo-runscript.patch
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ insinto /etc/minicom
+ doins "${FILESDIR}"/minirc.dfl
+}
+
+pkg_preinst() {
+ [[ -s ${EROOT}/etc/minicom/minirc.dfl ]] \
+ && rm -f "${ED}"/etc/minicom/minirc.dfl
+}