summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 21:23:01 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 21:23:01 +0000
commit40486c69106861cb454dc6bd54b963705e6022bc (patch)
tree84fe234f4bc69cc8cb64124093b9afc561b4d0c4 /net-dialup
parentuse dosbin instead of exeinto /usr/sbin/ && doexe (diff)
downloadgentoo-2-40486c69106861cb454dc6bd54b963705e6022bc.tar.gz
gentoo-2-40486c69106861cb454dc6bd54b963705e6022bc.tar.bz2
gentoo-2-40486c69106861cb454dc6bd54b963705e6022bc.zip
use dosbin instead of exeinto /usr/sbin/ && doexe
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/mwavem/ChangeLog8
-rw-r--r--net-dialup/mwavem/mwavem-2.0-r1.ebuild13
-rw-r--r--net-dialup/mwavem/mwavem-2.0-r2.ebuild9
3 files changed, 18 insertions, 12 deletions
diff --git a/net-dialup/mwavem/ChangeLog b/net-dialup/mwavem/ChangeLog
index 04bd18ec0ec8..9f7fb66a0af7 100644
--- a/net-dialup/mwavem/ChangeLog
+++ b/net-dialup/mwavem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/mwavem
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/ChangeLog,v 1.20 2014/06/27 07:22:07 pinkbyte Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/ChangeLog,v 1.21 2015/03/21 21:23:01 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> mwavem-2.0-r1.ebuild,
+ mwavem-2.0-r2.ebuild:
+ use dosbin instead of exeinto /usr/sbin/ && doexe
*mwavem-2.0-r2 (27 Jun 2014)
diff --git a/net-dialup/mwavem/mwavem-2.0-r1.ebuild b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
index 3f08dad6a738..53fb9945a99a 100644
--- a/net-dialup/mwavem/mwavem-2.0-r1.ebuild
+++ b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/mwavem-2.0-r1.ebuild,v 1.5 2014/06/27 07:20:27 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/mwavem-2.0-r1.ebuild,v 1.6 2015/03/21 21:23:01 jlec Exp $
EAPI="2"
AT_M4DIR="m4"
+
inherit autotools eutils
DESCRIPTION="User level application for IBM Mwave modem"
@@ -17,16 +18,16 @@ KEYWORDS="~amd64 x86"
IUSE=""
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- exeinto /usr/sbin
- doexe "${FILESDIR}/mwave-dev-handler"
+ dosbin "${FILESDIR}/mwave-dev-handler"
insinto /etc/devfs.d
newins "${FILESDIR}/mwave.devfs" mwave
diff --git a/net-dialup/mwavem/mwavem-2.0-r2.ebuild b/net-dialup/mwavem/mwavem-2.0-r2.ebuild
index a520f93f9a46..f66bfdba7633 100644
--- a/net-dialup/mwavem/mwavem-2.0-r2.ebuild
+++ b/net-dialup/mwavem/mwavem-2.0-r2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/mwavem-2.0-r2.ebuild,v 1.1 2014/06/27 07:22:07 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mwavem/mwavem-2.0-r2.ebuild,v 1.2 2015/03/21 21:23:01 jlec Exp $
EAPI="5"
AT_M4DIR="m4"
AUTOTOOLS_AUTORECONF=1
+
inherit autotools-utils
DESCRIPTION="User level application for IBM Mwave modem"
@@ -17,6 +18,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
DOCS=( AUTHORS ChangeLog FAQ NEWS README README.devfs THANKS )
+
PATCHES=(
"${FILESDIR}/${P}-gentoo.patch"
"${FILESDIR}/${P}-glibc-2.10.patch"
@@ -25,8 +27,7 @@ PATCHES=(
src_install() {
autotools-utils_src_install
- exeinto /usr/sbin
- doexe "${FILESDIR}/mwave-dev-handler"
+ dosbin "${FILESDIR}/mwave-dev-handler"
insinto /etc/devfs.d
newins "${FILESDIR}/mwave.devfs" mwave