summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-31 06:21:08 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-31 06:21:08 +0000
commit1a566067af1d3b587c7a9acd248cb17d1976b510 (patch)
tree1afdd34bbe89dcf0720523d959077e9a06d6cdab /net-dialup
parentRevision bump. 5.0.90-r1 includes the Percona 5.0.87-b20 patchset directly. P... (diff)
downloadgentoo-2-1a566067af1d3b587c7a9acd248cb17d1976b510.tar.gz
gentoo-2-1a566067af1d3b587c7a9acd248cb17d1976b510.tar.bz2
gentoo-2-1a566067af1d3b587c7a9acd248cb17d1976b510.zip
Fix multilib handling, more implicit decls, and improve crc output.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xc/ChangeLog11
-rw-r--r--net-dialup/xc/files/xc-4.3.2-add-115200.patch8
-rw-r--r--net-dialup/xc/files/xc-4.3.2-gentoo.patch70
-rw-r--r--net-dialup/xc/files/xc-4.3.2-implicit-decl.patch13
-rw-r--r--net-dialup/xc/xc-4.3.2-r2.ebuild41
5 files changed, 100 insertions, 43 deletions
diff --git a/net-dialup/xc/ChangeLog b/net-dialup/xc/ChangeLog
index 2f92864bc826..7aac519fc503 100644
--- a/net-dialup/xc/ChangeLog
+++ b/net-dialup/xc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/xc
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.21 2008/10/18 09:15:32 mrness Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.22 2010/01/31 06:21:08 vapier Exp $
+
+*xc-4.3.2-r2 (31 Jan 2010)
+
+ 31 Jan 2010; Mike Frysinger <vapier@gentoo.org> +xc-4.3.2-r2.ebuild,
+ files/xc-4.3.2-add-115200.patch, files/xc-4.3.2-gentoo.patch,
+ files/xc-4.3.2-implicit-decl.patch:
+ Fix multilib handling, more implicit decls, and improve crc output.
18 Oct 2008; Alin Năstac <mrness@gentoo.org> -files/xc-4.3.2-gentoo.diff,
+files/xc-4.3.2-gentoo.patch, xc-4.3.2-r1.ebuild:
diff --git a/net-dialup/xc/files/xc-4.3.2-add-115200.patch b/net-dialup/xc/files/xc-4.3.2-add-115200.patch
index 3d879ce1bc7b..c8238565ac0b 100644
--- a/net-dialup/xc/files/xc-4.3.2-add-115200.patch
+++ b/net-dialup/xc/files/xc-4.3.2-add-115200.patch
@@ -1,6 +1,8 @@
---- xcport.c.orig 2004-01-16 05:11:34.131877776 -0500
-+++ xcport.c 2004-01-16 05:13:52.459848728 -0500
-@@ -107,6 +107,7 @@ static struct {
+add support for 115200 baud
+
+--- xc-4.3.2/xcport.c
++++ xc-4.3.2/xcport.c
+@@ -107,6 +107,7 @@
{"38400",38400,B38400},
{"57600",57600,B50},
#endif
diff --git a/net-dialup/xc/files/xc-4.3.2-gentoo.patch b/net-dialup/xc/files/xc-4.3.2-gentoo.patch
index 7503c5b33382..8eb366059a62 100644
--- a/net-dialup/xc/files/xc-4.3.2-gentoo.patch
+++ b/net-dialup/xc/files/xc-4.3.2-gentoo.patch
@@ -1,7 +1,6 @@
-diff -ur xc-4.3.2.orig/Makefile xc-4.3.2/Makefile
---- xc-4.3.2.orig/Makefile 1996-11-24 06:56:14.000000000 +0000
-+++ xc-4.3.2/Makefile 2008-10-18 09:06:12.000000000 +0000
-@@ -5,21 +5,23 @@
+--- xc-4.3.2/Makefile
++++ xc-4.3.2/Makefile
+@@ -5,21 +5,24 @@
SHELL = /bin/sh
@@ -15,7 +14,8 @@ diff -ur xc-4.3.2.orig/Makefile xc-4.3.2/Makefile
+#CC = gcc
+GCCOPT = -fno-strength-reduce
#GCCOPT = -O -g
- CDEFS = -D_POSIX_SOURCE=1
+-CDEFS = -D_POSIX_SOURCE=1
++CDEFS = -D_XOPEN_SOURCE
-CFLAGS = $(WARN) $(CDEFS) $(GCCOPT)
+CFLAGS += $(WARN) $(CDEFS) $(GCCOPT)
@@ -25,6 +25,7 @@ diff -ur xc-4.3.2.orig/Makefile xc-4.3.2/Makefile
libdir = $(prefix)/lib/xc
-mandir = /usr/man/man1
+mandir = /usr/share/man
++man1dir = $(mandir)/man1
catdir = /var/catman/cat1
-manown = -o root -g man
+manown = -o root -g root
@@ -45,11 +46,11 @@ diff -ur xc-4.3.2.orig/Makefile xc-4.3.2/Makefile
xc: $(OBJS) eline
- $(CC) $(CFLAGS) $(OBJS) -o xc $(LDFLAGS)
-+ $(CC) $(LDFLAGS) $(OBJS) -o xc $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o xc $(LIBS)
uninstall:
rm -f $(bindir)/xc $(mandir)/xc.1 $(catdir)/xc.1.*
-@@ -64,10 +66,10 @@
+@@ -64,10 +66,9 @@
install: ./bin/xc ./bin/crc xc.1 crc.1
@echo " "
@@ -57,39 +58,46 @@ diff -ur xc-4.3.2.orig/Makefile xc-4.3.2/Makefile
- $(INSTALL) $(binown) -m 755 -s ./bin/crc $(bindir)
- $(INSTALL) $(manown) -m 644 xc.1 $(mandir)
- $(INSTALL) $(manown) -m 644 crc.1 $(mandir)
-+ $(INSTALL) $(binown) -m 755 ./bin/xc $(DESTDIR)$(bindir)
-+ $(INSTALL) $(binown) -m 755 ./bin/crc $(DESTDIR)$(bindir)
-+ $(INSTALL) $(manown) -m 644 xc.1 $(DESTDIR)$(mandir)/man1
-+ $(INSTALL) $(manown) -m 644 crc.1 $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -d -m755 $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
++ $(INSTALL) $(binown) -m 755 xc crc $(DESTDIR)$(bindir)
++ $(INSTALL) $(manown) -m 644 xc.1 crc.1 $(DESTDIR)$(man1dir)
@echo " "
@echo " "
@echo "You will want to manually install 'phonelist' and"
-@@ -113,7 +115,6 @@
- bin: xc crc
- cp ./xc ./bin
- cp ./crc ./bin
-- strip ./bin/xc ./bin/crc
-
- #########################################
- ## mostly unused stuff below here ... ##
-diff -ur xc-4.3.2.orig/xcsubs.c xc-4.3.2/xcsubs.c
---- xc-4.3.2.orig/xcsubs.c 1996-09-21 08:22:17.000000000 +0000
-+++ xc-4.3.2/xcsubs.c 2008-10-18 09:04:32.000000000 +0000
-@@ -23,7 +23,7 @@
+--- xc-4.3.2/xcsubs.c
++++ xc-4.3.2/xcsubs.c
+@@ -23,7 +23,6 @@
*tgetstr(), *tgoto();
int LI, /* One less than screen length in termcap entry */
CO; /* Screen width */
-speed_t ospeed; /* Used by termcap lib */
-+//speed_t ospeed; /* Used by termcap lib */
static char tc[LG_BUFF]; /* termcap buffer */
static char tbuf[LG_BUFF], *CD, *CF, *CL, *CM, *CN, *AE, *SE, *SO, *ME;
char *CE, PC; /* used by termcap -- padding character */
-@@ -410,7 +410,7 @@
+
+limit the 32bit crc to 32bits
+
+add simple usage
+
+--- xc-4.3.2/crc.c
++++ xc-4.3.2/crc.c
+@@ -152,7 +152,7 @@ char *name;
+ }
+ crc32 = oldcrc32; oldcrc = oldcrc32 = ~oldcrc32;
+
+- printf("%08lx %7ld ", oldcrc, charcnt);
++ printf("%08lx %7ld ", oldcrc & 0xffffffff, charcnt);
+ if (Block == 128)
+ printf("%5ld+%3ld ", charcnt/Block, charcnt%Block);
+ if (Block == 1024)
+@@ -170,6 +170,10 @@ char **argv;
{
- struct stat statbuf;
+ register errors = 0;
-- if (stat(pathname,&statbuf) || (statbuf.st_mode & S_IFMT) != S_IFREG)
-+ if (stat(pathname,&statbuf) || (statbuf.st_mode & __S_IFMT) != __S_IFREG)
- return NIL(FILE);
- return fopen(pathname, "r");
- }
++ if (argc == 1) {
++ puts("Usage: crc [-x|-k] <files>\n -x pad to 128 bytes\n -k pad to 1024 bytes");
++ exit(0);
++ }
+ if (argc > 1) {
+ if (!strcmp(argv[1], "-x")) {
+ Block = 128;
diff --git a/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch b/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
index 545299b04186..556392d8b189 100644
--- a/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
+++ b/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
@@ -1,17 +1,16 @@
-diff -Nru xc-4.3.2.orig/crc.c xc-4.3.2/crc.c
---- xc-4.3.2.orig/crc.c 1996-09-27 05:47:17.000000000 +0300
-+++ xc-4.3.2/crc.c 2007-04-15 14:34:09.000000000 +0300
-@@ -5,6 +5,7 @@
+--- xc-4.3.2/crc.c
++++ xc-4.3.2/crc.c
+@@ -5,6 +5,8 @@
* Crc - 32 BIT ANSI X3.66 CRC checksum files
*/
#include <stdio.h>
+#include <stdlib.h>
++#include <string.h>
#define OK 0
#define ERROR (-1)
#define LINT_ARGS
-diff -Nru xc-4.3.2.orig/xcterm.c xc-4.3.2/xcterm.c
---- xc-4.3.2.orig/xcterm.c 1996-09-25 06:58:31.000000000 +0300
-+++ xc-4.3.2/xcterm.c 2007-04-15 14:33:46.000000000 +0300
+--- xc-4.3.2/xcterm.c
++++ xc-4.3.2/xcterm.c
@@ -4,6 +4,8 @@
#define XCTERM_C 1
diff --git a/net-dialup/xc/xc-4.3.2-r2.ebuild b/net-dialup/xc/xc-4.3.2-r2.ebuild
new file mode 100644
index 000000000000..3eec28c63c55
--- /dev/null
+++ b/net-dialup/xc/xc-4.3.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r2.ebuild,v 1.1 2010/01/31 06:21:08 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="unix dialout program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-implicit-decl.patch
+ epatch "${FILESDIR}"/${P}-add-115200.patch
+
+ sed -i \
+ -e "/^libdir/s:/lib/:/$(get_libdir)/:" \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake WARN="" all || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ insinto /usr/$(get_libdir)/xc
+ doins phonelist xc.init dotfiles/.[a-z]* || die
+}