summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-24 15:59:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-24 15:59:19 +0000
commit0c4f3dbc1036944d98d7a868f479eb6988a7d227 (patch)
tree12c3e89a6fc3acbaca54e117b19245aeb6f8d6e8 /net-dialup/wvdial
parentAdded libMesaGL symlinks (diff)
downloadgentoo-2-0c4f3dbc1036944d98d7a868f479eb6988a7d227.tar.gz
gentoo-2-0c4f3dbc1036944d98d7a868f479eb6988a7d227.tar.bz2
gentoo-2-0c4f3dbc1036944d98d7a868f479eb6988a7d227.zip
Fixed glibc-2.2.2 issue
Diffstat (limited to 'net-dialup/wvdial')
-rw-r--r--net-dialup/wvdial/files/digest-wvdial-1.41-r31
-rw-r--r--net-dialup/wvdial/files/wvdial-1.41-r3-gentoo.diff11
-rw-r--r--net-dialup/wvdial/wvdial-1.41-r3.ebuild40
3 files changed, 52 insertions, 0 deletions
diff --git a/net-dialup/wvdial/files/digest-wvdial-1.41-r3 b/net-dialup/wvdial/files/digest-wvdial-1.41-r3
new file mode 100644
index 000000000000..37e0192a0917
--- /dev/null
+++ b/net-dialup/wvdial/files/digest-wvdial-1.41-r3
@@ -0,0 +1 @@
+MD5 753312352281f0d8c8579f2ffbffeae2 wvdial-1.41.tar.gz
diff --git a/net-dialup/wvdial/files/wvdial-1.41-r3-gentoo.diff b/net-dialup/wvdial/files/wvdial-1.41-r3-gentoo.diff
new file mode 100644
index 000000000000..178ba8ad6fd6
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.41-r3-gentoo.diff
@@ -0,0 +1,11 @@
+--- wvdial-1.41/streams/wvstream.cc~ Thu Oct 21 00:37:04 1999
++++ wvdial-1.41/streams/wvstream.cc Tue Apr 24 15:55:07 2001
+@@ -9,7 +9,7 @@
+ * for each stream.
+ */
+ #include "wvstream.h"
+-#include <sys/time.h>
++#include <time.h>
+ #include <sys/types.h>
+ #include <errno.h>
+ #include <assert.h>
diff --git a/net-dialup/wvdial/wvdial-1.41-r3.ebuild b/net-dialup/wvdial/wvdial-1.41-r3.ebuild
new file mode 100644
index 000000000000..7bca45312027
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.41-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.41-r3.ebuild,v 1.1 2001/04/24 15:59:19 achim Exp $
+
+P=wvdial-1.41
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Excellent program which automatically configures your PPP session"
+SRC_URI="http://www.worldvisions.ca/wvdial/wvdial-1.41.tar.gz"
+HOMEPAGE="http://www.worldvisions.ca/wvdial/"
+
+DEPEND=">=sys-devel/gcc-2.95.2
+ >=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ try make
+}
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}
+ cp rules.mk rules.mk.orig
+ sed -e "s/-g//g" -e "s/-O6/${CFLAGS}/" rules.mk.orig > rules.mk
+ cp Makefile Makefile.orig
+ sed -e "s:PREFIX=/usr/local:PREFIX=/usr:" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /usr
+ dobin wvdial/wvdial wvdial/wvdialconf
+ doman *.1
+ insinto /etc/ppp/peers
+ newins ppp.provider wvdial
+ dodoc ANNOUNCE CHANGES COPYING.LIB README
+ dodoc debian/changelog debian/copyright
+}
+
+