summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-10-24 09:14:29 +0000
committerAchim Gottinger <achim@gentoo.org>2001-10-24 09:14:29 +0000
commitb0d489f7471353b7cc740cc3e6cb91108f761e9d (patch)
tree88560aacadc91808b3524f5692247a3fba9543ac /net-dialup/rp-pppoe
parentupdated and removed A= (diff)
downloadgentoo-2-b0d489f7471353b7cc740cc3e6cb91108f761e9d.tar.gz
gentoo-2-b0d489f7471353b7cc740cc3e6cb91108f761e9d.tar.bz2
gentoo-2-b0d489f7471353b7cc740cc3e6cb91108f761e9d.zip
New version
Diffstat (limited to 'net-dialup/rp-pppoe')
-rw-r--r--net-dialup/rp-pppoe/files/digest-rp-pppoe-3.31
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-dialup/rp-pppoe/files/digest-rp-pppoe-3.3 b/net-dialup/rp-pppoe/files/digest-rp-pppoe-3.3
new file mode 100644
index 000000000000..df00aa31936d
--- /dev/null
+++ b/net-dialup/rp-pppoe/files/digest-rp-pppoe-3.3
@@ -0,0 +1 @@
+MD5 1cd6bc22f7601f769bb654db4a15b15d rp-pppoe-3.3.tar.gz
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild
new file mode 100644
index 000000000000..607c31457190
--- /dev/null
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>, David Bresson <david.bresson@yale.edu>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild,v 1.1 2001/10/24 09:14:29 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}/src
+DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
+SRC_URI="http://www.roaringpenguin.com/pppoe/${A}"
+HOMEPAGE="http://www.roaringpeguin.com/"
+
+DEPEND="virtual/glibc >=net-dialup/ppp-2.4.1"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make RPM_INSTALL_ROOT=${D} install
+ dodir /usr/share/doc
+ mv ${D}/usr/doc/${P} ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/doc
+ prepalldocs
+
+}
+