summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2004-12-30 09:05:31 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2004-12-30 09:05:31 +0000
commitac7e8241ee17d621f77de5e1367d91eec0c379b1 (patch)
tree7d511b20cc6b91e7a66202c21f6f37003f823170 /net-dialup/pptpd/pptpd-1.2.1.ebuild
parentVersion bump #75457. (Manifest recommit) (diff)
downloadgentoo-2-ac7e8241ee17d621f77de5e1367d91eec0c379b1.tar.gz
gentoo-2-ac7e8241ee17d621f77de5e1367d91eec0c379b1.tar.bz2
gentoo-2-ac7e8241ee17d621f77de5e1367d91eec0c379b1.zip
version bump.
Diffstat (limited to 'net-dialup/pptpd/pptpd-1.2.1.ebuild')
-rw-r--r--net-dialup/pptpd/pptpd-1.2.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-dialup/pptpd/pptpd-1.2.1.ebuild b/net-dialup/pptpd/pptpd-1.2.1.ebuild
new file mode 100644
index 000000000000..81857a9df20b
--- /dev/null
+++ b/net-dialup/pptpd/pptpd-1.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.2.1.ebuild,v 1.1 2004/12/30 09:05:31 jhhudso Exp $
+
+DESCRIPTION="Linux Point-to-Point Tunnelling Protocol Server"
+SRC_URI="mirror://sourceforge/poptop/${P}.tar.gz"
+HOMEPAGE="http://www.poptop.org/"
+
+DEPEND="virtual/libc
+ net-dialup/ppp
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="$DEPEND"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="tcpd"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+ econf --with-bcrelay \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ insinto /etc
+ doins samples/pptpd.conf
+
+ insinto /etc/ppp
+ doins samples/options.pptpd
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pptpd-init pptpd
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pptpd-confd pptpd
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO
+ docinto samples
+ dodoc samples/*
+}