summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-26 13:33:22 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-26 13:33:22 +0000
commitca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf (patch)
tree02768704f22ff3144221becd01936b118c7d679d /net-dialup/pppconfig
parentUpdate bug number in a comment. Pretty useless commit, but some users were co... (diff)
downloadgentoo-2-ca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf.tar.gz
gentoo-2-ca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf.tar.bz2
gentoo-2-ca6c5f76a394f8e3d0ba8a87cad86fbccd6566bf.zip
Version bump. Use mirror:// (bug #413341). Rewrite LINGUAS support using strip-linguas (maybe bug #403633).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-dialup/pppconfig')
-rw-r--r--net-dialup/pppconfig/ChangeLog11
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild8
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.21.ebuild55
3 files changed, 68 insertions, 6 deletions
diff --git a/net-dialup/pppconfig/ChangeLog b/net-dialup/pppconfig/ChangeLog
index ae55813b2166..ed876b70a926 100644
--- a/net-dialup/pppconfig/ChangeLog
+++ b/net-dialup/pppconfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/pppconfig
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/ChangeLog,v 1.29 2007/11/12 15:19:10 mrness Exp $
+# Copyright 2002-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/ChangeLog,v 1.30 2014/05/26 13:33:22 jer Exp $
+
+*pppconfig-2.3.21 (26 May 2014)
+
+ 26 May 2014; Jeroen Roovers <jer@gentoo.org> pppconfig-2.3.17-r1.ebuild,
+ +pppconfig-2.3.21.ebuild:
+ Version bump. Use mirror:// (bug #413341). Rewrite LINGUAS support using
+ strip-linguas (maybe bug #403633).
12 Nov 2007; Alin Năstac <mrness@gentoo.org> -pppconfig-2.3.15.ebuild:
Remove old version.
diff --git a/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild b/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild
index 870b636920a7..4ff2328e0590 100644
--- a/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild
+++ b/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild,v 1.3 2007/09/09 05:44:27 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild,v 1.4 2014/05/26 13:33:22 jer Exp $
DESCRIPTION="A text menu based utility for configuring ppp."
-SRC_URI="http://http.us.debian.org/debian/pool/main/p/pppconfig/${PN}_${PV}.tar.gz"
-HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/pppconfig/"
+HOMEPAGE="http://packages.qa.debian.org/p/pppconfig.html"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
diff --git a/net-dialup/pppconfig/pppconfig-2.3.21.ebuild b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
new file mode 100644
index 000000000000..184ed16795b0
--- /dev/null
+++ b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.21.ebuild,v 1.1 2014/05/26 13:33:22 jer Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A text menu based utility for configuring ppp"
+HOMEPAGE="http://packages.qa.debian.org/p/pppconfig.html"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="net-dialup/ppp
+ dev-util/dialog
+ dev-lang/perl"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i po/
+ fi
+}
+
+src_compile() {
+ default
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ msgfmt -o po/${lang}.{m,p}o || die
+ done
+ fi
+}
+
+src_install () {
+ dodir /etc/chatscripts /etc/ppp/resolv
+ dosbin 0dns-down 0dns-up dns-clean
+ newsbin pppconfig pppconfig.real
+ dosbin "${FILESDIR}/pppconfig"
+ doman man/pppconfig.8
+ dodoc debian/{copyright,changelog}
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ insinto /usr/share/locale/${lang}/LC_MESSAGES
+ newins po/${lang}.mo pppconfig.mo
+ done
+ fi
+}