summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-06 10:29:16 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-06 10:29:16 +0000
commitd8f088332dcdf026b4b9ad2a2c34fed68ffb4eb6 (patch)
tree69d370f5d2b697b44840ea6df148e908dabaf9cd /net-dialup/gtkterm
parentVersion bump, disable update check by default. (diff)
downloadgentoo-2-d8f088332dcdf026b4b9ad2a2c34fed68ffb4eb6.tar.gz
gentoo-2-d8f088332dcdf026b4b9ad2a2c34fed68ffb4eb6.tar.bz2
gentoo-2-d8f088332dcdf026b4b9ad2a2c34fed68ffb4eb6.zip
Version bump, also fixes compilation with current vte (#406105 by Xake).
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/gtkterm')
-rw-r--r--net-dialup/gtkterm/ChangeLog9
-rw-r--r--net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch14
-rw-r--r--net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild66
3 files changed, 87 insertions, 2 deletions
diff --git a/net-dialup/gtkterm/ChangeLog b/net-dialup/gtkterm/ChangeLog
index 8726b4c4e2f3..cf715d0175d2 100644
--- a/net-dialup/gtkterm/ChangeLog
+++ b/net-dialup/gtkterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/gtkterm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gtkterm/ChangeLog,v 1.21 2012/05/03 03:54:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gtkterm/ChangeLog,v 1.22 2012/10/06 10:29:15 pacho Exp $
+
+*gtkterm-0.99.7_rc1 (06 Oct 2012)
+
+ 06 Oct 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gtkterm-0.99.7_rc1-configure.patch, +gtkterm-0.99.7_rc1.ebuild:
+ Version bump, also fixes compilation with current vte (#406105 by Xake).
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gtkterm-0.99.5-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -77,4 +83,3 @@
09 Jul 2003; Martin Holzer <mholzer@gentoo.org> gtkterm-0.99.3.ebuild:
Initial ebuild submitted by Zach Bagnall <yem@y3m.net> in #23735.
-
diff --git a/net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch b/net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch
new file mode 100644
index 000000000000..795025623ac5
--- /dev/null
+++ b/net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch
@@ -0,0 +1,14 @@
+diff -urN gtkterm-0.99.7-rc1.old/configure.in gtkterm-0.99.7-rc1/configure.in
+--- gtkterm-0.99.7-rc1.old/configure.in 2012-03-02 14:05:29.842885142 -0800
++++ gtkterm-0.99.7-rc1/configure.in 2012-03-02 14:11:20.242419122 -0800
+@@ -32,8 +32,8 @@
+ dnl Checks for GTK+ and Imlib and libvte
+ PKG_CHECK_MODULES(VTE, vte >= 0.20, , AC_MSG_ERROR([*** vte >= 0.20 not installed ***]))
+
+-AC_SUBST(VTE_CFLAGS)
+-AC_SUBST(VTE_LIBS)
++AC_SUBST(TERMINAL_WIDGET_CFLAGS)
++AC_SUBST(TERMINAL_WIDGET_LIBS)
+
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.16, , AC_MSG_ERROR([*** GTK >= 2.16 not installed ***]))
+
diff --git a/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild b/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
new file mode 100644
index 000000000000..453c902a822e
--- /dev/null
+++ b/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild,v 1.1 2012/10/06 10:29:15 pacho Exp $
+
+EAPI=4
+
+MY_P="${P/_/-}"
+DESCRIPTION="A serial port terminal written in GTK+, similar to Windows' HyperTerminal"
+HOMEPAGE="https://fedorahosted.org/gtkterm/"
+SRC_URI="https://fedorahosted.org/released/gtkterm/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+inherit eutils autotools
+
+RDEPEND=">=x11-libs/gtk+-2.16:2
+ >=x11-libs/vte-0.20:0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" fr hu"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ # Fix test
+ echo "src/term_config.c" >> po/POTFILES.in || die
+
+ epatch "${FILESDIR}/${P}-configure.patch"
+ eautoreconf
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ if use nls; then
+ cd "${S}/po"
+ local MY_LINGUAS="" lang
+
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ MY_LINGUAS="${MY_LINGUAS} ${lang}"
+ fi
+ done
+ if [[ "${MY_LINGUAS}" ]] ; then
+
+ elog "Locale messages will be installed for following languages:"
+ elog " ${MY_LINGUAS}"
+
+ for lang in ${MY_LINGUAS}; do
+ msgfmt -o ${lang}.mo ${lang}.po && \
+ insinto /usr/share/locale/${lang}/LC_MESSAGES && \
+ newins ${lang}.mo gtkterm.mo || \
+ die "failed to install locale messages for ${lang} language"
+ done
+ fi
+ fi
+}