summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-03-09 06:34:58 +0000
committerAlin Năstac <mrness@gentoo.org>2005-03-09 06:34:58 +0000
commita16e6d5b5d4debad39a3d80ea16dc34f5eddb01f (patch)
tree953d85f47e36b00cd5dcecbef928b6c3742f139d /net-dialup/fcpci
parentAdd missing KEYWORDs. (diff)
downloadgentoo-2-a16e6d5b5d4debad39a3d80ea16dc34f5eddb01f.tar.gz
gentoo-2-a16e6d5b5d4debad39a3d80ea16dc34f5eddb01f.tar.bz2
gentoo-2-a16e6d5b5d4debad39a3d80ea16dc34f5eddb01f.zip
kernel-mod -> linux-mod
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-dialup/fcpci')
-rw-r--r--net-dialup/fcpci/ChangeLog5
-rw-r--r--net-dialup/fcpci/fcpci-3.11.02-r1.ebuild49
2 files changed, 31 insertions, 23 deletions
diff --git a/net-dialup/fcpci/ChangeLog b/net-dialup/fcpci/ChangeLog
index f30f74f10682..b034165b12e8 100644
--- a/net-dialup/fcpci/ChangeLog
+++ b/net-dialup/fcpci/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-dialup/fcpci
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.13 2005/02/06 11:19:42 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.14 2005/03/09 06:34:58 mrness Exp $
+
+ 09 Mar 2005; Alin Nastac <mrness@gentoo.org> fcpci-3.11.02-r1.ebuild:
+ Replace kernel-mod inheritance with linux-mod.
06 Feb 2005; Alin Nastac <mrness@gentoo.org> -fcpci-03.11.02.ebuild:
Remove obsolete ebuild.
diff --git a/net-dialup/fcpci/fcpci-3.11.02-r1.ebuild b/net-dialup/fcpci/fcpci-3.11.02-r1.ebuild
index fbbc49fb5e79..fedf885453d4 100644
--- a/net-dialup/fcpci/fcpci-3.11.02-r1.ebuild
+++ b/net-dialup/fcpci/fcpci-3.11.02-r1.ebuild
@@ -1,61 +1,66 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/fcpci-3.11.02-r1.ebuild,v 1.2 2005/01/10 20:59:12 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/fcpci-3.11.02-r1.ebuild,v 1.3 2005/03/09 06:34:58 mrness Exp $
-inherit flag-o-matic kernel-mod
+inherit flag-o-matic linux-mod
PV_K24=fcpci-suse8.2-0${PV}.tar.gz
PV_K26=fcpci-suse9.1-${PV/.0/-0}.tar.gz
DESCRIPTION="CAPI4Linux drivers for AVM Fritz!Card PCI"
HOMEPAGE="http://www.avm.de/"
-S="${WORKDIR}/fritz"
SRC_URI="ftp://ftp.avm.de/cardware/fritzcrd.pci/linux/suse.82/${PV_K24}
ftp://ftp.avm.de/cardware/fritzcrd.pci/linux/suse.91/${PV_K26}"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
IUSE=""
DEPEND="virtual/linux-sources"
-src_unpack() {
- if kernel-mod_is_2_4_kernel; then
- unpack ${PV_K24}
+S="${WORKDIR}/fritz"
+
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ if kernel_is 2 4; then
+ MODULE_NAMES="fcpci(extra::src.drv)"
else
- unpack ${PV_K26}
+ MODULE_NAMES="fcpci(extra::src)"
fi
}
-src_compile() {
- if kernel-mod_is_2_4_kernel; then
+src_unpack() {
+ if kernel_is 2 4; then
+ unpack ${PV_K24}
+
sed -i -e "s/\`uname -r\`/${KV_VERSION_FULL}/" \
-e 's/-DMODULE/-DMODULE -DMODVERSIONS/' \
- -e "s:(DEFINES) -O2:(DEFINES) ${CFLAGS} -I /usr/src/linux/include/ -include linux/modversions.h:" src.drv/makefile
+ -e "s:(DEFINES) -O2:(DEFINES) ${CFLAGS} -I /usr/src/linux/include/ -include linux/modversions.h:" \
+ ${S}/src.drv/makefile || die "sed failed"
#gentoo-sources contains this typedef
- sed -i -e "s:^typedef void irqreturn_t;.*:/*&*/:" src.drv/defs.h
+ sed -i -e "s:^typedef void irqreturn_t;.*:/*&*/:" \
+ ${S}/src.drv/defs.h || die "sed failed"
else
+ unpack ${PV_K26}
+
sed -i -e 's:SUBDIRS=:M=:' \
-e 's:/var/lib/fritz:${S}/lib:' \
-e "s:\(.*@cp.*\):#\1:" ${S}/src/Makefile || die "sed failed"
fi
+}
+src_compile() {
filter-flags "-fstack-protector"
filter-flags "-fstack-protector-all"
- (
- unset ARCH
- emake all || die "make failed"
- )
+
+ linux-mod_src_compile
}
src_install () {
- if kernel-mod_is_2_4_kernel; then
- insinto /lib/modules/${KV}/misc
- doins src.drv/fcpci.o || die "failed to install fcpci.o"
- else
- insinto /lib/modules/${KV}/misc
- doins src/fcpci.ko || die "failed to install fcpci.ko"
- fi
+ linux-mod_src_install
dodoc CAPI* compile* license.txt
dohtml install_passive-?.html