summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-03-19 22:39:45 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-03-19 22:39:45 +0000
commitd6a9dd2a191b6cc46bae733dc7ff90996b21993b (patch)
treed849e37db980927aca81c81d41fdad3a5bf78d5b /net-dialup/fcdsl
parentFixed bad if logic (must be getting good at this :|) for real codecs. (diff)
downloadgentoo-2-d6a9dd2a191b6cc46bae733dc7ff90996b21993b.tar.gz
gentoo-2-d6a9dd2a191b6cc46bae733dc7ff90996b21993b.tar.bz2
gentoo-2-d6a9dd2a191b6cc46bae733dc7ff90996b21993b.zip
Removing fcdslusb patch.. it does not work and is not needed.
(Portage version: 1.585-cvs)
Diffstat (limited to 'net-dialup/fcdsl')
-rw-r--r--net-dialup/fcdsl/ChangeLog6
-rw-r--r--net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild4
-rw-r--r--net-dialup/fcdsl/files/fcdslusb.diff86
3 files changed, 7 insertions, 89 deletions
diff --git a/net-dialup/fcdsl/ChangeLog b/net-dialup/fcdsl/ChangeLog
index b99f14c19f84..2cdbab95e2c9 100644
--- a/net-dialup/fcdsl/ChangeLog
+++ b/net-dialup/fcdsl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/fcdsl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/ChangeLog,v 1.12 2005/03/09 05:53:26 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/ChangeLog,v 1.13 2005/03/19 22:39:45 genstef Exp $
+
+ 19 Mar 2005; Stefan Schweizer <genstef@gentoo.org> -files/fcdslusb.diff,
+ fcdsl-2.6.20.7-r4.ebuild:
+ Removing fcdslusb patch.. it does not work and is not needed.
09 Mar 2005; Alin Nastac <mrness@gentoo.org> -fcdsl-2.6.20.7-r2.ebuild,
-fcdsl-2.6.20.7-r3.ebuild:
diff --git a/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild b/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild
index 2a8b9fe951d4..6cdc9d22d24b 100644
--- a/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild
+++ b/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild,v 1.3 2005/03/05 16:06:46 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-2.6.20.7-r4.ebuild,v 1.4 2005/03/19 22:39:45 genstef Exp $
inherit linux-mod eutils
@@ -68,7 +68,7 @@ src_unpack() {
tar xzf ${DISTDIR}/${FCDSL_FILES[CARD]}.tar.gz
mv fritz ${FCDSL_MODULES[CARD]/fc/fritz.}
cd ${FCDSL_MODULES[CARD]/fc/fritz.}/src
- patch -p0 < ${FILESDIR}/${FCDSL_MODULES[CARD]}.diff
+ [ -f ${FILESDIR}/${FCDSL_MODULES[CARD]}.diff ] && patch -p0 < ${FILESDIR}/${FCDSL_MODULES[CARD]}.diff
cd ../..
done
diff --git a/net-dialup/fcdsl/files/fcdslusb.diff b/net-dialup/fcdsl/files/fcdslusb.diff
deleted file mode 100644
index 922cad2629d0..000000000000
--- a/net-dialup/fcdsl/files/fcdslusb.diff
+++ /dev/null
@@ -1,86 +0,0 @@
---- driver.c.orig 2004-05-14 02:00:00.000000000 +0200
-+++ driver.c 2005-02-26 11:26:41.000000000 +0100
-@@ -18,6 +18,10 @@
- * http://www.opensource.org/licenses/lgpl-license.html
- *
- * Contact: AVM GmbH, Alt-Moabit 95, 10559 Berlin, Germany, email: info@avm.de
-+ *
-+ * Mon Oct 20 22:43:31 2003
-+ * Modified by Joerg Lehrke to improve locking
-+ * Fixed for rev 0.4.1 by Stefan Schweizer
- */
-
- #include <asm/atomic.h>
-@@ -46,6 +50,8 @@
- #include "main.h"
- #include "driver.h"
-
-+#undef SINGLE_LOCK
-+
- #ifndef HZ
- # error HZ is not defined...
- #endif
-@@ -76,7 +82,11 @@ static atomic_t crit_count = ATOMIC_I
- static volatile int hard_error_issued;
- static atomic_t tx_flag = ATOMIC_INIT (0);
- static atomic_t rx_flag = ATOMIC_INIT (0);
-+#if defined (SINGLE_LOCK)
-+# define stack_lock qt_lock
-+#else
- static spinlock_t stack_lock = SPIN_LOCK_UNLOCKED;
-+#endif
- static int thread_pid = -1;
- static atomic_t thread_flag;
- static atomic_t thread_capi_flag;
-@@ -1367,15 +1377,20 @@ static void tx_handler (card_p pdc) {
- /*---------------------------------------------------------------------------*\
- \*---------------------------------------------------------------------------*/
- static void tx_task (unsigned long data) {
--
-+ unsigned long flags;
- UNUSED_ARG (data);
-+
- if (in_critical ()) {
- atomic_set (&tx_flag, 1);
-- } else if (spin_trylock (&stack_lock)) {
-- tx_handler (capi_card);
-- spin_unlock (&stack_lock);
- } else {
-- atomic_set (&tx_flag, 1);
-+ local_irq_save(flags);
-+ if (spin_trylock (&stack_lock)) {
-+ tx_handler (capi_card);
-+ spin_unlock (&stack_lock);
-+ } else {
-+ atomic_set (&tx_flag, 1);
-+ }
-+ local_irq_restore(flags);
- }
- } /* tx_task */
-
-@@ -1412,15 +1427,20 @@ static void rx_handler (card_p pdc) {
- /*---------------------------------------------------------------------------*\
- \*---------------------------------------------------------------------------*/
- static void rx_task (unsigned long data) {
--
-+ unsigned long flags;
- UNUSED_ARG (data);
-+
- if (in_critical ()) {
- atomic_set (&rx_flag, 1);
-- } else if (spin_trylock (&stack_lock)) {
-- rx_handler (capi_card);
-- spin_unlock (&stack_lock);
- } else {
-- atomic_set (&rx_flag, 1);
-+ local_irq_save(flags);
-+ if (spin_trylock (&stack_lock)) {
-+ tx_handler (capi_card);
-+ spin_unlock (&stack_lock);
-+ } else {
-+ atomic_set (&tx_flag, 1);
-+ }
-+ local_irq_restore(flags);
- }
- } /* rxi_task */
-