summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-29 18:53:47 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-29 18:53:47 +0000
commitf890beaf7e2cfb056c9a7906a191a176c685e520 (patch)
tree0934cc8fb883a83dd31d0c8a8e54ce4d0a2c0803 /net-analyzer
parentSource is no more installed. Closes #23394. (diff)
downloadgentoo-2-f890beaf7e2cfb056c9a7906a191a176c685e520.tar.gz
gentoo-2-f890beaf7e2cfb056c9a7906a191a176c685e520.tar.bz2
gentoo-2-f890beaf7e2cfb056c9a7906a191a176c685e520.zip
Source is no more installed. Closes #23394.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/Manifest6
-rw-r--r--net-analyzer/cacti/cacti-0.8.1-r1.ebuild115
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.1-r11
4 files changed, 125 insertions, 4 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index ffde246ad9e1..8086aea3cd35 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.9 2003/06/13 20:06:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.10 2003/07/29 18:53:33 mholzer Exp $
+
+*cacti-0.8.1-r1 (30 Jul 2003)
+
+ 30 Jul 2003; Martin Holzer <mholzer@gentoo.org> cacti-0.8.1-r1.ebuild:
+ Source is no more installed. Closes #23393.
*cacti-0.8.1 (12 Jun 2003)
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 91f5c50f8b1d..3ce6477ce89e 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,7 +1,7 @@
-MD5 c932a74baa5138cd9a6704c24614fba8 ChangeLog 1219
+MD5 3976952a488a7b9cd577d6f3869517f6 ChangeLog 1372
MD5 d96fabbabcc5309989f97c185cc8c6de cacti-0.6.8a.ebuild 1482
-MD5 14f18c43b95aeb44194e88fc635f3f84 cacti-0.8.1.ebuild 4041
-MD5 14f18c43b95aeb44194e88fc635f3f84 cacti-0.8.1-r1.ebuild 4041
+MD5 4c987af71ae2cf59646137f58eaf9f9b cacti-0.8.1-r1.ebuild 4045
+MD5 4a83ea90dd510dbc3a375697bdb5d322 cacti-0.8.1.ebuild 4026
MD5 36cff775a40a01ca080d9b290109a795 files/digest-cacti-0.6.8a 64
MD5 f1e420ab088a8222b4020ab76a92c387 files/digest-cacti-0.8.1 63
MD5 f1e420ab088a8222b4020ab76a92c387 files/digest-cacti-0.8.1-r1 63
diff --git a/net-analyzer/cacti/cacti-0.8.1-r1.ebuild b/net-analyzer/cacti/cacti-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..060e2be9a056
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.1-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.1-r1.ebuild,v 1.1 2003/07/29 18:53:33 mholzer Exp $
+
+inherit eutils
+
+DESCRIPTION="Cacti is a complete frondend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="snmp"
+
+DEPEND=""
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ dev-php/php
+ dev-php/mod_php"
+
+export HTTPD_ROOT=/home/httpd/htdocs
+export HTTPD_USER=apache
+export HTTPD_GROUP=apache
+export INSTALL_DEST=${HTTPD_ROOT}/cacti
+
+src_install() {
+ dohtml docs/{INSTALL,UPGRADE}.htm
+ dodoc docs/{CHANGELOG,CONTRIB}
+ dodoc LICENSE
+
+ rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
+ rm docs/{README,CHANGELOG,CONTRIB}
+ rm LICENSE README
+
+ mv docs/manual .
+ rm -fr docs
+ rm -rf cactid
+
+ dodir ${INSTALL_DEST}
+ edos2unix `find -type f -name '*.php'`
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
+ mv * ${D}/${INSTALL_DEST}/
+}
+
+pkg_postinst() {
+ # check to see if we have a previous version installed
+ minor_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f2)"
+ rel_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f3)"
+ if [ ${minor_inst}${rel_inst} -lt 81 ]
+ then
+ einfo
+ einfo "The cacti has been installed to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "5. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ einfo "Test your upgraded installation. When all is fine you can"
+ eingo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ else
+ einfo
+ einfo "The cacti has been copied to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must:"
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "5. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ fi
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.1-r1 b/net-analyzer/cacti/files/digest-cacti-0.8.1-r1
new file mode 100644
index 000000000000..3ec1397a3b8d
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.1-r1
@@ -0,0 +1 @@
+MD5 d87613690e82e025412de6d747b0674e cacti-0.8.1.tar.gz 513944