summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-09-20 16:59:48 +0000
committerJeroen Roovers <jer@gentoo.org>2013-09-20 16:59:48 +0000
commited4174245b6e599b7e80a63ba0768996b17840e0 (patch)
tree79080662264f3f4497c8c46980375f6a793dc6ce /net-analyzer
parentMarked ~hppa too. (diff)
downloadgentoo-2-ed4174245b6e599b7e80a63ba0768996b17840e0.tar.gz
gentoo-2-ed4174245b6e599b7e80a63ba0768996b17840e0.tar.bz2
gentoo-2-ed4174245b6e599b7e80a63ba0768996b17840e0.zip
Migrate from python.eclass to distutils-r1.eclass.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/ChangeLog5
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.7.2.ebuild38
2 files changed, 11 insertions, 32 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index e309e920188c..8624493895c8 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.250 2013/09/20 15:23:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.251 2013/09/20 16:59:48 jer Exp $
+
+ 20 Sep 2013; Jeroen Roovers <jer@gentoo.org> net-snmp-5.7.2.ebuild:
+ Migrate from python.eclass to distutils-r1.eclass.
20 Sep 2013; Jeroen Roovers <jer@gentoo.org> net-snmp-5.7.2_rc1.ebuild,
net-snmp-5.7.2.ebuild:
diff --git a/net-analyzer/net-snmp/net-snmp-5.7.2.ebuild b/net-analyzer/net-snmp/net-snmp-5.7.2.ebuild
index bb45d67e3049..1247e0dc8f8b 100644
--- a/net-analyzer/net-snmp/net-snmp-5.7.2.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.7.2.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2.ebuild,v 1.4 2013/09/20 15:23:19 jer Exp $
-
-EAPI=4
-PYTHON_DEPEND="python? 2"
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2.ebuild,v 1.5 2013/09/20 16:59:48 jer Exp $
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+DISTUTILS_SINGLE_IMPL=yesplz
+DISTUTILS_OPTIONAL=yesplz
WANT_AUTOMAKE=none
-
PATCHSET=1
-inherit eutils perl-module python autotools
+inherit autotools distutils-r1 eutils perl-module
MY_P="${P/_rc/.rc}"
@@ -33,7 +33,7 @@ COMMON="ssl? ( >=dev-libs/openssl-0.9.6d )
bzip2? ( app-arch/bzip2 )
zlib? ( >=sys-libs/zlib-1.1.4 )
elf? ( dev-libs/elfutils )
- python? ( dev-python/setuptools )
+ python? ( dev-python/setuptools ${PYTHON_DEPS} )
pci? ( sys-apps/pciutils )
lm_sensors? ( sys-apps/lm_sensors )
netlink? ( dev-libs/libnl:1.1 )
@@ -58,13 +58,6 @@ RESTRICT=test
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
src_prepare() {
# snmpconf generates config files with proper selinux context
use selinux && epatch "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
@@ -78,8 +71,6 @@ src_configure() {
local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail smux"
use lm_sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
- use python && export PYTHON_DIR="$(python_get_sitedir)"
-
econf \
$(use_enable !ssl internal-md5) \
$(use_enable ipv6) \
@@ -154,18 +145,3 @@ src_install () {
"${D}"/**/*.pl
fi
}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize netsnmp
- fi
-
- elog "An example configuration file has been installed in"
- elog "/etc/snmp/snmpd.conf.example."
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup netsnmp
- fi
-}