summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-02-16 17:09:51 +0000
committerAron Griffis <agriffis@gentoo.org>2002-02-16 17:09:51 +0000
commite8a6b1773b5b420be4b93f31cb05a16fc0dcb312 (patch)
tree1caa010029c0ea26123c5e713e11b8908cac1253 /net-analyzer
parentFixed problem of installing outside of sandbox (diff)
downloadgentoo-2-e8a6b1773b5b420be4b93f31cb05a16fc0dcb312.tar.gz
gentoo-2-e8a6b1773b5b420be4b93f31cb05a16fc0dcb312.tar.bz2
gentoo-2-e8a6b1773b5b420be4b93f31cb05a16fc0dcb312.zip
Added net-analyzers/trafshow-3.1 ebuild from Aubrey Kilian
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/trafshow/files/digest-trafshow-3.11
-rw-r--r--net-analyzer/trafshow/files/trafshow-3.1-gentoo.patch11
-rw-r--r--net-analyzer/trafshow/trafshow-3.1.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/trafshow/files/digest-trafshow-3.1 b/net-analyzer/trafshow/files/digest-trafshow-3.1
new file mode 100644
index 000000000000..906d6b7d4501
--- /dev/null
+++ b/net-analyzer/trafshow/files/digest-trafshow-3.1
@@ -0,0 +1 @@
+MD5 085b99f160002a269b358aab1c5004f0 trafshow-3.1.tgz 72342
diff --git a/net-analyzer/trafshow/files/trafshow-3.1-gentoo.patch b/net-analyzer/trafshow/files/trafshow-3.1-gentoo.patch
new file mode 100644
index 000000000000..8c8fc5d999a7
--- /dev/null
+++ b/net-analyzer/trafshow/files/trafshow-3.1-gentoo.patch
@@ -0,0 +1,11 @@
+--- trafshow-3.1/Makefile.in.old 1998-08-24 00:54:16.000000000 -0400
++++ trafshow-3.1/Makefile.in 2002-02-16 12:07:04.000000000 -0500
+@@ -70,7 +70,7 @@
+ install: force
+ ./install-sh -c -s -m 550 -o bin -g @V_GROUP@ $(PROG) $(DESTDIR)$(BINDEST)/$(PROG)
+ ./install-sh -c -m 444 -o bin -g bin $(PROG).1 $(DESTDIR)$(MANDEST)/man1/$(PROG).1
+- ./install-sh -c -o root -m 644 .trafshow /etc/$(PROG)
++ ./install-sh -c -o root -m 644 .trafshow $(DESTDIR)/etc/$(PROG)
+
+ clean:
+ rm -f $(CLEANFILES)
diff --git a/net-analyzer/trafshow/trafshow-3.1.ebuild b/net-analyzer/trafshow/trafshow-3.1.ebuild
new file mode 100644
index 000000000000..3ca85f8322b5
--- /dev/null
+++ b/net-analyzer/trafshow/trafshow-3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Aubrey Kilian <aubrey@ebe.uct.ac.za>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafshow/trafshow-3.1.ebuild,v 1.1 2002/02/16 17:09:51 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Full screen visualization of the network traffic"
+SRC_URI="ftp://ftp.nsk.su/pub/RinetSoftware/${P}.tgz"
+HOMEPAGE="http://soft.risp.ru/trafshow/index_en.shtml"
+
+DEPEND="net-libs/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=\${prefix}/share/man \
+ --enable-ipv6 || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+}