summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-11-04 19:38:42 +0000
committerThilo Bangert <bangert@gentoo.org>2008-11-04 19:38:42 +0000
commitd114933b41904e276777d7946461e93c68d5ab60 (patch)
tree7bfb01051801597dd210b447b238ef6efffa27bc /net-analyzer
parentRevert upstream changes that cause broken graphs in cacti, bug #245331, thank... (diff)
downloadgentoo-2-d114933b41904e276777d7946461e93c68d5ab60.tar.gz
gentoo-2-d114933b41904e276777d7946461e93c68d5ab60.tar.bz2
gentoo-2-d114933b41904e276777d7946461e93c68d5ab60.zip
version bump and warning fixes by Jeroen Roovers - bug #244388
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/dhcpdump/ChangeLog9
-rw-r--r--net-analyzer/dhcpdump/dhcpdump-1.8.ebuild34
-rw-r--r--net-analyzer/dhcpdump/files/dhcpdump-1.8-Makefile.patch22
-rw-r--r--net-analyzer/dhcpdump/files/dhcpdump-1.8-debian.patch103
4 files changed, 167 insertions, 1 deletions
diff --git a/net-analyzer/dhcpdump/ChangeLog b/net-analyzer/dhcpdump/ChangeLog
index dd9c355b057e..bf7ffe677151 100644
--- a/net-analyzer/dhcpdump/ChangeLog
+++ b/net-analyzer/dhcpdump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/dhcpdump
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/ChangeLog,v 1.2 2008/06/11 07:44:49 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/ChangeLog,v 1.3 2008/11/04 19:38:42 bangert Exp $
+
+*dhcpdump-1.8 (04 Nov 2008)
+
+ 04 Nov 2008; Thilo Bangert <bangert@gentoo.org>
+ +files/dhcpdump-1.8-Makefile.patch, +files/dhcpdump-1.8-debian.patch,
+ +dhcpdump-1.8.ebuild:
+ version bump and warning fixes by Jeroen Roovers - bug #244388
11 Jun 2008; Thilo Bangert <bangert@gentoo.org> dhcpdump-1.7.ebuild:
add amd64 keyword - bug #225787
diff --git a/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild b/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild
new file mode 100644
index 000000000000..72cd25b154e8
--- /dev/null
+++ b/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild,v 1.1 2008/11/04 19:38:42 bangert Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="DHCP Packet Analyzer/tcpdump postprocessor"
+HOMEPAGE="http://www.mavetju.org/unix/general.php"
+SRC_URI="http://www.mavetju.org/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-debian.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install () {
+ dobin ${PN}
+ doman ${PN}.8
+ dodoc CHANGES CONTACT
+}
diff --git a/net-analyzer/dhcpdump/files/dhcpdump-1.8-Makefile.patch b/net-analyzer/dhcpdump/files/dhcpdump-1.8-Makefile.patch
new file mode 100644
index 000000000000..d089fe3da04b
--- /dev/null
+++ b/net-analyzer/dhcpdump/files/dhcpdump-1.8-Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2008-06-24 05:26:52.000000000 +0200
++++ Makefile 2008-10-26 01:22:32.000000000 +0200
+@@ -1,6 +1,6 @@
+-CFLAGS= -Wall -g
+-LDFLAGS= -g
+-LIBS= -lpcap
++#CFLAGS = -Wall -g
++#LDFLAGS = -g
++LIBS = -lpcap
+
+ all: dhcpdump dhcpdump.8
+
+@@ -15,7 +15,7 @@
+ dhcpdump.pod dhcpdump.8
+
+ dhcpdump: dhcpdump.o
+- ${CC} ${LDFLAGS} -o $@ dhcpdump.o ${LIBS}
++ $(CC) -DHAVE_STRSEP $(LDFLAGS) -o $@ dhcpdump.o $(LIBS)
+
+ dhcpdump.o: dhcpdump.c dhcp_options.h Makefile
+- ${CC} ${CFLAGS} -c -o $@ dhcpdump.c
++ $(CC) -DHAVE_STRSEP $(CFLAGS) -c -o $@ dhcpdump.c
diff --git a/net-analyzer/dhcpdump/files/dhcpdump-1.8-debian.patch b/net-analyzer/dhcpdump/files/dhcpdump-1.8-debian.patch
new file mode 100644
index 000000000000..a5882df76f7a
--- /dev/null
+++ b/net-analyzer/dhcpdump/files/dhcpdump-1.8-debian.patch
@@ -0,0 +1,103 @@
+--- dhcpdump-1.8.orig/dhcpdump.c
++++ dhcpdump-1.8/dhcpdump.c
+@@ -16,11 +16,13 @@
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/udp.h>
++#include <netinet/ether.h>
+ #include <arpa/inet.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <time.h>
+ #include <pcap.h>
+ #include <err.h>
+ #include <regex.h>
+@@ -38,11 +40,11 @@
+ #define LARGESTRING 1024
+
+ // header variables
+-u_char timestamp[40]; // timestamp on header
+-u_char mac_origin[40]; // mac address of origin
+-u_char mac_destination[40]; // mac address of destination
+-u_char ip_origin[40]; // ip address of origin
+-u_char ip_destination[40]; // ip address of destination
++char timestamp[40]; // timestamp on header
++char mac_origin[40]; // mac address of origin
++char mac_destination[40]; // mac address of destination
++char ip_origin[40]; // ip address of origin
++char ip_destination[40]; // ip address of destination
+ int max_data_len; // maximum size of a packet
+
+ int tcpdump_style = -1;
+@@ -160,13 +162,21 @@
+ strcpy(mac_destination,
+ ether_ntoa((struct ether_addr *)eh->ether_dhost));
+
+- strcpy(ip_origin, (u_char *)inet_ntoa(ip->ip_src));
+- strcpy(ip_destination, (u_char *)inet_ntoa(ip->ip_dst));
++ strcpy(ip_origin, (char *)inet_ntoa(ip->ip_src));
++ strcpy(ip_destination, (char *)inet_ntoa(ip->ip_dst));
+
++#ifdef __linux__
++ if (hmask && check_ch((u_char *)(sp + offset), ntohs(udp->len)))
++ return;
++
++ printdata((u_char *)(sp + offset), ntohs(udp->len));
++#else
+ if (hmask && check_ch((u_char *)(sp + offset), ntohs(udp->uh_ulen)))
+ return;
+
+ printdata((u_char *)(sp + offset), ntohs(udp->uh_ulen));
++#endif
++
+ }
+
+ // check for matching CHADDR (Peter Apian-Bennewitz <apian@ise.fhg.de>)
+@@ -301,7 +311,7 @@
+ // print the header and the options.
+ int printdata(u_char *data, int data_len) {
+ int j, i;
+- u_char buf[LARGESTRING];
++ char buf[LARGESTRING];
+
+ if (data_len == 0)
+ return 0;
+@@ -364,7 +374,7 @@
+ case 60: // Domain name
+ case 86: // NDS Tree name
+ case 87: // NDS context
+- strncpy(buf, &data[j + 2], data[j + 1]);
++ strncpy(buf, (char *)&data[j + 2], data[j + 1]);
+ buf[data[j + 1]] = 0;
+ printf("%s", buf);
+ break;
+@@ -510,7 +520,7 @@
+ printf("-");
+ print8bits(data + j + 4);
+ printf(" ");
+- strncpy(buf, &data[j + 5], data[j + 1] - 3);
++ strncpy(buf, (char *)&data[j + 5], data[j + 1] - 3);
+ buf[data[j + 1] - 3]=0;
+ printf("%s", buf);
+ break;
+@@ -518,6 +528,9 @@
+ case 82: // Relay Agent Information
+ printf("\n");
+ for (i = j + 2; i < j + data[j + 1]; ) {
++ if (i != j+2) {
++ printf("\n");
++ }
+ printf("%-17s %-13s ", " ",
+ data[i] > sizeof(relayagent_suboptions) ?
+ "*wrong value*" :
+@@ -527,7 +540,7 @@
+ break;
+ }
+ printHexColon(data + i + 2, data[i + 1]);
+- i += data[i + 1];
++ i += data[i + 1] + 2;
+ }
+ break;
+