summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2006-06-06 14:22:11 +0000
committerWolfram Schlich <wschlich@gentoo.org>2006-06-06 14:22:11 +0000
commitceaba518c7b01e1d836a6fe7043b42a689da724c (patch)
tree5b4e20bc961c386148d118d204fd45e4dfabc9d8 /net-analyzer
parentCommented inherit line to remove cvs and added a new inherit line without cvs... (diff)
downloadgentoo-2-ceaba518c7b01e1d836a6fe7043b42a689da724c.tar.gz
gentoo-2-ceaba518c7b01e1d836a6fe7043b42a689da724c.tar.bz2
gentoo-2-ceaba518c7b01e1d836a6fe7043b42a689da724c.zip
maintainer takeover, version bump
(Portage version: 2.1_rc4-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix-frontend/ChangeLog10
-rw-r--r--net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.13
-rw-r--r--net-analyzer/zabbix-frontend/files/postinstall-en-1.1.txt7
-rw-r--r--net-analyzer/zabbix-frontend/zabbix-frontend-1.1.ebuild34
4 files changed, 52 insertions, 2 deletions
diff --git a/net-analyzer/zabbix-frontend/ChangeLog b/net-analyzer/zabbix-frontend/ChangeLog
index 8f7ef85ef5e1..e59221e61a3b 100644
--- a/net-analyzer/zabbix-frontend/ChangeLog
+++ b/net-analyzer/zabbix-frontend/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/zabbix-frontend
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-frontend/ChangeLog,v 1.2 2005/07/19 16:47:15 dholm Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-frontend/ChangeLog,v 1.3 2006/06/06 14:22:11 wschlich Exp $
+
+*zabbix-frontend-1.1 (06 Jun 2006)
+
+ 06 Jun 2006; Wolfram Schlich <wschlich@gentoo.org>
+ +files/postinstall-en-1.1.txt, +zabbix-frontend-1.1.ebuild:
+ maintainer takeover, version bump
19 Jul 2005; David Holm <dholm@gentoo.org>
zabbix-frontend-1.1_alpha7.ebuild:
diff --git a/net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.1 b/net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.1
new file mode 100644
index 000000000000..70bfbcd9a4ca
--- /dev/null
+++ b/net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.1
@@ -0,0 +1,3 @@
+MD5 9697e5634547d9614963db04f6cd87d7 zabbix-1.1.tar.gz 1110644
+RMD160 4ef49a92117ef4aa9a2369d49008582f7db14b5f zabbix-1.1.tar.gz 1110644
+SHA256 c544e8b1ba9e3fc62ed283bab058ad753cf3e9ed39ab2aee97c75d483ddfcfa5 zabbix-1.1.tar.gz 1110644
diff --git a/net-analyzer/zabbix-frontend/files/postinstall-en-1.1.txt b/net-analyzer/zabbix-frontend/files/postinstall-en-1.1.txt
new file mode 100644
index 000000000000..a90a3e63e967
--- /dev/null
+++ b/net-analyzer/zabbix-frontend/files/postinstall-en-1.1.txt
@@ -0,0 +1,7 @@
+Change these values in ${VHOST_ROOT}/${PN}/include/db.inc.php:
+
+ $DB_TYPE
+ $DB_SERVER
+ $DB_DATABASE
+ $DB_USER
+ $DB_PASSWORD
diff --git a/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.ebuild b/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.ebuild
new file mode 100644
index 000000000000..6d7e58cb795e
--- /dev/null
+++ b/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.ebuild,v 1.1 2006/06/06 14:22:11 wschlich Exp $
+
+inherit eutils webapp depend.php
+
+MY_P=${PN//-frontend/}
+MY_PV=${PV//_/}
+DESCRIPTION="Zabbix PHP web-frontend"
+
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${MY_P}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+need_php_httpd
+
+S=${WORKDIR}/${MY_P}-${MY_PV}/frontends
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_gd
+}
+
+src_install() {
+ webapp_src_preinst
+ cp -R php/* "${D}/${MY_HTDOCSDIR}"
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-${MY_PV}.txt
+ webapp_configfile ${MY_HTDOCSDIR}/include/db.inc.php
+ webapp_src_install
+ fowners -R zabbix:zabbix ${MY_HTDOCSDIR}
+}