summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-11-24 09:55:13 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-11-24 09:55:13 +0000
commitc997c50d72b8c8482b39a05d69dea73272d8563e (patch)
tree5aa02d70c654de2851b69d21251c2ec44a0f03d9 /net-analyzer
parentPrevent update script from failing and removing default ssh key, bug #248049 (diff)
downloadgentoo-2-c997c50d72b8c8482b39a05d69dea73272d8563e.tar.gz
gentoo-2-c997c50d72b8c8482b39a05d69dea73272d8563e.tar.bz2
gentoo-2-c997c50d72b8c8482b39a05d69dea73272d8563e.zip
Fixed LDFLAGS ordering, see bug #247926.
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethstatus/ChangeLog7
-rw-r--r--net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild12
2 files changed, 15 insertions, 4 deletions
diff --git a/net-analyzer/ethstatus/ChangeLog b/net-analyzer/ethstatus/ChangeLog
index 5b7fb1df5456..d64e7831258b 100644
--- a/net-analyzer/ethstatus/ChangeLog
+++ b/net-analyzer/ethstatus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ethstatus
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethstatus/ChangeLog,v 1.7 2007/02/09 04:00:53 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethstatus/ChangeLog,v 1.8 2008/11/24 09:55:13 s4t4n Exp $
+
+ 24 Nov 2008; Michele Noberasco <s4t4n@gentoo.org> ChangeLog:
+ Fixed LDFLAGS ordering, see bug #247926.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild b/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild
index 9318b901fb43..e88d25ad3340 100644
--- a/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild
+++ b/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild,v 1.5 2005/07/19 13:04:06 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethstatus/ethstatus-0.4.2-r2.ebuild,v 1.6 2008/11/24 09:55:13 s4t4n Exp $
DESCRIPTION="ncurses based utility to display real time statistics about network traffic."
HOMEPAGE="http://ethstatus.calle69.net/"
@@ -13,6 +13,14 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5.4-r1"
+src_unpack()
+{
+ unpack ${A}
+
+ #Fix LDFLAGS ordering, see bug #247926
+ sed -i 's/$(LDFLAGS) -o ${BIN} ${SRC}/-o ${BIN} ${SRC} $(LDFLAGS)/' "${S}/Makefile"
+}
+
src_compile()
{
emake CFLAGS="${CFLAGS}" || die "Compilation failed"