summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-02-21 23:10:48 +0000
committerMichael Orlitzky <mjo@gentoo.org>2015-02-21 23:10:48 +0000
commitc1bf8dcde2d437aad9be92a7daf465f1128772be (patch)
treeefbd2938414c4194a87305cdd5f685334212968f /net-analyzer
parentAdd myself as a maintainer. (diff)
downloadgentoo-2-c1bf8dcde2d437aad9be92a7daf465f1128772be.tar.gz
gentoo-2-c1bf8dcde2d437aad9be92a7daf465f1128772be.tar.bz2
gentoo-2-c1bf8dcde2d437aad9be92a7daf465f1128772be.zip
New package with standard plugins for Icinga, Naemon, Nagios, etc. by Tomas Mozes (bug #520196).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/monitoring-plugins/ChangeLog10
-rw-r--r--net-analyzer/monitoring-plugins/metadata.xml31
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild96
3 files changed, 137 insertions, 0 deletions
diff --git a/net-analyzer/monitoring-plugins/ChangeLog b/net-analyzer/monitoring-plugins/ChangeLog
new file mode 100644
index 000000000000..2fb2729fd55f
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/monitoring-plugins
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/monitoring-plugins/ChangeLog,v 1.1 2015/02/21 23:10:48 mjo Exp $
+
+*monitoring-plugins-2.1.1 (21 Feb 2015)
+
+ 21 Feb 2015; Michael Orlitzky <mjo@gentoo.org> +metadata.xml,
+ +monitoring-plugins-2.1.1.ebuild:
+ New package with standard plugins for Icinga, Naemon, Nagios, etc. by Tomas
+ Mozes (bug #520196).
diff --git a/net-analyzer/monitoring-plugins/metadata.xml b/net-analyzer/monitoring-plugins/metadata.xml
new file mode 100644
index 000000000000..0c283ab6e982
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <use>
+ <flag name='dns'>
+ Install <pkg>net-dns/bind-tools</pkg> required for monitoring
+ DNS servers. Disabling the flag does not remove any plugins.
+ </flag>
+ <flag name='game'>
+ Install <pkg>games-util/qstat</pkg> required for monitoring FPS
+ servers. Disabling the flag does not remove any plugins.
+ </flag>
+ <flag name='fping'>
+ Install <pkg>net-analyzer/fping</pkg> required for fancy ping
+ monitoring. Disabling the flag does not remove any plugins.
+ </flag>
+ <flag name='ssh'>
+ Install <pkg>net-misc/openssh</pkg> required for monitoring SSH
+ servers. Disabling the flag does not remove any plugins.
+ </flag>
+ <flag name='snmp'>
+ Install <pkg>dev-perl/Net-SNMP</pkg> and
+ <pkg>net-analyzer/net-snmp</pkg> required for monitoring SNMP
+ values. Disabling the flag does not remove any plugins.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild
new file mode 100644
index 000000000000..dbf03c441d73
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild,v 1.1 2015/02/21 23:10:48 mjo Exp $
+
+EAPI=5
+
+inherit eutils multilib user
+
+DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
+HOMEPAGE="https://www.monitoring-plugins.org/"
+SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls ipv6 ldap mysql dns fping game postgres samba snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+#
+# REAL_DEPEND contains the dependencies that are actually needed to
+# build. DEPEND contains those plus the automagic dependencies.
+#
+REAL_DEPEND="dev-lang/perl
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ ssl? (
+ !gnutls? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )
+ )"
+
+DEPEND="${REAL_DEPEND}
+ dns? ( net-dns/bind-tools )
+ game? ( games-util/qstat )
+ fping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Basically everything collides with nagios-plugins.
+RDEPEND="${DEPEND}
+ !net-analyzer/nagios-plugins"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+src_configure() {
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with !gnutls openssl /usr)
+ $(use_with gnutls gnutls /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
+ NEWS README REQUIREMENTS SUPPORT THANKS )
+
+pkg_preinst() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${ROOT}usr/$(get_libdir)/nagios/plugins"
+}