summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-10 20:06:00 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-10 20:06:00 +0000
commitb9ef4cdf033f76d3233f356543c2f023685cebea (patch)
treec76607d0382898f518259d0c107cefea45e182e0 /net-analyzer
parentBump to 0.8.8, bug #430478. Thanks to Enrico Tagliavini. (diff)
downloadgentoo-2-b9ef4cdf033f76d3233f356543c2f023685cebea.tar.gz
gentoo-2-b9ef4cdf033f76d3233f356543c2f023685cebea.tar.bz2
gentoo-2-b9ef4cdf033f76d3233f356543c2f023685cebea.zip
Add prefix support by Christoph Junghans (bug #461296).
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netselect/ChangeLog10
-rw-r--r--net-analyzer/netselect/netselect-0.3-r3.ebuild (renamed from net-analyzer/netselect/netselect-0.3-r1.ebuild)35
2 files changed, 25 insertions, 20 deletions
diff --git a/net-analyzer/netselect/ChangeLog b/net-analyzer/netselect/ChangeLog
index fc89b17ec292..4aec08580faf 100644
--- a/net-analyzer/netselect/ChangeLog
+++ b/net-analyzer/netselect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netselect
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.40 2012/10/14 21:53:59 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.41 2013/03/10 20:06:00 jer Exp $
+
+*netselect-0.3-r3 (10 Mar 2013)
+
+ 10 Mar 2013; Jeroen Roovers <jer@gentoo.org> -netselect-0.3-r1.ebuild,
+ +netselect-0.3-r3.ebuild:
+ Add prefix support by Christoph Junghans (bug #461296).
14 Oct 2012; Alexis Ballier <aballier@gentoo.org> netselect-0.3-r2.ebuild:
keyword ~amd64-fbsd
diff --git a/net-analyzer/netselect/netselect-0.3-r1.ebuild b/net-analyzer/netselect/netselect-0.3-r3.ebuild
index e8524ad46fd6..f694ccd0ff9c 100644
--- a/net-analyzer/netselect/netselect-0.3-r1.ebuild
+++ b/net-analyzer/netselect/netselect-0.3-r3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r1.ebuild,v 1.21 2011/02/06 07:50:14 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r3.ebuild,v 1.1 2013/03/10 20:06:00 jer Exp $
-inherit eutils flag-o-matic
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Ultrafast implementation of ping."
HOMEPAGE="http://alumnit.ca/~apenwarr/netselect/index.html"
@@ -10,34 +11,32 @@ SRC_URI="http://alumnit.ca/~apenwarr/netselect/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S=${WORKDIR}/${PN}
+src_prepare() {
epatch "${FILESDIR}/${P}-bsd.patch"
-}
-src_compile() {
sed -i \
- -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:PREFIX =.*:PREFIX = ${ED}usr:" \
-e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
-e "s:LDFLAGS =.*:LDFLAGS = -g ${LDFLAGS}:" \
-e '23,27d' \
-e '34d' \
- Makefile \
- || die "sed Makefile failed"
+ Makefile || die
+}
- emake || die "emake failed"
+src_compile() {
+ emake CC="$(tc-getCC)"
}
src_install () {
- dobin netselect || die "dobin failed"
- fowners root:wheel /usr/bin/netselect
- fperms 4711 /usr/bin/netselect
+ dobin netselect
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
dodoc ChangeLog HISTORY README*
}