summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-09-03 18:48:33 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-09-03 18:48:33 +0000
commitb65445567909867480d12739c0fadcf1da7d196b (patch)
tree19c48847c8174567acc005a3de655dc0479cb9f0 /net-analyzer
parentVersion bump wrt #433718 by Simon Kohlmeyer (diff)
downloadgentoo-2-b65445567909867480d12739c0fadcf1da7d196b.tar.gz
gentoo-2-b65445567909867480d12739c0fadcf1da7d196b.tar.bz2
gentoo-2-b65445567909867480d12739c0fadcf1da7d196b.zip
Add missing includes patch, fixes bug 425182 and bug 433800
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/mk-livestatus/ChangeLog8
-rw-r--r--net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch11
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild8
3 files changed, 22 insertions, 5 deletions
diff --git a/net-analyzer/mk-livestatus/ChangeLog b/net-analyzer/mk-livestatus/ChangeLog
index c92dd73439a6..4fc62a468770 100644
--- a/net-analyzer/mk-livestatus/ChangeLog
+++ b/net-analyzer/mk-livestatus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/mk-livestatus
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.3 2011/04/27 13:50:15 idl0r Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.4 2012/09/03 18:48:33 idl0r Exp $
+
+ 03 Sep 2012; Christian Ruppert <idl0r@gentoo.org>
+ mk-livestatus-1.1.10_p1.ebuild, +files/gcc-4.7-compile.patch:
+ Add missing includes patch, fixes bug 425182 and bug 433800
*mk-livestatus-1.1.10_p1 (27 Apr 2011)
diff --git a/net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch b/net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch
new file mode 100644
index 000000000000..186f610109f6
--- /dev/null
+++ b/net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch
@@ -0,0 +1,11 @@
+--- src/TableLog.cc.orig 2012-07-07 19:52:47.171651476 +0200
++++ src/TableLog.cc 2012-07-07 19:53:20.291525974 +0200
+@@ -41,6 +41,8 @@
+ #include "TableCommands.h"
+ #include "TableContacts.h"
+
++#include <cstddef>
++
+ #define CHECK_MEM_CYCLE 1000 /* Check memory every N'th new message */
+
+ // watch nagios' logfile rotation
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild
index 04b05c9babed..91c7f4a26376 100644
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild,v 1.1 2011/04/27 13:50:15 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild,v 1.2 2012/09/03 18:48:33 idl0r Exp $
EAPI=3
@@ -10,7 +10,7 @@ PERL_EXPORT_PHASE_FUNCTIONS=no
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
-inherit perl-module python
+inherit perl-module python eutils
DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
@@ -56,6 +56,8 @@ src_prepare() {
fi
sed -i -e 's:$(LDFLAGS) -s:$(LDFLAGS):' src/Makefile.in || die
+
+ epatch "${FILESDIR}/gcc-4.7-compile.patch"
}
src_configure() {