summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-06 10:17:47 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-06 10:17:47 +0000
commitb488450e2d0c9be4f65c742282d1687dd540cc0b (patch)
tree8c65170c91a642f4cfc42838586121a40ee932a2 /net-analyzer
parentVersion Bump (diff)
downloadgentoo-2-b488450e2d0c9be4f65c742282d1687dd540cc0b.tar.gz
gentoo-2-b488450e2d0c9be4f65c742282d1687dd540cc0b.tar.bz2
gentoo-2-b488450e2d0c9be4f65c742282d1687dd540cc0b.zip
Version Bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/greenbone-security-assistant/ChangeLog9
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.6.ebuild61
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild4
3 files changed, 71 insertions, 3 deletions
diff --git a/net-analyzer/greenbone-security-assistant/ChangeLog b/net-analyzer/greenbone-security-assistant/ChangeLog
index 7c3dcf22db93..dedf44a60063 100644
--- a/net-analyzer/greenbone-security-assistant/ChangeLog
+++ b/net-analyzer/greenbone-security-assistant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/greenbone-security-assistant
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.16 2015/02/15 02:02:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.17 2015/03/06 10:17:47 jlec Exp $
+
+*greenbone-security-assistant-5.0.6 (06 Mar 2015)
+
+ 06 Mar 2015; Justin Lecher <jlec@gentoo.org>
+ +greenbone-security-assistant-5.0.6.ebuild,
+ greenbone-security-assistant-6.0_beta6.ebuild:
+ Version Bump
15 Feb 2015; Patrick Lauer <patrick@gentoo.org>
-greenbone-security-assistant-5.0.4.ebuild:
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.6.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.6.ebuild
new file mode 100644
index 000000000000..e0716bfbde45
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-5.0.6.ebuild,v 1.1 2015/03/06 10:17:47 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils systemd
+
+MY_PN=gsad
+
+DL_ID=1967
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-7.0.9
+ dev-libs/libxslt
+ net-libs/libmicrohttpd[messages]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.3-run.patch
+ )
+
+src_prepare() {
+ sed \
+ -e '/^install.*OPENVAS_CACHE_DIR.*/d' \
+ -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}/var"
+ -DSYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/${MY_PN}.init ${MY_PN}
+
+ insinto /etc/openvas
+ doins "${FILESDIR}"/${MY_PN}-daemon.conf
+ dosym ../openvas/${MY_PN}-daemon.conf /etc/conf.d/${PN}
+
+ insinto /etc/logrotate.d
+ doins "${FILESDIR}"/${MY_PN}.logrotate
+
+ systemd_newtmpfilesd "${FILESDIR}"/${MY_PN}.tmpfiles.d ${MY_PN}.conf
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+}
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild
index 6d7aaf3a0005..7f77333b8659 100644
--- a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild,v 1.1 2015/02/14 18:33:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0_beta6.ebuild,v 1.2 2015/03/06 10:17:47 jlec Exp $
EAPI=5
@@ -20,7 +20,7 @@ KEYWORDS=""
IUSE=""
RDEPEND="
- dev-libs/libgcrypt
+ dev-libs/libgcrypt:0
dev-libs/libxslt
>=net-analyzer/openvas-libraries-8.0_beta6
net-libs/libmicrohttpd[messages]"