summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-16 07:12:54 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-16 07:12:54 +0000
commitab72938f4e499467ab8b3424e9f6936f01229787 (patch)
treea7d14848b473104a61de75e4b825159c2f5e94df /net-analyzer
parentRevision bump ragel to fix the generated state machines to work with Ruby 1.9... (diff)
downloadgentoo-2-ab72938f4e499467ab8b3424e9f6936f01229787.tar.gz
gentoo-2-ab72938f4e499467ab8b3424e9f6936f01229787.tar.bz2
gentoo-2-ab72938f4e499467ab8b3424e9f6936f01229787.zip
Version bump, bug 343017. Fix build with USE=ruby, bug 321749. Discussed with rej on IRC.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog9
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.4.4-dont-link-system-lib.patch16
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.4.4.ebuild97
3 files changed, 121 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 451ed9f9bdc8..1878755ad13c 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.206 2010/10/16 13:52:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.207 2010/12/16 07:12:54 graaff Exp $
+
+*rrdtool-1.4.4 (16 Dec 2010)
+
+ 16 Dec 2010; Hans de Graaff <graaff@gentoo.org> +rrdtool-1.4.4.ebuild,
+ +files/rrdtool-1.4.4-dont-link-system-lib.patch:
+ Version bump, bug 343017. Fix build with USE=ruby, bug 321749. Discussed
+ with rej on IRC.
16 Oct 2010; Hans de Graaff <graaff@gentoo.org> rrdtool-1.3.8.ebuild:
Also apply the patch for bug 321749 to the stable version to fix USE=ruby
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.4.4-dont-link-system-lib.patch b/net-analyzer/rrdtool/files/rrdtool-1.4.4-dont-link-system-lib.patch
new file mode 100644
index 000000000000..5d8f8498f264
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.4.4-dont-link-system-lib.patch
@@ -0,0 +1,16 @@
+Make sure the Makefile for the ruby binding does not look in the
+normal library path first by setting it to something else that will
+not contain a rrd.so library. This is the least invasive method to fix
+the linking order.
+
+--- bindings/Makefile.am.~1~ 2010-03-02 17:54:04.000000000 +0100
++++ bindings/Makefile.am 2010-11-27 14:19:07.080938486 +0100
+@@ -29,7 +29,7 @@
+ # RUBYARCHDIR= is to work around in a makefile quirk not sure
+ # it is is the right thing todo, but it makes rrdtool build on freebsd as well
+ ruby: Makefile
+- cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) RUBYARCHDIR=
++ cd ruby && $(RUBY) extconf.rb && $(MAKE) libdir=/lib EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) RUBYARCHDIR=
+
+ # rules for building the pyton module
+ python: Makefile
diff --git a/net-analyzer/rrdtool/rrdtool-1.4.4.ebuild b/net-analyzer/rrdtool/rrdtool-1.4.4.ebuild
new file mode 100644
index 000000000000..1259104eaf56
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.4.4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.4.4.ebuild,v 1.1 2010/12/16 07:12:54 graaff Exp $
+
+EAPI="3"
+
+GENTOO_DEPEND_ON_PERL="no"
+inherit eutils flag-o-matic multilib perl-module autotools
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+IUSE="doc lua perl python ruby rrdcgi tcl"
+
+# This versions are minimal versions upstream tested with.
+RDEPEND="
+ >=media-libs/libpng-1.2.10
+ >=dev-libs/libxml2-2.6.31
+ >=x11-libs/cairo-1.4.6[svg]
+ >=dev-libs/glib-2.12.12
+ >=x11-libs/pango-1.17
+ lua? ( dev-lang/lua )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.8.6_p287-r13 !dev-ruby/ruby-rrd )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.8-configure.ac.patch"
+ epatch "${FILESDIR}/${PN}-1.4.3-ruby-ldflags.patch"
+ epatch "${FILESDIR}/${P}-dont-link-system-lib.patch"
+ sed -i '/PERLLD/s:same as PERLCC:same-as-PERLCC:' configure.ac #281694
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
+
+ # to solve bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ econf $(use_enable rrdcgi) \
+ $(use_enable lua) \
+ $(use_enable lua lua-site-install) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_enable python)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
+ fi
+
+ if use !rrdcgi ; then
+ # uses rrdcgi, causes invalid shebang error in Prefix, useless
+ # without rrdcgi installed
+ rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
+ fi
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+}
+
+pkg_postinst() {
+ ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
+ ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
+ ewarn "causes older versions of rrdtool restore to be unhappy."
+ ewarn
+ ewarn "To restore a new dump with an old rrdtool restore version, either remove"
+ ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
+ ewarn "or use rrdtool dump --no-header."
+ ewarn
+ ewarn "Note: rrdtool-1.3.x doesn't have any default font bundled. Thus if you've"
+ ewarn "upgraded from rrdtool-1.2.x and don't have any font installed to make"
+ ewarn "lables visible, please, install some font, e.g. media-fonts/dejavu."
+}