summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-03 10:26:07 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-03 10:26:07 +0000
commita701e805c88edf1bdbaa7060091173e2a0a46591 (patch)
tree29a2555a66c03070901f3047453ce94ec43cdc27 /net-analyzer
parentPin dev-qt/qtgui to SLOT 4. (diff)
downloadgentoo-2-a701e805c88edf1bdbaa7060091173e2a0a46591.tar.gz
gentoo-2-a701e805c88edf1bdbaa7060091173e2a0a46591.tar.bz2
gentoo-2-a701e805c88edf1bdbaa7060091173e2a0a46591.zip
net-analyzer/openvas-cli: Version BUmp
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openvas-cli/ChangeLog9
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.4_beta5.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/net-analyzer/openvas-cli/ChangeLog b/net-analyzer/openvas-cli/ChangeLog
index dd258523df2c..1c1c577e1def 100644
--- a/net-analyzer/openvas-cli/ChangeLog
+++ b/net-analyzer/openvas-cli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/openvas-cli
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/ChangeLog,v 1.11 2014/12/01 16:54:36 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/ChangeLog,v 1.12 2015/02/03 10:26:07 jlec Exp $
+
+*openvas-cli-1.4_beta5 (03 Feb 2015)
+
+ 03 Feb 2015; Justin Lecher <jlec@gentoo.org> +openvas-cli-1.4_beta5.ebuild:
+ Version BUmp
*openvas-cli-1.4_beta4 (01 Dec 2014)
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.4_beta5.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.4_beta5.ebuild
new file mode 100644
index 000000000000..359b886c4db3
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.4_beta5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-cli/openvas-cli-1.4_beta5.ebuild,v 1.1 2015/02/03 10:26:07 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=1882
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-8.0_beta4
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_beta/+beta}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}