summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-23 14:57:05 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-23 14:57:05 +0000
commita0f97b432d07118385bbc40456c15351b85058d4 (patch)
tree6678142d4ef07c4383fca1f4617476feb4be088d /net-analyzer
parentkde build fix, again, and some added features for kde, see ChangeLog (Manifes... (diff)
downloadgentoo-2-a0f97b432d07118385bbc40456c15351b85058d4.tar.gz
gentoo-2-a0f97b432d07118385bbc40456c15351b85058d4.tar.bz2
gentoo-2-a0f97b432d07118385bbc40456c15351b85058d4.zip
purge
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/cacti-0.8.5a.ebuild126
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.5a1
2 files changed, 0 insertions, 127 deletions
diff --git a/net-analyzer/cacti/cacti-0.8.5a.ebuild b/net-analyzer/cacti/cacti-0.8.5a.ebuild
deleted file mode 100644
index 0afd8abd6198..000000000000
--- a/net-analyzer/cacti/cacti-0.8.5a.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.5a.ebuild,v 1.8 2004/08/07 23:52:22 slarti Exp $
-
-inherit eutils webapp-apache
-
-DESCRIPTION="Cacti is a complete frontend to rrdtool"
-HOMEPAGE="http://www.raxnet.net/products/cacti/"
-SRC_URI="http://www.raxnet.net/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~alpha ~amd64"
-IUSE="snmp mysql"
-
-DEPEND=""
-RDEPEND="net-www/apache
- snmp? ( virtual/snmp )
- net-analyzer/rrdtool
- mysql? ( dev-db/mysql )
- dev-php/php
- dev-php/mod_php"
-
-pkg_setup() {
- webapp-detect || NO_WEBSERVER=1
- webapp-pkg_setup "${NO_WEBSERVER}"
- einfo "Installing into ${ROOT}${HTTPD_ROOT}."
-}
-
-src_install() {
- webapp-mkdirs
-
- local DocumentRoot=${HTTPD_ROOT}
- local destdir=${DocumentRoot}/${PN}
- dodir ${destdir}
-
- dohtml docs/{INSTALL,UPGRADE}.htm
- dodoc docs/{CHANGELOG,CONTRIB}
- dodoc LICENSE
-
- #rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
- rm docs/{README,CHANGELOG,CONTRIB}
- rm LICENSE README
-
- #mv docs/manual .
- rm -rf docs
- rm -rf cactid
-
- edos2unix `find -type f -name '*.php'`
- #chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
- cp -r . ${D}/${HTTPD_ROOT}/${PN}
- cd ${D}/${HTTPD_ROOT}
- chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
-}
-
-pkg_postinst() {
- # check to see if we have a previous version installed
- ver_installed="$(ls -d /var/db/pkg/net-analyzer/cacti* | sed 's:.*cacti-::')"
- if [[ ${ver_installed} != ${PV} ]]
- then
- einfo
- einfo "The cacti has been installed to ${INSTALL_DEST}"
- einfo
- einfo "Before cacti works you must upgrade the cacti database:"
- einfo "1. Backup the old cacti database:"
- einfo " shell> mysqlhotcopy --suffix=_old cacti"
- einfo "2. Drop the old cacti database:"
- einfo " shell> mysqladmin -p drop cacti"
- einfo "3. Create the new cacti database"
- einfo " shell> mysqladmin --user=root create cacti"
- einfo "4. Import the default cacti database:"
- einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
- einfo "5. Edit ${INSTALL_DEST}/include/config.php."
- einfo " + Modify the MySQL user, password and database for your"
- einfo " cacti configuration."
- einfo " \$database_default = \"cacti\";"
- einfo " \$database_hostname = \"localhost\";"
- einfo " \$database_username = \"cactiuser\";"
- einfo " \$database_password = \"cacti\";"
- einfo "6. Add this line to your /etc/crontab file:"
- einfo " */5 * * * * ${HTTPD_USER} php ${HTTPD_ROOT}${PN}/cmd.php > /dev/null 2>&1"
- einfo "7. Point your web browser to: http://your-server/cacti/"
- einfo " Select \"Upgrade\"."
- einfo " Make sure to fill in all of the path variables carefully and"
- einfo " correctly on the following screen."
- einfo
- einfo "FINALLY, you must have these settings in your php.ini:"
- einfo " register_globals = On"
- einfo " register_argc_argv = On"
- einfo
- einfo "Test your upgraded installation. When all is fine you can"
- einfo "drop the cacti_old database like so:"
- einfo " shell> mysqladmin -p drop cacti_old"
- einfo
- else
- einfo
- einfo "The cacti has been copied to ${INSTALL_DEST}"
- einfo
- einfo "Before cacti works you must:"
- einfo "1. Create the new cacti database"
- einfo " shell> mysqladmin --user=root create cacti"
- einfo "2. Import the default cacti database:"
- einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
- einfo "3. Optional: Create a MySQL username and password for cacti."
- einfo " shell> mysql --user=root mysql"
- einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
- einfo " mysql> flush privileges;"
- einfo "4. Edit ${INSTALL_DEST}/include/config.php."
- einfo " + Modify the MySQL user, password and database for your"
- einfo " cacti configuration."
- einfo " \$database_default = \"cacti\";"
- einfo " \$database_hostname = \"localhost\";"
- einfo " \$database_username = \"cactiuser\";"
- einfo " \$database_password = \"cacti\";"
- einfo "5. Add this line to your /etc/crontab file:"
- einfo " */5 * * * * ${HTTPD_USER} php ${HTTPD_ROOT}${PN}/cmd.php > /dev/null 2>&1"
- einfo "6. Point your web browser to: http://your-server/cacti/"
- einfo " Make sure to fill in all of the path variables carefully and"
- einfo " correctly on the following screen."
- einfo
- einfo "FINALLY, you must have these settings in your php.ini:"
- einfo " register_globals = On"
- einfo " register_argc_argv = On"
- einfo
- fi
-}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.5a b/net-analyzer/cacti/files/digest-cacti-0.8.5a
deleted file mode 100644
index 7a5183477ccd..000000000000
--- a/net-analyzer/cacti/files/digest-cacti-0.8.5a
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2b9ef4194664d65b86cdcc9a0f126609 cacti-0.8.5a.tar.gz 986785