summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-23 11:48:14 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-23 11:48:14 +0000
commit818383a3e6eb71627293d642bcf90a8d6291f17e (patch)
treeb55535aa66d9cd08733d26ef1519886b70ea7164 /net-analyzer
parentVersion bump - closes bugs #57576, #57867, #58663, #58816, #59310 and #59687.... (diff)
downloadgentoo-2-818383a3e6eb71627293d642bcf90a8d6291f17e.tar.gz
gentoo-2-818383a3e6eb71627293d642bcf90a8d6291f17e.tar.bz2
gentoo-2-818383a3e6eb71627293d642bcf90a8d6291f17e.zip
Converted to webapp.eclass. Closes #54615.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/piwi/ChangeLog7
-rw-r--r--net-analyzer/piwi/Manifest2
-rw-r--r--net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r31
-rw-r--r--net-analyzer/piwi/piwi-0.8.0.20031109-r3.ebuild103
4 files changed, 112 insertions, 1 deletions
diff --git a/net-analyzer/piwi/ChangeLog b/net-analyzer/piwi/ChangeLog
index 7dcb74a96834..1a5ad96783dd 100644
--- a/net-analyzer/piwi/ChangeLog
+++ b/net-analyzer/piwi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/piwi
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/piwi/ChangeLog,v 1.16 2004/07/11 10:36:09 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/piwi/ChangeLog,v 1.17 2004/08/23 11:48:14 eldad Exp $
+
+*piwi-0.8.0.20031109-r3 (23 Aug 2004)
+
+ 23 Aug 2004; Eldad Zack <eldad@gentoo.org> +piwi-0.8.0.20031109-r3.ebuild:
+ Converted to webapp.eclass. Closes #54615.
11 Jul 2004; Eldad Zack <eldad@gentoo.org> piwi-0.8.0.20031109-r2.ebuild:
marked x86 stable
diff --git a/net-analyzer/piwi/Manifest b/net-analyzer/piwi/Manifest
index 201c08dcea34..db1b13095f1f 100644
--- a/net-analyzer/piwi/Manifest
+++ b/net-analyzer/piwi/Manifest
@@ -1,6 +1,8 @@
+MD5 3991bda0e6b0868cc4915d8014e21ef9 piwi-0.8.0.20031109-r3.ebuild 3269
MD5 d727de56f0f51d479c06a6aa57967c03 piwi-0.8.0.20031109-r2.ebuild 3558
MD5 090287b5b7c50d90c756e84d19b686c7 ChangeLog 2773
MD5 f05921d751b274bc413e66205f783070 metadata.xml 341
MD5 09b1b03da063c7fc20841f8a74d938ff files/make_release.sh 529
MD5 4d13a93c357ca67b8c4ca9a5085e5ab5 files/digest-piwi-0.8.0.20031109-r2 72
+MD5 4d13a93c357ca67b8c4ca9a5085e5ab5 files/digest-piwi-0.8.0.20031109-r3 72
MD5 7166a0c6b90970d69af563f6ae7b3036 files/piwi-apache.conf 371
diff --git a/net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r3 b/net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r3
new file mode 100644
index 000000000000..9cf32c317a09
--- /dev/null
+++ b/net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r3
@@ -0,0 +1 @@
+MD5 61f78ced1975e580ad32ae400ac188ad piwi_v0.8.0.20031109.tar.gz 251843
diff --git a/net-analyzer/piwi/piwi-0.8.0.20031109-r3.ebuild b/net-analyzer/piwi/piwi-0.8.0.20031109-r3.ebuild
new file mode 100644
index 000000000000..5b1fc05cda53
--- /dev/null
+++ b/net-analyzer/piwi/piwi-0.8.0.20031109-r3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/piwi/piwi-0.8.0.20031109-r3.ebuild,v 1.1 2004/08/23 11:48:14 eldad Exp $
+
+inherit webapp
+
+DESCRIPTION="(Prelude|Perl) IDS Web Interface"
+HOMEPAGE="http://www.prelude-ids.org"
+
+# [LeRoutier] son, i'll keep this versionning scheme : x.y.z.t (x.y to
+# match the major of prelude, z is piwi
+#SRC_URI="http://www.leroutier.net/Projects/PreludeIDS/${PN}_v${PV}.tar.gz"
+#SRC_URI="http://dev.gentoo.org/~mboman/distfiles/${PN}_v${PV}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}_v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="mysql postgres gd"
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ dev-perl/DBI
+ dev-perl/Date-Calc
+ virtual/ghostscript
+ dev-perl/Geo-IP
+ postgres? ( dev-perl/DBD-Pg )
+ mysql? ( dev-perl/DBD-mysql )
+ gd? ( dev-perl/GDGraph )
+"
+
+S=${WORKDIR}/
+
+src_compile() {
+ if ! use mysql && ! use postgres; then
+ eerror "You must have either MySQL or PostgreSQL enabled to use this software."
+ eerror "You must put either 'mysql' or 'postgres' (or both) in your USE flags before emerging this."
+
+ has_version ">=sys-apps/portage-2.0.50" && (
+ einfo ""
+ einfo "You can add the following line to /etc/portage/package.use"
+ einfo "to permamently set this package's USE flags:"
+ einfo ""
+ einfo "net-analyzer/piwi [use flags]"
+ einfo ""
+ )
+ exit 1
+ fi
+}
+
+
+src_install() {
+ webapp_src_preinst
+
+ dodir ${D}${MY_HTDOCSDIR}
+ dodir /etc/piwi
+
+ # "install" the files into the destination
+ cp -aR ${S}/* ${D}${MY_HTDOCSDIR}/ || die
+
+ # Fix permissions
+ chmod -R o-rwx ${D}${MY_HTDOCSDIR}/* || die
+
+ # Move files around and create symlinks to make sure configuration files
+ # are not being overwritten when you do upgrades...
+ mv ${D}/${MY_HTDOCSDIR}/generated/Filters ${D}/etc/piwi/Filters || die
+ dosym /etc/piwi/Filters ${MY_HTDOCSDIR}/generated/Filters || die
+
+ mv ${D}/${MY_HTDOCSDIR}/Profiles ${D}/etc/piwi/Profiles || die
+ dosym /etc/piwi/Profiles ${MY_HTDOCSDIR}/Profiles || die
+
+ # default config.pl is looking for ghostscript in /usr/local/... that's not where
+ # Gentoo has it.. So we do some sed magic to fix it..
+ sed -i -e 's:/usr/local/bin/gs:/usr/bin/gs:' ${D}/${MY_HTDOCSDIR}/Functions/config.pl || die
+ mv ${D}/${MY_HTDOCSDIR}/Functions/config.pl ${D}/etc/piwi/config.pl || die
+ dosym /etc/piwi/config.pl ${MY_HTDOCSDIR}/Functions/config.pl || die
+
+ # Install configuration file for apache
+ insinto /etc/piwi
+ doins ${FILESDIR}/piwi-apache.conf || die
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo ""
+ einfo "To have Apache run PIWI, please do the following:"
+ einfo "1) Include the /etc/piwi/piwi-apache.conf in your apache configuration"
+ einfo "2) Edit /etc/conf.d/apache or /etc/conf.d/apache2 and add \"-D PIWI\""
+ einfo "3) Edit /etc/piwi/config.pl to reflect your settings"
+ ewarn ""
+ ewarn "NOTE: If you do not perform these steps PIWI will _not_ work."
+ ewarn " You have been warned. Any bugs against this will be either:"
+ ewarn ""
+ ewarn " - directed to /dev/null"
+ ewarn " - resolved with a RTFM comment"
+ ewarn ""
+ ewarn "Consider yourself warned"
+ # Make sure that the user pay attention
+ echo -ne "\a"; sleep 0.25 ; echo -ne "\a"; sleep 0.25
+}