summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-04 16:06:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-04 16:06:40 +0000
commit6d2dc206e1a0c598d0f5afc83f3c43a44d1a24eb (patch)
treecea432e2809e02b1d8d0b3cf2af27cb758946051 /net-analyzer
parentSnapshot update. (diff)
downloadgentoo-2-6d2dc206e1a0c598d0f5afc83f3c43a44d1a24eb.tar.gz
gentoo-2-6d2dc206e1a0c598d0f5afc83f3c43a44d1a24eb.tar.bz2
gentoo-2-6d2dc206e1a0c598d0f5afc83f3c43a44d1a24eb.zip
Improve the patch for --as-needed. Closes bug #132659.
(Portage version: 2.1_rc4-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/ChangeLog6
-rw-r--r--net-analyzer/net-snmp/files/digest-net-snmp-5.2.2-r32
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch36
3 files changed, 41 insertions, 3 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index fc31b79107af..63fccb70729d 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.135 2006/02/11 19:46:31 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.136 2006/06/04 16:06:40 flameeyes Exp $
+
+ 04 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ files/net-snmp-5.2.2-asneeded.patch:
+ Improve the patch for --as-needed. Closes bug #132659.
*net-snmp-5.2.2-r3 (11 Feb 2006)
diff --git a/net-analyzer/net-snmp/files/digest-net-snmp-5.2.2-r3 b/net-analyzer/net-snmp/files/digest-net-snmp-5.2.2-r3
index 0cbebdac5c7a..646091cbe46d 100644
--- a/net-analyzer/net-snmp/files/digest-net-snmp-5.2.2-r3
+++ b/net-analyzer/net-snmp/files/digest-net-snmp-5.2.2-r3
@@ -1 +1,3 @@
MD5 2d9cdf956d6be5c5fcf2f898b403389b net-snmp-5.2.2.tar.gz 3919826
+RMD160 54c0bcc34ca6462aaab9ba69b06955dd7c11670f net-snmp-5.2.2.tar.gz 3919826
+SHA256 ed5cc617e4cfe38af64a3ded8542c4e61d045dbeec00d5b93a31afc3337135fd net-snmp-5.2.2.tar.gz 3919826
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch b/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch
index d84c58ebdf9a..12af501d6602 100644
--- a/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch
+++ b/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch
@@ -20,7 +20,21 @@ Index: net-snmp-5.2.2/configure.in
===================================================================
--- net-snmp-5.2.2.orig/configure.in
+++ net-snmp-5.2.2/configure.in
-@@ -2671,6 +2671,7 @@ if test "x$useopenssl" != "xno" ; then
+@@ -2362,11 +2362,12 @@ if test $? -eq 0 ; then
+ *)
+ AC_CHECK_HEADER(sensors/sensors.h,,
+ [AC_MSG_ERROR([asked to use lm_sensors but I couldn't find sensors/sensors.h])])
+- AC_CHECK_LIB(sensors, sensors_get_detected_chips, LIBS="${LIBS} -lsensors",
++ AC_CHECK_LIB(sensors, sensors_get_detected_chips, SENSORLIBS="-lsensors",
+ [AC_MSG_ERROR([asked to use lm_sensors but I couldn't find -lsensors])])
+ ;;
+ esac
+ fi
++AC_SUBST(SENSORLIBS)
+
+ #
+ # Install the various perl modules
+@@ -2691,6 +2692,7 @@ if test "x$useopenssl" != "xno" ; then
encrmodes="[disabled]"
fi
AC_DEFINE(USE_OPENSSL)
@@ -28,7 +42,7 @@ Index: net-snmp-5.2.2/configure.in
AC_MSG_RESULT(OpenSSL Support)
elif test "x$usepkcs" != "xno" ; then
authmodes="MD5 SHA1"
-@@ -2690,6 +2691,7 @@ fi
+@@ -2710,6 +2712,7 @@ fi
if test "x$enable_md5" = "xno"; then
authmodes=`echo $authmodes | sed 's/MD5 *//;'`
fi
@@ -36,3 +50,21 @@ Index: net-snmp-5.2.2/configure.in
AC_MSG_CACHE_ADD(Authentication support: $authmodes)
AC_MSG_CACHE_ADD(Encryption support: $encrmodes)
+Index: net-snmp-5.2.2/agent/Makefile.in
+===================================================================
+--- net-snmp-5.2.2.orig/agent/Makefile.in
++++ net-snmp-5.2.2/agent/Makefile.in
+@@ -130,11 +130,11 @@ snmpd$(EXEEXT): ${LAGENTOBJS} $(USELIBS)
+
+
+ libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION): ${LLIBAGENTOBJS} libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION)
+- $(LIB_LD_CMD) libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION) ${LLIBAGENTOBJS} $(LIB_LD_LIBS)
++ $(LIB_LD_CMD) libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION) ${LLIBAGENTOBJS} $(LIB_LD_LIBS) helpers/libnetsnmphelpers.la
+ $(RANLIB) libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION)
+
+ libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION): ${LMIBOBJS}
+- $(LIB_LD_CMD) libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION) ${LMIBOBJS} $(LIB_LD_LIBS)
++ $(LIB_LD_CMD) libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION) ${LMIBOBJS} $(LIB_LD_LIBS) @SENSORLIBS@
+ $(RANLIB) libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION)
+
+ embedperlinstall: