summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-04 19:32:18 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-04 19:32:18 +0000
commit690dd43c50a356609356a1bcd52eda1cebb8d1bb (patch)
tree1990cc67209f2d8a8f5469353cf24ae55d87600f /net-analyzer
parentfix ffmpeg deps for bug #245467 (diff)
downloadgentoo-2-690dd43c50a356609356a1bcd52eda1cebb8d1bb.tar.gz
gentoo-2-690dd43c50a356609356a1bcd52eda1cebb8d1bb.tar.bz2
gentoo-2-690dd43c50a356609356a1bcd52eda1cebb8d1bb.zip
Revert upstream changes that cause broken graphs in cacti, bug #245331, thank Thomas Beutin for report and fleg for tests. Remove unused.
(Portage version: 2.2_rc13/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog10
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.2.28-revert-font-fix.patch26
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.28-r1.ebuild (renamed from net-analyzer/rrdtool/rrdtool-1.3.3.ebuild)51
3 files changed, 60 insertions, 27 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 1d03b986d531..13be663fb821 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.155 2008/10/28 00:18:32 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.156 2008/11/04 19:32:17 pva Exp $
+
+*rrdtool-1.2.28-r1 (04 Nov 2008)
+
+ 04 Nov 2008; Peter Volkov <pva@gentoo.org>
+ +files/rrdtool-1.2.28-revert-font-fix.patch, +rrdtool-1.2.28-r1.ebuild,
+ -rrdtool-1.3.3.ebuild:
+ Revert upstream changes that cause broken graphs in cacti, bug #245331,
+ thank Thomas Beutin for report and fleg for tests. Remove unused.
28 Oct 2008; Brent Baude <ranger@gentoo.org> rrdtool-1.2.28.ebuild:
stable ppc64, bug 244248
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.2.28-revert-font-fix.patch b/net-analyzer/rrdtool/files/rrdtool-1.2.28-revert-font-fix.patch
new file mode 100644
index 000000000000..19a0a8072811
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.2.28-revert-font-fix.patch
@@ -0,0 +1,26 @@
+=== modified file 'src/rrd_graph.c'
+--- src/rrd_graph.c 2008-11-04 14:50:21 +0000
++++ src/rrd_graph.c 2008-11-04 14:57:04 +0000
+@@ -3508,17 +3508,15 @@
+ if (size > 0){
+ im->text_prop[propidx].size=size;
+ }
+- if (strlen(optarg) > end){
+- if (optarg[end] == ':'){
+- strncpy(im->text_prop[propidx].font,optarg+end+1,255);
++ if (strlen(prop) > end){
++ if (prop[end] == ':'){
++ strncpy(im->text_prop[propidx].font,prop+end+1,255);
+ im->text_prop[propidx].font[255] = '\0';
+ } else {
+- rrd_set_error("expected : after font size in '%s'",optarg);
++ rrd_set_error("expected after font size in '%s'",prop);
+ return;
+ }
+ }
+- /* only run the for loop for DEFAULT (0) for
+- all others, we break here. woodo programming */
+ if (propidx==sindex && sindex != 0) break;
+ }
+ } else {
+
diff --git a/net-analyzer/rrdtool/rrdtool-1.3.3.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.28-r1.ebuild
index 9724e3dd132c..f7704f353ab2 100644
--- a/net-analyzer/rrdtool/rrdtool-1.3.3.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.2.28-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.3.3.ebuild,v 1.1 2008/09/16 18:02:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.28-r1.ebuild,v 1.1 2008/11/04 19:32:17 pva Exp $
inherit eutils flag-o-matic multilib perl-module
@@ -10,34 +10,40 @@ SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="doc perl python ruby rrdcgi tcl"
-# This versions are minimal versions upstream tested with.
-RDEPEND="
- >=media-libs/libpng-1.2.10
- >=dev-libs/libxml2-2.6.31
- >=x11-libs/cairo-1.4.6
- >=dev-libs/glib-2.12.12
- >=x11-libs/pango-1.17
- tcl? ( dev-lang/tcl )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- ruby? ( dev-lang/ruby
- !dev-ruby/ruby-rrd )"
+RDEPEND="tcl? ( dev-lang/tcl )
+ >=sys-libs/zlib-1.2.1
+ >=media-libs/freetype-2.1.5
+ >=media-libs/libart_lgpl-2.3.16
+ >=media-libs/libpng-1.2.5
+ rrdcgi? ( >=dev-libs/cgilib-0.5 )
+ ruby? ( !dev-ruby/ruby-rrd )"
DEPEND="${RDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( dev-lang/ruby )
sys-apps/gawk"
+TCLVER=""
+
+HTMLDOC_DIR="${PF}/html"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.2.15-newstyle-resize.patch"
+ epatch "${FILESDIR}/${P}-revert-font-fix.patch"
+}
+
pkg_setup() {
- if ! built_with_use x11-libs/cairo svg; then
- eerror "${PN} requires x11-libs/cairo to be built with svg USE flag."
- die "Rebuild x11-libs/cairo with svg USE flag enabled."
- fi
use perl && perl-module_pkg_setup
}
src_compile() {
+ filter-mfpmath sse
filter-flags -ffast-math
export RRDDOCDIR=/usr/share/doc/${PF}
@@ -49,7 +55,7 @@ src_compile() {
$(use_enable perl perl-site-install) \
$(use_enable tcl) \
$(use_with tcl tcllib /usr/$(get_libdir)) \
- $(use_enable python)
+ $(use_enable python) || die "econf failed."
emake || die "make failed"
}
@@ -72,13 +78,6 @@ pkg_preinst() {
pkg_postinst() {
use perl && perl-module_pkg_postinst
- ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
- ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
- ewarn "causes older versions of rrdtool restore to be unhappy."
- ewarn
- ewarn "To restore a new dump with ann old rrdtool restore version, either remove"
- ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
- ewarn "or use rrdtool dump --no-header."
}
pkg_prerm() {