summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-08-07 01:14:03 +0000
committerJeroen Roovers <jer@gentoo.org>2012-08-07 01:14:03 +0000
commit627f5340b0a6fa141836155d5ecf2a990c13ad3c (patch)
tree8c1ab29af55bd5c63cb9cb68974272d06ded89f1 /net-analyzer
parentkeyword amd64-linux, x86-linux (diff)
downloadgentoo-2-627f5340b0a6fa141836155d5ecf2a990c13ad3c.tar.gz
gentoo-2-627f5340b0a6fa141836155d5ecf2a990c13ad3c.tar.bz2
gentoo-2-627f5340b0a6fa141836155d5ecf2a990c13ad3c.zip
Do not inject -L$prefix/lib into LDFLAGS (bug #394479).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog6
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.8.1-394479.patch12
-rw-r--r--net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild11
3 files changed, 25 insertions, 4 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 6cf694b1828f..c9c48e8c06a4 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.371 2012/08/06 09:41:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.372 2012/08/07 01:14:03 jer Exp $
+
+ 07 Aug 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.8.1-r1.ebuild,
+ +files/wireshark-1.8.1-394479.patch:
+ Do not inject -L$prefix/lib into LDFLAGS (bug #394479).
06 Aug 2012; Jeroen Roovers <jer@gentoo.org> wireshark-1.8.1-r1.ebuild:
Add --disable-usr-local to econf.
diff --git a/net-analyzer/wireshark/files/wireshark-1.8.1-394479.patch b/net-analyzer/wireshark/files/wireshark-1.8.1-394479.patch
new file mode 100644
index 000000000000..91d27e57f9d8
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.8.1-394479.patch
@@ -0,0 +1,12 @@
+--- a/configure.in
++++ b/configure.in
+@@ -652,7 +652,8 @@
+ #
+ # Arrange that we search for libraries in "$prefix/lib".
+ #
+- AC_WIRESHARK_ADD_DASH_L(LDFLAGS, $prefix/lib)
++# We do not need this - JeR (possibly bug #394479)
++# AC_WIRESHARK_ADD_DASH_L(LDFLAGS, $prefix/lib)
+ else
+ AC_MSG_RESULT(no)
+ fi
diff --git a/net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild b/net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild
index c56984f9402b..37e1b50888f9 100644
--- a/net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild,v 1.3 2012/08/06 09:41:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.8.1-r1.ebuild,v 1.4 2012/08/07 01:14:03 jer Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
-inherit eutils flag-o-matic python toolchain-funcs user
+inherit autotools eutils flag-o-matic python toolchain-funcs user
[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && MY_P=${PN}-${PV/_} || MY_P=${P}
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-apps/sed
sys-devel/flex
- !!<net-analyzer/wireshark-1.8.0"
+"
S=${WORKDIR}/${MY_P}
@@ -102,6 +102,11 @@ pkg_setup() {
enewgroup wireshark
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-394479.patch
+ eautoreconf
+}
+
src_configure() {
local myconf