summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-24 07:45:41 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-24 07:45:41 +0000
commit565fd4c0ccda97229c24af7ade13e403baf51ebb (patch)
tree7c10e4958ef4f62f58f154c7b8da59fc20c17717 /net-analyzer
parentStable for amd64, wrt bug #417343 (diff)
downloadgentoo-2-565fd4c0ccda97229c24af7ade13e403baf51ebb.tar.gz
gentoo-2-565fd4c0ccda97229c24af7ade13e403baf51ebb.tar.bz2
gentoo-2-565fd4c0ccda97229c24af7ade13e403baf51ebb.zip
Initial import (thanks to Ortwin Glueck and sunrise for the initial ebuild, bug 389399)
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcping/ChangeLog11
-rw-r--r--net-analyzer/tcping/Manifest4
-rw-r--r--net-analyzer/tcping/metadata.xml8
-rw-r--r--net-analyzer/tcping/tcping-1.3.5.ebuild30
4 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/tcping/ChangeLog b/net-analyzer/tcping/ChangeLog
new file mode 100644
index 000000000000..ec626800c739
--- /dev/null
+++ b/net-analyzer/tcping/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/tcping
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcping/ChangeLog,v 1.1 2012/05/24 07:45:41 xmw Exp $
+
+*tcping-1.3.5 (24 May 2012)
+
+ 24 May 2012; Michael Weber <xmw@gentoo.org> +tcping-1.3.5.ebuild,
+ +metadata.xml:
+ Initial import (thanks to Ortwin Glueck and sunrise for the initial ebuild,
+ bug 389399)
+
diff --git a/net-analyzer/tcping/Manifest b/net-analyzer/tcping/Manifest
new file mode 100644
index 000000000000..60bfa362d89a
--- /dev/null
+++ b/net-analyzer/tcping/Manifest
@@ -0,0 +1,4 @@
+DIST tcping-1.3.5.tar.gz 5889 RMD160 918638a346201ccce31c67bdaa01c599135bcd66 SHA1 ecc5fe7fb2f8e86a1fc2d09651310b26fa922c7b SHA256 1ad52e904094d12b225ac4a0bc75297555e931c11a1501445faa548ff5ecdbd0
+EBUILD tcping-1.3.5.ebuild 603 RMD160 0d36b975f04867af2529ccc7f1113af720f7e130 SHA1 60c58a69ab915394d39178b6940351dc7dc18184 SHA256 603d71913dcf2e363eb052ad3cef5d83176afc9e4636ea4b6aeff43548c6d727
+MISC ChangeLog 327 RMD160 0944fe86195160add0b7e5eb9f7fae2f6812333d SHA1 cfa73334cbcdabb16722faa104803f0bb780591b SHA256 240ab17b2ce6fa6f5417cea6f494d6a2d8bf9c7b0e2fbc06db557053b525b8aa
+MISC metadata.xml 225 RMD160 982914e2305e9ebb7394d6fceb66585bd5c1930f SHA1 8355c19032eebada6ac6208bc6ecc948893b3608 SHA256 4fe82023835a361f6a28b205c212aacfbf277f63806275b5de2d07d2cfe83fb3
diff --git a/net-analyzer/tcping/metadata.xml b/net-analyzer/tcping/metadata.xml
new file mode 100644
index 000000000000..0f350e3d4d81
--- /dev/null
+++ b/net-analyzer/tcping/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/tcping/tcping-1.3.5.ebuild b/net-analyzer/tcping/tcping-1.3.5.ebuild
new file mode 100644
index 000000000000..fa771a9eaf73
--- /dev/null
+++ b/net-analyzer/tcping/tcping-1.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcping/tcping-1.3.5.ebuild,v 1.1 2012/05/24 07:45:41 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ping implementation that uses the TCP protocol"
+HOMEPAGE="http://www.linuxco.de/tcping/tcping.html"
+SRC_URI="http://www.linuxco.de/tcping/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}